Subject: [ietf-dkim] Conspicuously absent statistics

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 25 Oct 2010 11:44:57 -0700

Well, actually, not so conspicuous since nobody pointed it out yet...

Our stats stuff is reporting absolutely nothing so far about use of "i=".

I just posted a patch release that includes some code to start collecting this, and one of our sites has already rolled it out.  After we've had some time to collect some numbers, I'll provide some information about what we're seeing in the wild with respect to use of "i=".

_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 25 Oct 2010 22:34:54 -0700

One day of statistics (7 hosts from 3 sites reporting so far) reveals:

4911 signatures contained no i= tag
3832 signatures (43.8%) had i= tags
1247 distinct d= domains were found in signatures that contained "i=" tags
1580 (41.2%) had an i= domain that matched d= and had an empty local-part
1650 (43.1%) had an i= domain that matched d= and had a local-part matching the one in From:
4 (0.1%) had an i= domain that matched d= and had a local-part different from the one in From:
467 (12.2%) had an i= domain that was a subdomain of d= and had an empty local-part
None had an i= domain that was a subdomain of d= and had a local-part matching the one in From:
122 (3.2%) had an i= domain that was a subdomain of d= and had a local-part different from the one in From:

I'll let this accumulate for a while and then add it to the interoperability report.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Murray S. Kucherawy
Sent: Monday, October 25, 2010 11:45 AM
To: [email-masked]
Subject: [ietf-dkim] Conspicuously absent statistics