Subject: [Ietf-hub-boston] IETF-Hub-Boston: Next Meetup Thurs Oct 27 4-6pm plus optional dinner

From: Alia Atlas <[email-masked]>
Date: Thu, 13 Oct 2016 15:36:47 -0400

Michael O'Malley at 128 Technology in Burlington has kindly offered to host
this meeting.
The office is at 200 Wheeler Road in Burlington, MA.

What I hear for offers for talks are:

1) David Oran,  Intro to ICN  (location may be an issue)
2) Dan York, Latest happenings in DNS world - particularly around DNS
privacy, DNSSEC, DANE, etc.
3) John Klensin, Internationalization Issues (location may be an issue)
4) Dale Worley, ??Mystery Topic??
5) Ted Lemon, Homenet Naming and DNSSD for homenet
6) Alia Atlas, Hot topics in the Routing Area & IETF Hub Organizing
(separate topics)

If all of those are confirmed, then we can do 15 minutes a piece (10
talking, 5 questions) and have a meeting.

Could those of you whom have offered to do a talk confirm (list or
privately)?
If there are others who are interested in offering a talk now that this is
going ahead, please do speak up.

I'd like to publicize this a bit (BOSNOG, local Systers, Mass High Tech &
NH High Tech Council, other ideas??) and see if we can pull in some folks
who aren't active long-time IETFers too.

I've heard that it might be nice to find a sponsor for some
beverages/snacks, if anyone has an idea there.

There are a number of restaurants around the area; we could try to get a
reservation depending on how many we are or plan on splitting up into
groups of interest.  Someplace like Macaroni Grill or Uno's might work;
other suggestions more than welcome.

I am thinking that - if we have agreement - then we can set up a doodle
poll or a MeetUp with the agenda and details for spreading.

Thanks,
Alia

---

From: David Oran <[email-masked]>
Date: Thu, 13 Oct 2016 15:49:09 -0400

> On Oct 13, 2016, at 3:36 PM, Alia Atlas <[email-masked]> wrote:
> 
> Michael O'Malley at 128 Technology in Burlington has kindly offered to host this meeting.
not a problem - I have a car.

> 2) Dan York, Latest happenings in DNS world - particularly around DNS privacy, DNSSEC, DANE, etc.
> 6) Alia Atlas, Hot topics in the Routing Area & IETF Hub Organizing (separate topics)
> 
> If all of those are confirmed, then we can do 15 minutes a piece (10 talking, 5 questions) and have a meeting.
I can’t do even the most minimal ICN intro in 15 minutes + questions. Pick some of the other ones unless you want a longer talk (e.g. 30-40 mins).

> 
> Could those of you whom have offered to do a talk confirm (list or privately)?
> If there are others who are interested in offering a talk now that this is going ahead, please do speak up. 
> 
> I'd like to publicize this a bit (BOSNOG, local Systers, Mass High Tech & NH High Tech Council, other ideas??) and see if we can pull in some folks who aren't active long-time IETFers too.
> 
> I've heard that it might be nice to find a sponsor for some beverages/snacks, if anyone has an idea there.
> 
> There are a number of restaurants around the area; we could try to get a reservation depending on how many we are or plan on splitting up into groups of interest.  Someplace like Macaroni Grill or Uno's might work; other suggestions more than welcome.
> 
I'm up for dinner afterward.
As I recall Cafe Escadrille is an old standard nearby. Also Legal in the mall, and the new Mexican place, Besito’s menu looked good (haven’t eaten there)

> I am thinking that - if we have agreement - then we can set up a doodle poll or a MeetUp with the agenda and details for spreading.
> 
> Thanks,
> Alia
> _______________________________________________
> Ietf-hub-boston mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-hub-boston

---

From: Aanchal Malhotra <[email-masked]>
Date: Thu, 13 Oct 2016 15:56:00 -0400

Hi All,

I have been working on Network Time Protocol (NTP) security. I will be
attending IETF 97 at Seoul, where I present a draft on the recommendations
for Message Authentication Code (MAC) algorithms to be used in NTP to the
NTP working group.

I have submitted a draft and will be updating it soon. It would be good to
present it to people at this ietf meet up and have their feedback on the
same.  A 15-minute talk works fine for me.

Thanks,
Aanchal Malhotra.

On Thu, Oct 13, 2016 at 3:49 PM, David Oran <[email-masked]> wrote:

> I can’t do even the most minimal ICN intro in 15 minutes + questions. Pick
> some of the other ones unless you want a longer talk (e.g. 30-40 mins).
>
> >
> > I'd like to publicize this a bit (BOSNOG, local Systers, Mass High Tech
> & NH High Tech Council, other ideas??) and see if we can pull in some folks
> As I recall Cafe Escadrille is an old standard nearby. Also Legal in the
> mall, and the new Mexican place, Besito’s menu looked good (haven’t eaten
> there)
>

---

From: Alia Atlas <[email-masked]>
Date: Thu, 13 Oct 2016 16:12:25 -0400

Hi Aanchal,

That sounds like a helpful idea and one of the things I'm thinking sessions
like this might be useful for.
Let me poke at the schedule a bit; I think we may need to end up splitting
into a couple meetings for technical
talks.

Regards,
Alia

On Thu, Oct 13, 2016 at 3:56 PM, Aanchal Malhotra <[email-masked]> wrote:

>> I can’t do even the most minimal ICN intro in 15 minutes + questions.
>> Pick some of the other ones unless you want a longer talk (e.g. 30-40 mins).
>>
>> >
>> > There are a number of restaurants around the area; we could try to get
>> a reservation depending on how many we are or plan on splitting up into

---

From: Ethan Banks <[email-masked]>
Date: Thu, 13 Oct 2016 16:20:09 -0400

Happy to publicize a MeetUp (or whatever) page to BOSNOG once this is
decided.

*/Ethan*

From: Alia Atlas <[email-masked]> <[email-masked]>
Reply: Alia Atlas <[email-masked]> <[email-masked]>
Date: October 13, 2016 at 3:36:54 PM
To: [email-masked] <[email-masked]>
<[email-masked]>
Cc: Thomas D. Nadeau <[email-masked]> <[email-masked]>, Mike
O'Malley <[email-masked]> <[email-masked]>, Kathleen
Moriarty <[email-masked]>
<[email-masked]>
Subject:  [Ietf-hub-boston] IETF-Hub-Boston: Next Meetup Thurs Oct 27 4-6pm
plus optional dinner

Thanks,
Alia

---

From: John C Klensin <[email-masked]>
Date: Thu, 13 Oct 2016 16:25:35 -0400

> 3) John Klensin, Internationalization Issues (location may be

Location should be manageable (probably can drive; certainly can
make it to Alewife).  Date still a little marginal, but should
work.  

> If all of those are confirmed, then we can do 15 minutes a
> piece (10 talking, 5 questions) and have a meeting.
> 

I have a little bit of the same problem Dave does.  I might be
able to give some examples of the issues and why people should
care in 10 minutes.  If I am in a bad mood, it would involve
reading from several creation myths about language diversity,
probably starting with the Tower of Babel one, and substituting
"writing system and language" for just "language".  I'm also not
sure how much I can do without visuals, so I would need to know
whether a projector would be available or how many handouts I
need to bring.

> If there are others who are interested in offering a talk now
> that this is going ahead, please do speak up.
> 
> I'd like to publicize this a bit (BOSNOG, local Systers, Mass
> High Tech & NH High Tech Council, other ideas??) and see if we
> can pull in some folks who aren't active long-time IETFers too.

Ok, but not that a 4PM start is likely to be fairly bad for a
lot of those groups, especially the last two.

>...
> There are a number of restaurants around the area; we could
> try to get a reservation depending on how many we are or plan
> on splitting up into groups of interest.  Someplace like
> Macaroni Grill or Uno's might work; other suggestions more
> than welcome.

I'd like to see something a bit up the "decent food" ladder from
those two.  Even some of the places in the Mall food court would
meet that description although it is hard to find a good place
to talk there.  Dave's suggestions are reasonable (I haven't
tried Besito's and, having grown up slightly more than an hour
from the border, have learned to be very skeptical about
Boston-area supposedly-Mexican restaurants, but their menu
doesn't exhibit any of the standard warning signs, so I'm
willing to try.  I've also heard positive things about Del
Frisco's Grille, although I haven't eaten there either.
 
best,
    john

---

From: Alia Atlas <[email-masked]>
Date: Thu, 13 Oct 2016 16:51:46 -0400

Hi John,

> whether a projector would be available or how many handouts I

Ok - I'll work on pulling together something better.  I think we're heading
towards 2 meetings (which is great) with 1 45 minute talk and then a set of
4-5 more 15 minute talks.  Because this is the meeting before IETF, I would
prefer to prioritize folks looking to get opinions on new drafts or updates
that
are going to be talked about there (such as Aanchal's request).

> lot of those groups, especially the last two.

Well, we've got a plan, place, and host for this meeting.  Let's see what
times might be better for broader participation for next time.

> Frisco's Grille, although I haven't eaten there either.

I would be beyond delighted to have someone with more foody tendencies
to pick a place.  I've spent the last 10 years optimizing for places that I
could
bring small children :-)

Regards,
Alia

---

From: Alia Atlas <[email-masked]>
Date: Thu, 13 Oct 2016 17:05:26 -0400

Revised plan:

How does this sound?  Please send more accurate/detailed titles so that we
can put this up and advertise it.
Please invite folks.

1) David Oran, Intro to ICN    4 - 4:45pm
2) Ted Lemon, Homenet Naming and DNSSD for homenet 4:45 - 5:05
3) Aanchal Malhotra, Message Authentication Code Algorithms for NTP  5:05 -
5:20
4) Dan York, Latest Happenings in DNS world, 5:20 - 5:35
5) Alia Atlas, IETF Boston Hub Organizing, 5:35 - 6pm

For the second meeting (in late Nov or early Dec), we'll have:

1) John Klensin, Internationalization Issues  45 minutes
2) Dale Worley, ??Mystery Topic??,  15 minutes
3) Alia Atlas, Hot Topics in the Routing Area,  15 minutes
4) unbooked 15 minutes
5) unbooked  15 minutes

Michael says that 128 Technology can also sponsor refreshments.  Their cafe
can hold more than 50 (and apparently
has beer).

Thanks,
Alia

On Thu, Oct 13, 2016 at 4:51 PM, Alia Atlas <[email-masked]> wrote:

> prefer to prioritize folks looking to get opinions on new drafts or
> updates that
> to pick a place.  I've spent the last 10 years optimizing for places that
> I could
> bring small children :-)
>
> Regards,
> Alia
>
>
>> best,
>>     john
>>
>>
>>
>

---

From: [email-masked]
Date: Thu, 13 Oct 2016 17:11:28 -0400

Please excuse typos, sent from handheld device 

> On Oct 13, 2016, at 4:12 PM, Alia Atlas <[email-masked]> wrote:
> 
> Hi Aanchal,
> 
> That sounds like a helpful idea and one of the things I'm thinking sessions like this might be useful for.
> Let me poke at the schedule a bit; I think we may need to end up splitting into a couple meetings for technical
> talks.

This could be useful.  Has there been discussion on the draft?  I'd like to see that first.

Thanks,
Kathleen 
>> I have been working on Network Time Protocol (NTP) security. I will be attending IETF 97 at Seoul, where I present a draft on the recommendations for Message Authentication Code (MAC) algorithms to be used in NTP to the NTP working group.
>> 
>> I have submitted a draft and will be updating it soon. It would be good to present it to people at this ietf meet up and have their feedback on the same.  A 15-minute talk works fine for me. 
>> 
>> Thanks,
>> Aanchal Malhotra.
>>

---

From: Aanchal Malhotra <[email-masked]>
Date: Thu, 13 Oct 2016 17:25:49 -0400

On Thu, Oct 13, 2016 at 5:11 PM, <[email-masked]> wrote:

> Hi Kathleen,

I don't believe there was any discussion on mailing lists about the draft.
But I presented the draft at Berlin IETF. It was half-baked then. Now we
have the latest version.
Also, we are hosting Network Time Security (NTS) design team face-to-face
meeting tomorrow at Boston University. I will be discussing this draft
tomorrow. For now it is pretty NTP specific, but we aim to turn it into a
general MAC recommendation (or at least the one that can be used for other
time protocols like PTP, etc.) draft eventually.

Here is the latest submission.

URL:            https://www.ietf.org/internet-drafts/draft-aanchal4-ntp-mac-
02.txt
Status:         https://datatracker.ietf.org/doc/draft-aanchal4-ntp-mac/
Htmlized:       https://tools.ietf.org/html/draft-aanchal4-ntp-mac-02

Aanchal.

>> I have submitted a draft and will be updating it soon. It would be good
>> to present it to people at this ietf meet up and have their feedback on the
>>> > I'd like to publicize this a bit (BOSNOG, local Systers, Mass High
>>> Tech & NH High Tech Council, other ideas??) and see if we can pull in some
>>> folks who aren't active long-time IETFers too.
>>> >
>>> > I am thinking that - if we have agreement - then we can set up a
>>> doodle poll or a MeetUp with the agenda and details for spreading.
>>> >
>>> > Thanks,
>>> > Alia

---

From: John C Klensin <[email-masked]>
Date: Thu, 13 Oct 2016 18:35:00 -0400

Alia,

WFM, but note two things fwiw.

(1) There is something on Jari's "New Work in Seoul" BOF list
called "DNSBUNDLED".  It, at least in the mind of the
first-listed author of the draft Jari cited
(draft-yao-bundled-name-problem-statement-02), very much an i18n
topics.  I assume being on that list is enough to qualify the
topic as relevant to IETF 97.   The topic is closely related to
the micro-conversation we had at Sugar Shack about what can and
cannot be done with/in a simple tree.  There is also a good deal
of activity in ICANN that interacts with IETF work, notable
efforts to restrict non-root domains to a standard (!)
connection of characters much smaller than that allowed by
IDNA2008 (RFCs 5890ff).  I don't know what Dan is planning to
cover, but I wouldn't try to do even the parts I know about in
10 minutes.

(2) While I'm trying to avoid it, I fear there is a trip to
Guadalajara in my future for the first week in December (IGF for
those of you lucky enough to entirely avoid such things).  If I
do go, I'm likely to have to head out early.  So "late Nov or
early Dec" is likely to be overconstrained for me.

best,
   john

--On Thursday, October 13, 2016 17:05 -0400 Alia Atlas
<[email-masked]> wrote:

> Revised plan:
> 
> How does this sound?  Please send more accurate/detailed
> titles so that we can put this up and advertise it.
> Please invite folks.
> 
> 3) Aanchal Malhotra, Message Authentication Code Algorithms
> for NTP  5:05 - 5:20
> Michael says that 128 Technology can also sponsor
> refreshments.  Their cafe can hold more than 50 (and apparently
> has beer).

---

From: Alia Atlas <[email-masked]>
Date: Thu, 13 Oct 2016 20:44:16 -0400

John,

> cover, but I wouldn't try to do even the parts I know about in

Ok - it sounds like you feel that your talk is timely when combined with
the
DNSBUNDLED BoF.  Unless I hear that Dave Oran feels that timing is important
for his ICN talk, let's plan on swapping them then.

Is 45 minutes sufficient for your talk, including questions?

> early Dec" is likely to be overconstrained for me.

Which is another reason to do it for this meeting.

---

From: David Oran <[email-masked]>
Date: Thu, 13 Oct 2016 20:50:14 -0400

> On Oct 13, 2016, at 8:44 PM, Alia Atlas <[email-masked]> wrote:
> 
> John,
> 
> Ok - it sounds like you feel that your talk is timely when combined with the 
Not a problem for me - I should be around until the holidays having the other talks first is no problem.

---

From: Kathleen Moriarty <[email-masked]>
Date: Thu, 13 Oct 2016 21:25:07 -0400

On Thu, Oct 13, 2016 at 5:25 PM, Aanchal Malhotra <[email-masked]> wrote:

>> Let me poke at the schedule a bit; I think we may need to end up
>> splitting into a couple meetings for technical
>> talks.
>>
>>
> URL:            https://www.ietf.org/internet-
> drafts/draft-aanchal4-ntp-mac-02.txt
Thank you for your work in this space!  I have to catch up on the NTP list
as I haven't been following it, but know securing it is of interest and
there may be other solutions int he works, but I'm not up-to-date, hence my
interest in seeing list discussion as well as your presentation.  I hope I
can make it to this event.

Kathleen

Aanchal.
>>>> > There are a number of restaurants around the area; we could try to
>>>> get a reservation depending on how many we are or plan on splitting up into
>>>> As I recall Cafe Escadrille is an old standard nearby. Also Legal in
>>>> the mall, and the new Mexican place, Besito’s menu looked good (haven’t
>>>> eaten there)
>>>>

-- 

Best regards,
Kathleen