Subject: [Ietf-hub-boston] Future meeting schedule

From: [email-masked] (Dale R. Worley)
Date: Sun, 03 Nov 2019 19:18:34 -0500

What with the IETF meeting nearly upon us, it's a little early to
schedule the next Hub meeting.  But I've been thinking of principles to
get a regular meeting cycle going.  So far, I've come up with:

- three meetings a year, equidistant from the IETF meetings, i.e.,
  mid-January, mid-May, and Mid-September  (Probably put the mid-Jan
  meeting *after* MLK Day.)

- rotating among the three high-tech zones in metro Boston:  Kendall
  Square, Route 128 NW, and Route 495 NW (Are there other zones I've
  missed?)

- rotating among the three days of the week that seem to be the easiest
  for people:  Tuesday, Wednesday, and Thursday

The rotations help prevent people from being locked out if they have a
rigid commitment on a particular day of the week, or find one of the
zones inaccessible.

I think it's also important to get the dates of the meetings fixed well
in advance, as people can then construct the rest of their calendar
around the Hub meeting, rather than trying to put the Hub meeting among
scheduled things.  People seem better at dynamically adjusting where
they commute to than dynamically adjusting when events are.

Comments?

Dale

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 4 Nov 2019 09:36:51 -0500

Dale,

Sounds good to me.

Cheers,
Andy

On Sun, Nov 3, 2019 at 7:18 PM Dale R. Worley <[email-masked]> wrote:

> _______________________________________________
> Ietf-hub-boston mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-hub-boston
>

---

From: Ted Lemon <[email-masked]>
Date: Mon, 4 Nov 2019 16:02:42 +0100

It might be good to answer the question ”why are we meeting“ first.   Otherwise it’s hard to know if this is the right amount. 

For my part, I’m actually more interested in low effort frequent meetings that not everyone gets to than high effort infrequent meetings that.. not everyone gets to. I’m not claiming that’s right, just sharing my impression. 

> On Nov 4, 2019, at 15:37, Andrew G. Malis <[email-masked]> wrote:
> 
> 
> Dale,
> 
> Sounds good to me.
> 
> Cheers,
> Andy
> 
>

---

From: Kyle Rose <[email-masked]>
Date: Mon, 4 Nov 2019 13:33:24 -0500

I agree, mostly because I think we benefit greatly from informal
discussion. The hour and a half we spent talking about the IETF leadership
at the last meeting was eye-opening, and IMO would have been even better
with more folks in attendance sharing their perspectives.

On Mon, Nov 4, 2019 at 10:03 AM Ted Lemon <[email-masked]> wrote:

> It might be good to answer the question ”why are we meeting“ first.
> Otherwise it’s hard to know if this is the right amount.
>
> For my part, I’m actually more interested in low effort frequent meetings
> that not everyone gets to than high effort infrequent meetings that.. not
> everyone gets to. I’m not claiming that’s right, just sharing my
> impression.
>

---

From: Dave Lawrence <[email-masked]>
Date: Mon, 4 Nov 2019 14:39:45 -0500

Kyle Rose writes:
> The hour and a half we spent talking about the IETF leadership at
> the last meeting was eye-opening,

Well now I'm really curious.

---

From: Kyle Rose <[email-masked]>
Date: Mon, 4 Nov 2019 13:50:01 -0500

Lest this go off the rails, let me be clear: by "talking about the IETF
leadership" I don't mean we spent the time gossiping about individuals. It
was more about how the very structure of the leadership (for instance, the
modern relationship of the IESG to the IAB) influences decision-making,
outcomes, and even (in my interpretation at least) the Overton window of
publicly-acceptable viewpoints.

---

From: Dave Lawrence <[email-masked]>
Date: Mon, 4 Nov 2019 15:05:27 -0500

Kyle Rose writes:
> Lest this go off the rails, let me be clear: by "talking about the
> IETF leadership" I don't mean we spent the time gossiping about 
> individuals. 

Well that's good.  I hadn't figured it was that way, though I can see
how some might have taken the "eye-opening" remark in that vein.

> It was more about how the very structure of the leadership (for
> instance, the modern relationship of the IESG to the IAB) influences
> decision-making, outcomes, and even (in my interpretation at least)
> the Overton window of publicly-acceptable viewpoints.

I'm still really interested in this.

---

From: John C Klensin <[email-masked]>
Date: Tue, 05 Nov 2019 01:53:16 -0500

Ted,

--On Monday, November 4, 2019 16:02 +0100 Ted Lemon
<[email-masked]> wrote:

> It might be good to answer the question "why are we
> meeting" first.   Otherwise it's hard to know if this is
> the right amount. 

I would agree except that I fear that reaching anything
resembling consensus on that subject might lead to long email
threads and prevent us from meeting again, ever.  My guess is
that different of us have different reasons.  For a relative
newcomer, it might be an opportunity to meet and talk informally
with some of us who have been around forever plus or minus a few
years.  For some of us old fossils, it may be the opportunity to
hear about work that is interesting but out of whatever silos we
have fallen (or been pushed) into and to meet the people who are
doing that work.  There are obviously other reasons too, but
those mean scheduling is more important than topics.   In my
case, it also makes it really unfortunate that I wasn't able to
go out to dinner with people after the last time but I had been
back from China for less than a week and I still wasn't
recovered.

I can imagine many reasons for missing one of these things, but
the particular content of the planned presentations or
discussions isn't on the list.   Others almost certainly feel
differently.

> For my part, I'm actually more interested in low effort
> frequent meetings that not everyone gets to than high effort
> infrequent meetings that.. not everyone gets to. I'm not
> claiming that's right, just sharing my impression. 

I have trouble speaking to levels of effort, but I agree that
there are good arguments for somewhat higher frequency if it
were possible to organize that.  At the same time, most of us
are ridiculously busy, so it may not actually be possible.  For
that reason, Dale's suggestion seems good to me; if we can get
that stabilized, it could be a starting point for doing it more
frequently.

best,
   john

>> On Nov 4, 2019, at 15:37, Andrew G. Malis <[email-masked]>
ഀ਀㸀㸀 䐀愀氀攀Ⰰഀ਀㸀㸀 ഀ਀㸀㸀 匀漀甀渀搀猀 最漀漀搀 琀漀 洀攀⸀ഀ਀㸀㸀 ഀ਀㸀㸀 䌀栀攀攀爀猀Ⰰഀ਀㸀㸀 䄀渀搀礀ഀ਀㸀㸀 ഀ਀㸀㸀 ഀ਀㸀㸀㸀 伀渀 匀甀渀Ⰰ 一漀瘀 ㌀Ⰰ ㈀　㄀㤀 愀琀 㜀㨀㄀㠀 倀䴀 䐀愀氀攀 刀⸀ 圀漀爀氀攀礀ഀ਀㸀㸀㸀 㰀眀漀爀氀攀礀䀀愀爀椀愀搀渀攀⸀挀漀洀㸀 眀爀漀琀攀㨀 圀栀愀琀 眀�
�琀栀 琀栀攀 䤀䔀吀䘀 洀攀攀琀椀渀最ഀ਀㸀㸀㸀 渀攀愀爀氀礀 甀瀀漀渀 甀猀Ⰰ 椀琀✀猀 愀 氀椀琀琀氀攀 攀愀爀氀礀 琀漀 猀挀栀攀搀甀氀攀 琀栀攀 渀攀砀琀 䠀甀戀ഀ਀㸀㸀㸀 洀攀攀琀椀渀最⸀  䈀甀琀 䤀✀瘀攀 戀攀攀渀 琀栀椀渀欀椀渀最 漀昀 瀀爀椀渀挀椀瀀氀攀猀 琀漀 最攀琀 愀ഀ਀㸀㸀㸀 爀攀最甀氀愀爀 洀攀攀琀椀渀�
�� 挀礀挀氀攀 最漀椀渀最⸀  匀漀 昀愀爀Ⰰ 䤀✀瘀攀 挀漀洀攀 甀瀀 眀椀琀栀㨀ഀ਀㸀㸀㸀 ഀ਀㸀㸀㸀 ⴀ 琀栀爀攀攀 洀攀攀琀椀渀最猀 愀 礀攀愀爀Ⰰ 攀焀甀椀搀椀猀琀愀渀琀 昀爀漀洀 琀栀攀 䤀䔀吀䘀 洀攀攀琀椀渀最猀Ⰰഀ਀㸀㸀㸀 椀⸀攀⸀Ⰰ 洀椀搀ⴀ䨀愀渀甀愀爀礀Ⰰ 洀椀搀ⴀ䴀愀礀Ⰰ 愀渀搀 䴀椀搀ⴀ匀攀瀀琀攀洀戀攀爀  
⠀倀爀漀戀愀戀氀礀 瀀甀琀ഀ਀㸀㸀㸀   琀栀攀 洀椀搀ⴀ䨀愀渀 洀攀攀琀椀渀最 ⨀愀昀琀攀爀⨀ 䴀䰀䬀 䐀愀礀⸀⤀ഀ਀㸀㸀㸀 ഀ਀㸀㸀㸀 ⴀ 爀漀琀愀琀椀渀最 愀洀漀渀最 琀栀攀 琀栀爀攀攀 栀椀最栀ⴀ琀攀挀栀 稀漀渀攀猀 椀渀 洀攀琀爀漀 䈀漀猀琀漀渀㨀ഀ਀㸀㸀㸀 䬀攀渀搀愀氀氀 匀焀甀愀爀攀Ⰰ 刀漀甀琀攀 ㄀㈀㠀 一圀Ⰰ 愀�
�搀 刀漀甀琀攀 㐀㤀㔀 一圀 ⠀䄀爀攀 琀栀攀爀攀ഀ਀㸀㸀㸀   漀琀栀攀爀 稀漀渀攀猀 䤀✀瘀攀 洀椀猀猀攀搀㼀⤀ഀ਀㸀㸀㸀 ഀ਀㸀㸀㸀 ⴀ 爀漀琀愀琀椀渀最 愀洀漀渀最 琀栀攀 琀栀爀攀攀 搀愀礀猀 漀昀 琀栀攀 眀攀攀欀 琀栀愀琀 猀攀攀洀 琀漀 戀攀ഀ਀㸀㸀㸀 琀栀攀 攀愀猀椀攀猀琀 昀漀爀 瀀攀漀瀀氀攀㨀  吀甀攀猀搀愀�
��Ⰰ 圀攀搀渀攀猀搀愀礀Ⰰ 愀渀搀 吀栀甀爀猀搀愀礀ഀ਀㸀㸀㸀 ഀ਀㸀㸀㸀 吀栀攀 爀漀琀愀琀椀漀渀猀 栀攀氀瀀 瀀爀攀瘀攀渀琀 瀀攀漀瀀氀攀 昀爀漀洀 戀攀椀渀最 氀漀挀欀攀搀 漀甀琀 椀昀ഀ਀㸀㸀㸀 琀栀攀礀 栀愀瘀攀 愀 爀椀最椀搀 挀漀洀洀椀琀洀攀渀琀 漀渀 愀 瀀愀爀琀椀挀甀氀愀爀 搀愀礀 漀昀 琀栀攀ഀ਀㸀㸀㸀 眀攀攀欀
Ⰰ 漀爀 昀椀渀搀 漀渀攀 漀昀 琀栀攀 稀漀渀攀猀 椀渀愀挀挀攀猀猀椀戀氀攀⸀ഀ਀㸀㸀㸀 ഀ਀㸀㸀㸀 䤀 琀栀椀渀欀 椀琀✀猀 愀氀猀漀 椀洀瀀漀爀琀愀渀琀 琀漀 最攀琀 琀栀攀 搀愀琀攀猀 漀昀 琀栀攀 洀攀攀琀椀渀最猀ഀ਀㸀㸀㸀 昀椀砀攀搀 眀攀氀氀 椀渀 愀搀瘀愀渀挀攀Ⰰ 愀猀 瀀攀漀瀀氀攀 挀愀渀 琀栀攀渀 挀漀渀猀琀爀�
�挀琀 琀栀攀 爀攀猀琀ഀ਀㸀㸀㸀 漀昀 琀栀攀椀爀 挀愀氀攀渀搀愀爀 愀爀漀甀渀搀 琀栀攀 䠀甀戀 洀攀攀琀椀渀最Ⰰ 爀愀琀栀攀爀 琀栀愀渀 琀爀礀椀渀最ഀ਀㸀㸀㸀 琀漀 瀀甀琀 琀栀攀 䠀甀戀 洀攀攀琀椀渀最 愀洀漀渀最 猀挀栀攀搀甀氀攀搀 琀栀椀渀最猀⸀  倀攀漀瀀氀攀 猀攀攀洀ഀ਀㸀㸀㸀 戀攀琀琀攀爀 愀琀 搀礀渀愀洀椀挀愀�
��氀礀 愀搀樀甀猀琀椀渀最 眀栀攀爀攀 琀栀攀礀 挀漀洀洀甀琀攀 琀漀 琀栀愀渀ഀ਀㸀㸀㸀 搀礀渀愀洀椀挀愀氀氀礀 愀搀樀甀猀琀椀渀最 眀栀攀渀 攀瘀攀渀琀猀 愀爀攀⸀ഀ਀㸀㸀㸀 ഀ਀㸀㸀㸀 䌀漀洀洀攀渀琀猀㼀ഀ਀㸀㸀㸀 ഀ਀㸀㸀㸀 䐀愀氀攀ഀ਀㸀㸀㸀 ഀ਀㸀㸀㸀 开开开开开开开开开开开开开开开开开开开开开开开开开开开开开开开开开开
开开开开开开开开开开开开开ഀ਀㸀㸀㸀 䤀攀琀昀ⴀ栀甀戀ⴀ戀漀猀琀漀渀 洀愀椀氀椀渀最 氀椀猀琀ഀ਀㸀㸀㸀 䤀攀琀昀ⴀ栀甀戀ⴀ戀漀猀琀漀渀䀀椀攀琀昀⸀漀爀最ഀ਀㸀㸀㸀 栀琀琀瀀猀㨀⼀⼀眀眀眀⸀椀攀琀昀⸀漀爀最⼀洀愀椀氀洀愀渀⼀氀椀猀琀椀渀昀漀⼀椀攀琀昀ⴀ栀甀戀ⴀ戀漀猀琀漀渀ഀ਀㸀㸀 开开开开开开开开开开开开开开开开开开开开开开开开开�
�开开开开开开开开开开开开开开开开开开开开开ഀ਀㸀㸀 䤀攀琀昀ⴀ栀甀戀ⴀ戀漀猀琀漀渀 洀愀椀氀椀渀最 氀椀猀琀ഀ਀㸀㸀 䤀攀琀昀ⴀ栀甀戀ⴀ戀漀猀琀漀渀䀀椀攀琀昀⸀漀爀最ഀ਀㸀㸀 栀琀琀瀀猀㨀⼀⼀眀眀眀⸀椀攀琀昀⸀漀爀最⼀洀愀椀氀洀愀渀⼀氀椀猀琀椀渀昀漀⼀椀攀琀昀ⴀ栀甀戀ⴀ戀漀猀琀漀渀ഀ਀ഀ਀ഀ਀ഀ਀

---

From: John C Klensin <[email-masked]>
Date: Tue, 05 Nov 2019 02:27:26 -0500

Dave,

I started that discussion because I'm very concerned about where
the IETF is headed.  As Kyle said, not to gossip about (or
trash) individuals but because I see some medium and long term
trends that we, as a community, are not handling very well and
may be in denial about.  Part of my concern is that, if those
trends and our [non-]response or arguably inappropriate
responses continue, we could easily find the IETF irrelevant or
worse.  In a way, the leadership is probably a symptom rather
than a cause although, if one wanted to point fingers, some
people have made things better (or slowed the speed at which
problems accumulate), some have made things worse (or
accelerated those trends), and some people have been in one
group on one occasion and a different one in another.

My plan had been to ask permission to record the discussion so
it could be made available later if it turned out to be helpful
(or at least eye-opening or informative) and I brought my trusty
voice recorder with me, but then I spaced it out and didn't
realized I had done so until I was in the elevator on the way
home.  Sorry about that.

Others would probably identify other key themes --it was an
interesting discussion that went in ways I didn't anticipate--
but one was the one Kyle mentioned.  From my point of view, part
of what drove POISED and the reactions to the perception that
the IAB had gotten seriously out of touch with the community was
a desire to identify and make the most obvious and important
changes quickly, get perhaps 80% of the perceived problem(s)
solved, and then more on.  The result of working that way are
almost exactly the same as they would be if we approached
network engineering the same way: one deploys the solution,
things mostly work, but, over time, the number of loose ends
that such a process inevitably leaves come back and cause harm,
whether in the form of insidious bugs, failures of robustness,
inability to adapt to evolution and other changes, and so on.  I
think it is only one important example, but an accidental
consequence of the old model of an IAB in control and spawning
and overseeing various task forces is that the IESG's role was
strictly to manage and steer the IETF.   ADs didn't find
themselves responsible for chartering, overseeing, nurturing,
and generally supporting a WG and its work, only to then have to
turn around and try to support an impartial and broader-scope
evaluation of that work that might result in its rejection.  We
changed that with POISED and the reassignment of final document
review to the IESG, creating that conflict.   All in all, I
think it has been managed astonishingly well (far better than we
had any right to expect) over the years, but, as things get more
specialized (maybe an inevitable result of our working on a 40
or 50 year old technology and its derivatives rather than at a
much earlier stage but YMMD), I think we are seeing more
frequent symptoms of that change being more of a "best thing we
can think of quickly" decision than one that was carefully
thought out with the whole system and possible side-effects
considered.  

I was at a memorial service for Corby Monday afternoon and I
think it was Jack Dennis who made the observation that, while
Computer Science turned into a real academic discipline during
Corby's career, we still haven't gotten there yet with Systems
Engineering and that is a problem.   In a way, that connected to
the concerns about and the IETF hasn't gotten there, or stayed
there for long, either.

Anyway, the discussion was interesting and, at least to me,
helpful, informative, and helped me calibrate some of my
thinking on the subject.  Sorry you missed it.

best,
   john

--On Monday, November 4, 2019 15:05 -0500 Dave Lawrence
<[email-masked]> wrote:

> Kyle Rose writes:
>> Lest this go off the rails, let me be clear: by "talking
>> about the IETF leadership" I don't mean we spent the time
>> gossiping about  individuals. 
> 
> Well that's good.  I hadn't figured it was that way, though I
> can see how some might have taken the "eye-opening" remark in
> that vein.
> 
>> It was more about how the very structure of the leadership
>> (for instance, the modern relationship of the IESG to the
>> IAB) influences decision-making, outcomes, and even (in my
>> interpretation at least) the Overton window of

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 5 Nov 2019 13:00:41 +0000

resembling consensus on that subject might lead to long email
    threads and prevent us from meeting again, ever.  My guess is
    that different of us have different reasons.

Strong +1

---

From: Dave Lawrence <[email-masked]>
Date: Tue, 5 Nov 2019 12:59:56 -0500

> thinking on the subject.  Sorry you missed it.

I do appreciate very much the summary that you gave, thank you.  I
might pick your brain about it more in the near future, especially
depending on the outcome of the current round of nomcom.

---

From: John C Klensin <[email-masked]>
Date: Tue, 05 Nov 2019 12:51:12 -0500

--On Tuesday, November 5, 2019 12:59 -0500 Dave Lawrence
<[email-masked]> wrote:

> I do appreciate very much the summary that you gave, thank
> you.  I might pick your brain about it more in the near
> future, especially depending on the outcome of the current
> round of nomcom.

At your convenience although, depending on that outcome and its
aftermath, further discussion may require lubrication with an
appropriate adult beverage.

For context, although the story is much longer, I've started
looking for options to move internationalization work out of the
IETF --which increasingly seems unable and/or unwilling to do
it, much less do it well-- and into some international forum
with a clear mandate to do the work and the ability to get (and
evaluate) the right expert involvement.  Unless someone comes up
with a better idea (and much of what the IETF has been dropping
the ball on involves issues too far down the stack to be
appropriate for W3C even if they were willing to take it on),
that probably means some combination of UNESCO and ITU.  That
is, to me, terrifying for two reasons.  First, if anyone had
suggested a decade or two ago that I'd be thinking about such a
thing, I would have been more astonished than anyone else.
Second, it would move the IETF one step closer to being
perceived of by some important actors as focusing on some narrow
issues but being increasingly irrelevant to issues that are
important to the global Internet community.

To put it mildly, not good.  But in many respects, just another
symptom of the issues that motivated me to open up the broader
discussion.

best,
   john

---

From: [email-masked] (Dale R. Worley)
Date: Tue, 05 Nov 2019 23:05:22 -0500

Ted Lemon <[email-masked]> writes:
> For my part, I'm actually more interested in low effort frequent
> meetings that not everyone gets to than high effort infrequent
> meetings that.. not everyone gets to. I'm not claiming that's right,
> just sharing my impression.

I'd like to know your definition of "low effort" and "high effort" here.

Dale

---

From: [email-masked] (Dale R. Worley)
Date: Wed, 06 Nov 2019 18:54:04 -0500

For "conference style" meetings, I'm assuming, say, running it from 5 to
7pm, with dinner afterward.  This could be split into 4 30-minute
segments or 6 20-minute segments.  OTOH, we could run it from 5 to 8pm,
and have 6 30-minute segments.

One question is how hard it is to get speakers.  Having never done that
for IETF Hub, I don't know how many people have pent-up discussions to
present.

In regard to effort level, I assume that for most people, most of the
effort is travel and allocating the time.  But maybe the shorter format
of a simple dinner gettogether is much easier for people to schedule.

Opinions?

Dale

---

From: "Dean Bogdanovic" <[email-masked]>
Date: Thu, 07 Nov 2019 08:02:18 +0800

I would suggest shorter time slot (6-8pm) with 4 30 min slots. I’m not 
sure we will be able to regularly fill 6 presentations with speakers. 
Another idea is to get updates what is going on in different areas/WG 
and progress they make. You can’t follow everything in the IETF and 
some interesting work for you might happen in the IETF, but goes 
unnoticed. The IETF Hub meeting might help with raising visibility of 
such topics.

---

From: Ted Lemon <[email-masked]>
Date: Thu, 7 Nov 2019 08:49:11 +0100

FWIW, we’ve had problems with people getting to the facility on time when the start time is as early as six.   Five might actually be easier, if people don’t mind leaving work early, because there will be somewhat less rush-hour traffic on the way to the facility for people who aren’t nearby.