Subject: Re: [Ietf-languages] Missing M.49 code

From: "Doug Ewell" <[email-masked]>
Date: Tue, 20 Feb 2018 11:13:19 -0700

Mark Davis wrote:

>> Is this desired because
>>
>> (a) there is actual linguistic content in Sercquiais (or the "Sark
>> variety" of some other language) that needs to be tagged,
>
> (a) Not a relevant objection. There may well be a need; BCP47 is
> structured so that we don't have to care whether there is a "need" for
> ja-AQ, etc.

I wasn't objecting. I was asking what the use case was for pursuing this
right now. As you noted, 680 for Sark has existed in M.49 since 2011
with no 3166-1 equivalent, and it didn't seem to be a concern until now.

>> (b) because there is a desire to create CLDR locale data for Sark, or
>>
>> (c) simply because CLDR somehow expects every UN M.49 code element to
>> have a corresponding ISO 3166-1 alpha-2 code element?
>
> (b), (c) General-purpose software has come to depend on the LSTR for
> stable codes. Having a misalignment does nobody any good.

Should we be talking about creating variant subtag 'sercq'?
 
--
Doug Ewell | Thornton, CO, US | ewellic.org

---

From: Mark Davis ☕️ <[email-masked]>
Date: Tue, 20 Feb 2018 19:48:01 +0100

No, variants don't help at all

Mark

---

From: Michael Everson <[email-masked]>
Date: Tue, 20 Feb 2018 20:28:29 +0000

On 20 Feb 2018, at 18:13, Doug Ewell <[email-masked]> wrote:

> Should we be talking about creating variant subtag 'sercq’?

If there is evidence the dialect differs enough, that might be an option.

Michael