Subject: Re: [Ietf-languages] Click letters in ISO 639-3 and Registry (long)

From: Michael Everson <[email-masked]>
Date: Sun, 11 Mar 2018 00:38:26 +0000

Those two are ejectives, so the should use 02BC.

> Sent: Wednesday, February 28, 2018 9:39
> To: ietflang IETF Languages Discussion
> Cc: Mark Davis ; Michael Everson
> Subject: Re: [Ietf-languages] Click letters in ISO 639-3 and Registry (long)
> 
> Only two of the languages with click letters in their names involve any
> sort of apostrophe:
> 
> • Juǀʼhoan / Juǀʼhoansi
> • ǂKxʼauǁʼein
> 
> Are we able to make a decision on just these two, so that we can handle
> all of the click names in one sweep, without opening any floodgates or
> setting any precedents?
> 
> --
> Doug Ewell | Thornton, CO, US | ewellic.org
> 
> 
> _______________________________________________
> Ietf-languages mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-languages

---

From: Arthur Reutenauer <[email-masked]>
Date: Sun, 11 Mar 2018 01:57:48 +0100

> Those two are ejectives, so the should use 02BC.

  Actually, according to Wikipedia, the apostrophe-like character
indicates glottalisation after a click, and ejectiveness (is that a
word?) after other consonants, but I agree, the character definitely is
U+02BC in all cases.

	Best,

		Arthur

---

From: "Doug Ewell" <[email-masked]>
Date: Sat, 10 Mar 2018 18:59:06 -0700

and Arthur Reutenauer replied:

> word?) after other consonants, but I agree, the character definitely
> is U+02BC in all cases.

Mark and others, do you agree? Can we recommend spellings to 639-3/RA 
for these two languages using this character? Remember we are NOT trying 
to solve the apostrophe problem for all language names, let alone for 
running text in these languages and others (such as Polynesian 
languages).

What about the click characters in my original post of February 27? ( ǀ 
ǁ ǂ ǃ ) Can we agree on the names using these characters as I posted?

What about ASCII fallbacks? We will need to give the RA something to put 
in their Latin-1–restricted files. They are currently using ( | || ! ) 
which seem OK, and ( ‡ ) which is awful and not even Latin-1. Can we 
recommend that they use ( | || |= ! ) plus U+0027 for the 
glottal-ejective-whatever apostrophe?

And finally, can we agree, after the RA makes these changes, NOT to use 
the ASCII fallbacks in the Registry, but only the names with the real 
clicks and apostrophe letters? I realize this might be the most 
controversial part.

---

From: Peter Constable <[email-masked]>
Date: Mon, 12 Mar 2018 16:23:39 +0000

Clicks, by definition, are articulated with a closed glottis, but with the tongue or lips as the source of air movement. Ejectives are articulated by a closed glottis as the source of air movement.

But what characters are used to write a sound is a matter of orthography, not of articulatory phonetics.

Peter

-----Original Message-----
From: Ietf-languages <[email-masked]> On Behalf Of Arthur Reutenauer
Sent: Saturday, March 10, 2018 4:58 PM
To: Michael Everson <[email-masked]>
Cc: IETF Languages Discussion <[email-masked]>
Subject: Re: [Ietf-languages] Click letters in ISO 639-3 and Registry (long)

> Those two are ejectives, so the should use 02BC.

  Actually, according to Wikipedia, the apostrophe-like character indicates glottalisation after a click, and ejectiveness (is that a
word?) after other consonants, but I agree, the character definitely is
U+02BC in all cases.

	Best,

		Arthur

_______________________________________________
Ietf-languages mailing list
[email-masked]
https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fietf-languages&data=04%7C01%7Cpetercon%40microsoft.com%7Ce9ccb07ce2294e1853c008d586eb2f8d%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636563267035193445%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwifQ%3D%3D%7C-1&sdata=x3WJ24UNrErgvyGRrzjHdufL9dWVRxMMI5xBDOxJOZI%3D&reserved=0

---

From: Michael Everson <[email-masked]>
Date: Mon, 12 Mar 2018 16:34:26 +0000

The recommended character for this is 02BC, even if it is polyvalent in the IPA as regards its function when next to different kinds of letters. It’s the high 9-shaped modifier letter.

> On 12 Mar 2018, at 16:23, Peter Constable <[email-masked]> wrote:
>

---

From: Arthur Reutenauer <[email-masked]>
Date: Mon, 12 Mar 2018 19:06:06 +0100

> Clicks, by definition, are articulated with a closed glottis, but with the tongue or lips as the source of air movement. Ejectives are articulated by a closed glottis as the source of air movement.

  In other words, there is no such thing as an ejective click, if I
understand correctly?

> But what characters are used to write a sound is a matter of orthography, not of articulatory phonetics.

  It was orthography I talking about: I don’t have a better reference
than Wikipedia, whether online or offline, but the article
https://en.wikipedia.org/wiki/Ju%C7%80'hoan_dialect#Orthography seems
quite well informed and makes it clear that the apostrophe-like
character is used as a modifier after certain consonants – including
clicks – with several possible meanings.  That being the case, it would
seem that U+02BC MODIFIER LETTER APOSTROPHE is best suited to represent
it.  Do you agree?

	Best,

		Arthur

---

From: Arthur Reutenauer <[email-masked]>
Date: Mon, 12 Mar 2018 19:09:24 +0100

> The recommended character for this is 02BC, even if it is polyvalent in the IPA as regards its function when next to different kinds of letters. It’s the high 9-shaped modifier letter.

  Actually, it’s rather the other way round: IPA has a specific symbol
for each of the articulatory mechanisms, but they may be merged into one
character in some orthographies, like here.  I agree with you otherwise.

	Best,

		Arthur

---

From: Arthur Reutenauer <[email-masked]>
Date: Thu, 15 Mar 2018 17:45:33 +0100

On Sat, Mar 10, 2018 at 06:59:06PM -0700, Doug Ewell wrote:
> Mark and others, do you agree? Can we recommend spellings to 639-3/RA for
> these two languages using this character? Remember we are NOT trying to
> solve the apostrophe problem for all language names, let alone for running
> text in these languages and others (such as Polynesian languages).
> 
> What about the click characters in my original post of February 27? ( ǀ ǁ ǂ
> ǃ ) Can we agree on the names using these characters as I posted?

  I agree to all the names you’ve suggested in that email, and to not
use ASCII fallbacks in the registry.

> What about ASCII fallbacks? We will need to give the RA something to put in
> their Latin-1–restricted files. They are currently using ( | || ! ) which
> seem OK, and ( ‡ ) which is awful and not even Latin-1. Can we recommend
> that they use ( | || |= ! ) plus U+0027 for the glottal-ejective-whatever
> apostrophe?

  Actually, they’re only using ‡ once in the UTF-8 file, in ASCII it’s =/
which to be consistent we could recommend replacing by =| instead.  I
agree with all the rest.

	Best,

		Arthur