Subject: Re: [Ietf-languages] Click letters in ISO 639-3 and Registry (long)

From: Michael Everson <[email-masked]>
Date: Thu, 1 Mar 2018 09:22:36 +0000

Please ask a more complete question so I can understand what you are trying to say.

> On 28 Feb 2018, at 18:31, Hugh Paterson <[email-masked]> wrote:
> 
> @Michael Everson
> 
> Do you see a reasonable way to use ISO 15924 data to make the distinction?
> 
> - Hugh
> 
> On Wed, Feb 28, 2018 at 8:39 AM, Doug Ewell <[email-masked]> wrote:
> Only two of the languages with click letters in their names involve any
> sort of apostrophe:
> 
> • Juǀʼhoan / Juǀʼhoansi
> • ǂKxʼauǁʼein
> 
> Are we able to make a decision on just these two, so that we can handle
> all of the click names in one sweep, without opening any floodgates or
> setting any precedents?
> 
> --
> Doug Ewell | Thornton, CO, US | ewellic.org
> 
> 
> _______________________________________________
> Ietf-languages mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-languages
> 
> _______________________________________________
> Ietf-languages mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-languages

---

From: Hugh Paterson <[email-masked]>
Date: Thu, 1 Mar 2018 08:24:40 -0800

@Michael Everson

ISO 15924 is an ISO standard which indicates which unicode values are part
of a script. A script which is in turn is used by a language.
Do you see a reasonable way to use ISO 15924 correspondences between
language and the characters used to make the distinction between which of
the apostrophe like characters is the optimal candidate for use in the
language name by ISO 639-3?
Or is this a moot point because we are not writing our language names in
the scripts that those languages use to write. For instance we write 'Thai'
not 'ภาษาไทย' as the language name in descriptions. So for some language's
names we are are not looking for the 'proper' character used by the
language in the writing of their language name, we are looking for the
proper character to write their language name as it would appear in a
'Latin' typeface script.

- all the best,
Hugh Paterson III

---

From: John Cowan <[email-masked]>
Date: Thu, 1 Mar 2018 12:05:06 -0500

On Thu, Mar 1, 2018 at 4:22 AM, Michael Everson <[email-masked]>
wrote:

Please ask a more complete question so I can understand what you are trying
> to say.

Doug is, if I understand him correctly, asking this:

In the process of changing the various language names with clicks in them
from their ASCII fallbacks (/, //, !) to proper Unicode ( ǀ,  ǁ, !), he has
found two names which contain both a click letter and an ASCII apostrophe
fallback.  He is proposing to change these two apostrophe fallbacks to
proper Unicode apostrophes as well, so that these names do not have to be
changed twice, once now and once when the apostrophes are fixed.

Does this proposal meet with your approval, O king, live forever?

(Irrelevant font-maker's note:  The ǃ retroflex click should properly be a ǀ
dental click with a retroflex dot below: using the shape of ! is a
corruption.)

-- 
John Cowan          http://vrici.lojban.org/~cowan        [email-masked]
LEAR: Dost thou call me fool, boy?
FOOL: All thy other titles thou hast given away:
That thou wast born with.

---

From: Michael Everson <[email-masked]>
Date: Thu, 1 Mar 2018 21:55:43 +0000

I am still unpacking and will attend to this when I can. Please be patient.

> On 1 Mar 2018, at 17:05, John Cowan <[email-masked]> wrote:
> 
> 
> 
> On Thu, Mar 1, 2018 at 4:22 AM, Michael Everson <[email-masked]> wrote:
> 
> In the process of changing the various language names with clicks in them from their ASCII fallbacks (/, //, !) to proper Unicode ( ǀ,  ǁ, !), he has found two names which contain both a click letter and an ASCII apostrophe fallback.  He is proposing to change these two apostrophe fallbacks to proper Unicode apostrophes as well, so that these names do not have to be changed twice, once now and once when the apostrophes are fixed.
> 
> (Irrelevant font-maker's note:  The ǃ retroflex click should properly be a ǀ dental click with a retroflex dot below: using the shape of ! is a corruption.)
> 
> --

---

From: Michael Everson <[email-masked]>
Date: Thu, 1 Mar 2018 21:54:55 +0000

On 1 Mar 2018, at 16:24, Hugh Paterson <[email-masked]> wrote:

> ISO 15924 is an ISO standard which indicates which unicode values are part of a script. A script which is in turn is used by a language.

I know. I’m the registrar for the Registration Authority (the Unicode Consortium) and I was the project leader and editor when the standard was being developed.

> Do you see a reasonable way to use ISO 15924 correspondences between language and the characters used to make the distinction between which of the apostrophe like characters is the optimal candidate for use in the language name by ISO 639-3?

No, because the apostrophe-like characters have the “Common” script property.

> Or is this a moot point because we are not writing our language names in the scripts that those languages use to write.

Hawaiian uses Latin letters which have the “Latin” script property, and also U+02BB. 

Michael