Subject: Re: [Ietf-languages] Registration request: fonkirsh

From: "Doug Ewell" <[email-masked]>
Date: Mon, 19 Mar 2018 08:20:38 -0700

Sascha Brawer wrote:

> Instead of registering a BCP47 variant subtag for the Kirshenbaum
> alphabet, an alternative might be tagging such content with BCP47
> extension T. In that case, English content in the Kirshenbaum phonetic
> alphabet would probably be tagged as “en-fonipa-t-d0-fonkirsh”. If the
> language wasn’t known, the tag would be “und-fonipa-t-d0-fonkirsh”.
> (Assuming, of course, that we’d register a BCP47 extension T subtag
> into Unicode’s registry).

We have continued to register variant subtags for phonetic alphabets
('fonnapa' and 'unifon') since the publication of extension T, which is
not the case for standards for transliterating a language from one
script to another.

On the other hand, CLDR (the source of identifiers for extension T) has
plenty identifiers for transliteration standards, but none for phonetic
alphabets.

Therefore, my opinion (worth the paper it's written on) is that a
variant subtag is the right solution for Kirshenbaum, whereas EWTS
should be coded via extension T.
 
--
Doug Ewell | Thornton, CO, US | ewellic.org

---

From: Peter Constable <[email-masked]>
Date: Mon, 19 Mar 2018 17:33:32 +0000

I agree.

Peter

-----Original Message-----
From: Ietf-languages <[email-masked]> On Behalf Of Doug Ewell
Sent: Monday, March 19, 2018 8:21 AM
To: Sascha Brawer <[email-masked]>; ietflang IETF Languages Discussion <[email-masked]>
Cc: Reece H. Dunn <[email-masked]>
Subject: Re: [Ietf-languages] Registration request: fonkirsh

> into Unicode’s registry).

We have continued to register variant subtags for phonetic alphabets ('fonnapa' and 'unifon') since the publication of extension T, which is not the case for standards for transliterating a language from one script to another.

On the other hand, CLDR (the source of identifiers for extension T) has plenty identifiers for transliteration standards, but none for phonetic alphabets.

Therefore, my opinion (worth the paper it's written on) is that a variant subtag is the right solution for Kirshenbaum, whereas EWTS should be coded via extension T.

_______________________________________________
Ietf-languages mailing list
[email-masked]
https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fietf-languages&data=04%7C01%7Cpetercon%40microsoft.com%7C1c6c997122ae469e4e2d08d58dad1ecb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636570697038286300%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwifQ%3D%3D%7C-1&sdata=UO7loXxO3D0rL4UR%2Bh2ZyMrneYAqy731gSkMwE5SCdE%3D&reserved=0