Subject: Re: [Ietf-languages] [EXTERNAL] Re: language identifiers for sign languages (incl. sgn) vs. attribute for indicating the representation of an individual language in "sign language modality"

From: "Doug Ewell" <[email-masked]>
Date: Mon, 25 Nov 2019 08:55:45 -0700

Elizabeth is correct that a BCP 47 tag like "it-signed" would be appropriate for a true signed version of Italian, but not for Italian Sign Language, which is a different language and would be tagged "ise".

Similarly, signed spoken English (any variety) is not the same as American Sign Language. The former could be "en-signed"; the latter is "ase".

ISO 639-3 has code elements for more than 140 sign languages, in addition to the generic [sgn], plus a well-defined mechanism to add more as needed. They are not the issue here. The issue is how to tag signed forms of non-sign languages, such as Signing Exact English.

As a side note, I wish Bickford had not included the following in the article Elizabeth cited:

> ISO 639-3 announces to the world that your language exists and that
> it is different from all other languages. This can give it more
> prestige and respect.

because there are already too many people who request an ISO 639 code element for a language because they think it will give it prestige and respect. (This is usually a problem with new constructed languages, not with established sign languages. But still.)

--

Doug Ewell | Thornton, CO, US | ewellic.org

-------- Original Message --------

Subject: Re: [Ietf-languages] [EXTERNAL] Re: language identifiers for

sign languages (incl. sgn) vs. attribute for indicating the

representation of an individual language in "sign language modality"

From: "Pyatt, Elizabeth J" <[email-masked]>

Date: Mon, November 25, 2019 7:18 am

To: Mark Davis ☕️ <[email-masked]>

Cc: <many>

In terms of identifying sign languages, it's important to note that languages such as ASL (American Sign Language) are not variants of a spoken language, but can be independent grammatical systems.

Finger spelling in ASL can provide a phonetic translation of specific spoken words, but the primary signs have nothing to do with English phonology or grammar. In fact, ASL was an adaptation of French Sign Language (FSL) and as such has object pronouns. It

https://www.accreditedlanguage.com/interpreting/types-of-sign-language-and-their-development/

ASL also has second person plural pronouns and apparently does not always distinguish gender in the third person.

https://www.lifeprint.com/asl101/pages-layout/possession.htm

Tagging ASL as a variant of English would be incorrect. Tagging ASL as a sign language associated with the U.S.(i.e. sgn-us) might be more accurate. But having appropriate identification tags for the languages would be better, because there are dialects and "accents" in different sign languages.

FYI - SIL does have a mechanism to register specific regional sign languages.

https://www.sil.org/system/files/reapdata/49/93/30/4993307252502011969228542832463330862/ISO_639_3_for_Deaf_Communities__English_.pdf

Hope this is useful.

Elizabeth

---

From: Peter Constable <[email-masked]>
Date: Tue, 26 Nov 2019 23:34:32 +0000

Re-sending with trimmed to/cc (to avoid being blocked by list)

From: Peter Constable
Sent: Tuesday, November 26, 2019 2:08 PM
To: Shawn Steele <Shawn.Steele=[email-masked]>; Doug Ewell <[email-masked]>; Pyatt, Elizabeth J <[email-masked]>; Mark Davis ☕️ <[email-masked]>
Cc: John Cowan <[email-masked]>; Fourney, David <[email-masked]>; Sebastian Drude <[email-masked]>; Christian Galinski <[email-masked]>; ietf-languages <[email-masked]>; [email-masked]
Subject: RE: [Ietf-languages] [EXTERNAL] Re: language identifiers for sign languages (incl. sgn) vs. attribute for indicating the representation of an individual language in "sign language modality"

If “signed” were registered as a subtag, it should be explicitly defined to denote a signed modality for an oral language, and should not be used in combination with a primary language tag for a signed language. Of course, the registry doesn’t identify what are signed languages, so that constraint couldn’t be validated.

But “signed” would inherently be limited in its utility—which I think is John’s point. As an rough analogy, it would be a bit like tagging content to indicate that the speaker/author has a language impediment, but without any indication as to the nature of that impediment. So, maybe they can’t pronounce interdental fricatives or maybe they haven’t learned a dual/plural distinction in inflections or any other number of possibilities. Would that really be useful? It might be, but I gather John thinks not, and it certainly wouldn’t satisfy requirements in all scenarios.

Peter

From: Shawn Steele <Shawn.Steele=[email-masked]<mailto:Shawn.Steele=[email-masked]>>
Sent: Monday, November 25, 2019 9:56 AM
To: Doug Ewell <[email-masked]<mailto:[email-masked]>>; Pyatt, Elizabeth J <[email-masked]<mailto:[email-masked]>>; Mark Davis ☕️ <[email-masked]<mailto:[email-masked]>>
Cc: John Cowan <[email-masked]<mailto:[email-masked]>>; Peter Constable <[email-masked]<mailto:[email-masked]>>; Fourney, David <[email-masked]<mailto:[email-masked]>>; Sebastian Drude <[email-masked]<mailto:[email-masked]>>; Christian Galinski <[email-masked]<mailto:[email-masked]>>; ietf-languages <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Ietf-languages] [EXTERNAL] Re: language identifiers for sign languages (incl. sgn) vs. attribute for indicating the representation of an individual language in "sign language modality"

If I understood correctly, the original question was about a way to tag signed variants for spoken English vs the language codes for the signed languages.

It would seem to me that “en-signed” and “ase” solve those reasonably well.  So I think that adding a “signed” subtag would be a reasonable solution to the problem.  I’m not sure how you’d avoid having naïve users choose “en-signed” for ASL though.

The discussion also asked about regional variations, however I’d like to point out that we don’t do well with those for spoken languages either.  (Just watched an “English” movie with my reasonably fluent Chinese exchange student and I’d be surprised if he understood half of it… heck, I had trouble with parts!  And I remember arriving in Stuttgart, hearing the airport paging system and thinking “I haven’t been in Germany for a couple years, but surely my German isn’t that bad!” – and then learning about Swabian…)  Probably a mechanism would work as well for those would also work for dialects of signed languages.

-Shawn

From: Ietf-languages <[email-masked]<mailto:[email-masked]>> On Behalf Of Doug Ewell
Sent: Monday, November 25, 2019 7:56 AM
To: Pyatt, Elizabeth J <[email-masked]<mailto:[email-masked]>>; Mark Davis ☕️ <[email-masked]<mailto:[email-masked]>>
Cc: John Cowan <[email-masked]<mailto:[email-masked]>>; Peter Constable <petercon=[email-masked]<mailto:petercon=[email-masked]>>; Fourney, David <[email-masked]<mailto:[email-masked]>>; Sebastian Drude <[email-masked]<mailto:[email-masked]>>; Christian Galinski <[email-masked]<mailto:[email-masked]>>; ietf-languages <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Ietf-languages] [EXTERNAL] Re: language identifiers for sign languages (incl. sgn) vs. attribute for indicating the representation of an individual language in "sign language modality"

--
Doug Ewell | Thornton, CO, US | ewellic.org<https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fewellic.org&data=02%7C01%7Cpetercon%40microsoft.com%7Ca297710b4d3e41d09f7f08d771d0b844%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637103013822669086&sdata=QHbtdpJAbDitNEilaayLLmetWim6vi84aEEunDC8vxw%3D&reserved=0>

-------- Original Message --------
Subject: Re: [Ietf-languages] [EXTERNAL] Re: language identifiers for
sign languages (incl. sgn) vs. attribute for indicating the
representation of an individual language in "sign language modality"
From: "Pyatt, Elizabeth J" <[email-masked]<mailto:[email-masked]>>
Date: Mon, November 25, 2019 7:18 am
To: Mark Davis ☕️ <[email-masked]<mailto:[email-masked]>>
Cc: <many>

https://www.accreditedlanguage.com/interpreting/types-of-sign-language-and-their-development/<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.accreditedlanguage.com%2Finterpreting%2Ftypes-of-sign-language-and-their-development%2F&data=02%7C01%7Cpetercon%40microsoft.com%7Ca297710b4d3e41d09f7f08d771d0b844%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637103013822679086&sdata=Wi6cLDFGsNmIQTJw%2BJ%2Fi3SlbfbhLN%2Fjy3e1SeFlBtr8%3D&reserved=0>

ASL also has second person plural pronouns and apparently does not always distinguish gender in the third person.
https://www.lifeprint.com/asl101/pages-layout/possession.htm<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.lifeprint.com%2Fasl101%2Fpages-layout%2Fpossession.htm&data=02%7C01%7Cpetercon%40microsoft.com%7Ca297710b4d3e41d09f7f08d771d0b844%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637103013822679086&sdata=pL1rRjd3B0EdKAW76w3HYqYNpigFrd7N18AJzhklxNk%3D&reserved=0>

FYI - SIL does have a mechanism to register specific regional sign languages.
https://www.sil.org/system/files/reapdata/49/93/30/4993307252502011969228542832463330862/ISO_639_3_for_Deaf_Communities__English_.pdf<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.sil.org%2Fsystem%2Ffiles%2Freapdata%2F49%2F93%2F30%2F4993307252502011969228542832463330862%2FISO_639_3_for_Deaf_Communities__English_.pdf&data=02%7C01%7Cpetercon%40microsoft.com%7Ca297710b4d3e41d09f7f08d771d0b844%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637103013822689084&sdata=0PHUNeiAqe5G1HBfRcKGZbcTPGOAZHl39m8m8LEe1VQ%3D&reserved=0>

Hope this is useful.

Elizabeth

---

From: Shawn Steele <[email-masked]>
Date: Tue, 26 Nov 2019 23:37:54 +0000

Resending w/o all the folks…

-------------------------------

I’m not really seeing any action for the registry here.  It seems like existing tags work fine for the actual signed languages.  It also seems like a generic “signed” tag isn’t likely to be sufficient to be helpful as there might be several ways of doing that.  Am I missing something?

I do wonder if there’s something absent here in the stack as a whole:  Systems tend to ask user’s which language they speak, eg: English.  Technically, you can add an “ase” to your windows language profile, but I seriously doubt anyone knows how to do that.  So I don’t know how an application would know how to offer it to a user.  (Unless they explicitly used another mechanism to offer those resources without using language tagging).

Would there be a useful scenario to say “I’d like a signed version of English, if you have one” without specifying ASL (ase) explicitly?  Would language identifiers be the right thing to communicate that request?

-Shawn

From: Peter Constable <petercon=[email-masked]<mailto:petercon=[email-masked]>>
Sent: Tuesday, November 26, 2019 2:08 PM
To: Shawn Steele <[email-masked]<mailto:[email-masked]>>; Doug Ewell <[email-masked]<mailto:[email-masked]>>; Pyatt, Elizabeth J <[email-masked]<mailto:[email-masked]>>; Mark Davis ☕️ <[email-masked]<mailto:[email-masked]>>
Cc: John Cowan <[email-masked]<mailto:[email-masked]>>; Fourney, David <[email-masked]<mailto:[email-masked]>>; Sebastian Drude <[email-masked]<mailto:[email-masked]>>; Christian Galinski <[email-masked]<mailto:[email-masked]>>; ietf-languages <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Ietf-languages] [EXTERNAL] Re: language identifiers for sign languages (incl. sgn) vs. attribute for indicating the representation of an individual language in "sign language modality"

Peter

-Shawn

-------- Original Message --------

Hope this is useful.

Elizabeth

---

From: Peter Constable <[email-masked]>
Date: Tue, 26 Nov 2019 23:41:25 +0000

> Would there be a useful scenario to say “I’d like a signed version of English, if you have one” without specifying ASL (ase) explicitly?

Implicit in the wording of that question are two mis-conceptions:

  *   ASL is not a signed version of English, or in any sense a variant of English.
  *   A signed-modality expression of English is still English and not ASL or any other signed language.

Re the latter: You speak English with your mouth. Or you write/type it with your hand. A signed modality of English is akin to the latter, except the expression uses hand and face gestures rather than a mechanical device to put marks on paper.

Peter

From: Shawn Steele <Shawn.Steele=[email-masked]>
Sent: Tuesday, November 26, 2019 2:57 PM
To: Peter Constable <[email-masked]>; Doug Ewell <[email-masked]>; Pyatt, Elizabeth J <[email-masked]>; Mark Davis ☕️ <[email-masked]>
Cc: John Cowan <[email-masked]>; Fourney, David <[email-masked]>; Sebastian Drude <[email-masked]>; Christian Galinski <[email-masked]>; ietf-languages <[email-masked]>; [email-masked]
Subject: RE: [Ietf-languages] [EXTERNAL] Re: language identifiers for sign languages (incl. sgn) vs. attribute for indicating the representation of an individual language in "sign language modality"

-Shawn

Peter

-Shawn

--
Doug Ewell | Thornton, CO, US | ewellic.org<https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fewellic.org&data=02%7C01%7Cpetercon%40microsoft.com%7Cdd1bef0b8fed423139bd08d772c3f064%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637104058200732681&sdata=RYnhle%2B41IqQRR3MEXDFV%2BfaVBmoElFgBcUIbp3IPHs%3D&reserved=0>

-------- Original Message --------

https://www.accreditedlanguage.com/interpreting/types-of-sign-language-and-their-development/<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.accreditedlanguage.com%2Finterpreting%2Ftypes-of-sign-language-and-their-development%2F&data=02%7C01%7Cpetercon%40microsoft.com%7Cdd1bef0b8fed423139bd08d772c3f064%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637104058200742673&sdata=mDz37cYS3oyYwmay%2FRwzmpPrphLhj8SiURGz2G7y%2F%2FU%3D&reserved=0>

ASL also has second person plural pronouns and apparently does not always distinguish gender in the third person.
https://www.lifeprint.com/asl101/pages-layout/possession.htm<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.lifeprint.com%2Fasl101%2Fpages-layout%2Fpossession.htm&data=02%7C01%7Cpetercon%40microsoft.com%7Cdd1bef0b8fed423139bd08d772c3f064%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637104058200742673&sdata=11cex6ZDX6y12LzY1UE6bFBtNROK%2F2Xu5HLR%2Fv9hU4M%3D&reserved=0>

FYI - SIL does have a mechanism to register specific regional sign languages.
https://www.sil.org/system/files/reapdata/49/93/30/4993307252502011969228542832463330862/ISO_639_3_for_Deaf_Communities__English_.pdf<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.sil.org%2Fsystem%2Ffiles%2Freapdata%2F49%2F93%2F30%2F4993307252502011969228542832463330862%2FISO_639_3_for_Deaf_Communities__English_.pdf&data=02%7C01%7Cpetercon%40microsoft.com%7Cdd1bef0b8fed423139bd08d772c3f064%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637104058200752669&sdata=deAaFXNtARW7Doc60eyvepgVbmwA32b%2Bn61mFPLicx4%3D&reserved=0>

Hope this is useful.

Elizabeth

---

From: "Doug Ewell" <[email-masked]>
Date: Tue, 26 Nov 2019 19:33:09 -0700

Peter Constable replied to Shawn Steele:

 �

>> Would there be a useful scenario to say “I’d like a signed version

>> of English, if you have one” without specifying ASL (ase) explicitly?

> �

> �

> - ASL is not a signed version of English, or in any sense a variant of

>   English.

> - A signed-modality expression of English is still English and not ASL

>   or any other signed language. 

 �

Indeed, I think these misconceptions probably cause more confusion over tagging sign languages, and more resistance to developing a solution for signed spoken languages, than anything else.

 �

--

---

From: Shawn Steele <[email-masked]>
Date: Wed, 27 Nov 2019 19:33:19 +0000

Yea, I expressed my thoughts poorly.  I meant it more like “if someone speaks English but wants to indicate they’d like to use a signed language.” (which wouldn’t be English, of course, but one might be able to infer which one(s) they’d be more likely to use if you knew the user knew English.)”.  Probably that concept would be best expressed through a non-language tagged setting.

Similar to the idea “if an en-CA speaker spoke a 2nd language, which one(s) would it most likely be (perhaps fr-CA?)”

Anyway, after sending my random thought to the list, it seems like this would probably be best expressed through a mechanism other than a language tag.  (Unless it was an explicit “en-US;ase” type list.)

It’s still unclear to me if a “signed modality of English” would be interesting enough (and consistent enough) to warrant a subtag.   It sounds like the answer is probably “no”.

-Shawn

From: Doug Ewell <[email-masked]>
Sent: Tuesday, November 26, 2019 6:33 PM
To: Peter Constable <[email-masked]>; Shawn Steele <[email-masked]>; 'ietf-languages' <[email-masked]>
Subject: RE: [Ietf-languages] [EXTERNAL] Re: language identifiers for sign languages (incl. sgn) vs. attribute for indicating the representation of an individual language in "sign language modality"

---

From: Peter Constable <[email-masked]>
Date: Thu, 28 Nov 2019 00:27:21 +0000

I think it’s rarely safe to make assumptions about other languages someone might use if going in the direction of lower likelihood. So, if someone indicates they speak (say) Ainu, it’s probably _somewhat_ safe to assume they can also speak Japanese; but it certainly wouldn’t be safe to assume that, if a speaker of Japanese also speaks other languages, then Ainu would be one of them.

If I know that someone speaks English (native speaker, or maybe 2nd language?), and that they also speak a signed language, maybe that sign language is ASL, but it might also be Maritime Sign Language, or Hawai’I Sign Language, or Kenyan Sign Language, etc. At a minimum, I probably need much more info to make reduce risk of bad inferences, and probably I shouldn’t make inferences at all but should let them indicate explicitly all of their language preferences.

Peter

From: Shawn Steele <[email-masked]>
Sent: Wednesday, November 27, 2019 11:33 AM
To: Doug Ewell <[email-masked]>; Peter Constable <[email-masked]>; 'ietf-languages' <[email-masked]>
Subject: RE: [Ietf-languages] [EXTERNAL] Re: language identifiers for sign languages (incl. sgn) vs. attribute for indicating the representation of an individual language in "sign language modality"

-Shawn

From: Doug Ewell <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, November 26, 2019 6:33 PM
To: Peter Constable <[email-masked]<mailto:[email-masked]>>; Shawn Steele <[email-masked]<mailto:[email-masked]>>; 'ietf-languages' <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Ietf-languages] [EXTERNAL] Re: language identifiers for sign languages (incl. sgn) vs. attribute for indicating the representation of an individual language in "sign language modality"

---

From: "Doug Ewell" <[email-masked]>
Date: Wed, 27 Nov 2019 19:02:03 -0700

CLDR has a lot of this type of best-guess fallback data: if someone speaks Breton but we don’t have a Breton localization, offer them French instead, but don’t go the other way.

 �

I don’t think it’s something we would want to embed in BCP 47 or the Registry at all (not that Shawn was suggesting that).

 �

Shawn wrote:

 �

> It’s still unclear to me if a “signed modality of English” would be

> interesting enough (and consistent enough) to warrant a subtag. It

> sounds like the answer is probably “no”.

 �

The “interesting” part puzzles me, because the whole point of this thread is that a group has come to ISO 639-3 and to this list, making the case that it is important to have such tagging.

 �

--

 �

From: Peter Constable <[email-masked]> 
Sent: Wednesday, November 27, 2019 17:27
To: Shawn Steele <[email-masked]>; Doug Ewell <[email-masked]>; 'ietf-languages' <[email-masked]>
Subject: RE: [Ietf-languages] [EXTERNAL] Re: language identifiers for sign languages (incl. sgn) vs. attribute for indicating the representation of an individual language in "sign language modality"

 �

 �

 �

 �

Peter

---

From: Shawn Steele <[email-masked]>
Date: Fri, 29 Nov 2019 20:56:10 +0000

Is there additional information available about the problem they're trying to solve with this request?

Get Outlook for Android<https://aka.ms/ghei36>

________________________________
From: Doug Ewell <[email-masked]>
Sent: Wednesday, November 27, 2019 6:02:03 PM
To: Peter Constable <[email-masked]>; Shawn Steele <[email-masked]>; 'ietf-languages' <[email-masked]>
Subject: RE: [Ietf-languages] [EXTERNAL] Re: language identifiers for sign languages (incl. sgn) vs. attribute for indicating the representation of an individual language in "sign language modality"

--

Peter