Subject: [Ietf-languages] FW: [EXTERNAL] Re: language identifiers for sign languages (incl. sgn) vs. attribute for indicating the representation of an individual language in "sign language modality"

From: "Sebastian Drude \(personal\)" <[email-masked]>
Date: Sun, 1 Dec 2019 14:17:44 -0300

Dear all,

Here my reply to John Cowan. I am now member of this list.

Best,

Sebastian

-- 

Museu P.E. Goeldi, CCH, Linguistica  ▪  Av. Perimetral, 1901

Terra Firme, CEP: 66077-530  ▪  Belém do Pará – PA  ▪  Brazil

 <mailto:[email-masked]> [email-masked]   ▪  Mobil : +55 (91) 983 733 319

From: Sebastian Drude (personal) <[email-masked]> 
Sent: 01 December 2019 13:43
To: 'John Cowan' <[email-masked]>
Cc: 'Christian Galinski' <[email-masked]>; 'Fourney, David' <[email-masked]>; [email-masked]' <[email-masked]>; 'Debra Russell' <[email-masked]>; 'ietf-languages' <[email-masked]>; 'Gary Simons' <[email-masked]>; '105-5-03 Hein, Anja' <[email-masked]>
Subject: RE: [EXTERNAL] Re: [Ietf-languages] language identifiers for sign languages (incl. sgn) vs. attribute for indicating the representation of an individual language in "sign language modality"

Dear John, all,

My comments in-line below.

Best wishes,

Sebastian

-- 

Museu P.E. Goeldi, CCH, Linguistica  ▪  Av. Perimetral, 1901

Terra Firme, CEP: 66077-530  ▪  Belém do Pará – PA  ▪  Brazil

 <mailto:[email-masked]> [email-masked]   ▪  Mobil : +55 (91) 983 733 319

From: John Cowan <[email-masked] <mailto:[email-masked]> > 
Sent: 30 November 2019 00:58
To: Sebastian Drude <[email-masked] <mailto:[email-masked]> >
Cc: Christian Galinski <[email-masked] <mailto:[email-masked]> >; Fourney, David <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> ; Debra Russell <[email-masked] <mailto:[email-masked]> >; ietf-languages <[email-masked] <mailto:[email-masked]> >; Gary Simons <[email-masked] <mailto:[email-masked]> >; 105-5-03 Hein, Anja <[email-masked] <mailto:[email-masked]> >
Subject: Re: [EXTERNAL] Re: [Ietf-languages] language identifiers for sign languages (incl. sgn) vs. attribute for indicating the representation of an individual language in "sign language modality"

On Fri, Nov 29, 2019 at 7:56 AM Sebastian Drude <[email-masked] <mailto:[email-masked]> > wrote:

To begin with, a single flat hierarchy mixing dialects and modalities etc. without cross-classifications is doomed, given the multidimensionality of linguistic variation (cf. ISO 21636). 

Even without considering multidimensional variation, a simple family tree is also not something that should be baked into an IS, because it varies with time: languages are routinely reclassified not only individually but en masse, and there is not always a consensus view.  

[> ] I generally agree with your point on trees, they should not go into the ISO standard, and you probably will never reach a true consensus.  But you have an excellent attempt at evaluating the existing evidence for the different proposals and come to a current best-informed tree.  This has very consistently, as far as I and colleagues can tell, been done in the Glottolog <https://glottolog.org/> .

As to your specific questions, the Glottolog evaluation is:

Is Dene-Yeniseian consensus now or not? (Lyle Campbell doesn't like it, but he doesn't like any grouping that wasn't proposed at least a century ago.)  

[> ] Dene <https://glottolog.org/resource/languoid/id/atha1245> -Yeniseian <https://glottolog.org/resource/languoid/id/yeni1252> : “The link to Eyak-Athapascan-Tlingit Edward J. Vajda 2010 <https://glottolog.org/resource/reference/id/159689>  is not yet mature enough to conclude a genetic relationship Lyle Campbell 2011 <https://glottolog.org/resource/reference/id/31225>  George Starostin 2012 <https://glottolog.org/resource/reference/id/323413>  Gerber, Pascal 2017 <https://glottolog.org/resource/reference/id/555344>  , Edward J. Vajda 2018 <https://glottolog.org/resource/reference/id/567516> .”

What about Altaic?  ("Infinite are the arguments of mages.")  

[> ] Altaic <https://glottolog.org/resource/languoid/id/turk1311> : “See Alexander Vovin 2005 <https://glottolog.org/resource/reference/id/133723>  Georg, Stefan 2017 <https://glottolog.org/resource/reference/id/548973>  for critique on the Altaic hypothesis.”

The current classification of Bantu is basically geographic, and it's not even clear if all those regions actually belong in a single family.  Etc.

[> ]  Bantu: Glottolog follows Blench, Roger 2009 <https://glottolog.org/resource/reference/id/24122>  for Bantoid <https://glottolog.org/resource/languoid/id/bant1294> , and Bostoen, Koen and Grégoire, Claire 2007 <https://glottolog.org/resource/reference/id/99738>  for Narrow Bantu <https://glottolog.org/resource/languoid/id/narr1281> .

Then, an attempt to exhaustively list all varieties of all languages in the world by basically a single person or very small group must fail; this clearly needs a community effort where many experts contribute. 

You'd still need them to agree on common standards:  see above.

[> ] Yes, common criteria and procedures are part of the challenge.  I believe that with differentiating between the different dimensions of internal variation, much of potential and actual confusion can be mitigated already. 

Work on what is now ISO 21636 was originally intended to replace the failed ISO 639-6, but is now a related but separate endeavor, preparing the ground for a future registration mechanism for language varieties. 

This present mailing list, or de facto WG, is a present registration mechanism for language varieties, with a view to identification rather than classification.  Identification views can and, I argue, should be flat.  

[> ] I am not sure I understand what you refer to in this context by “identification”, and I was not aware that this WG ‘is’ a registration mechanism (that seems to be a complicated statement already for ontological reasons 😉); where one can read about that; what are the procedures and criteria?  Which are the varieties already established/identified/registered?

Biologists have enough trouble wrangling their binomial names and dealing with the changes that come with genus-level classifications: if they routinely named our species "Animalia Chordata Mammalia Primates Haplorhini Simiiformes Hominidae Homininae Hominini Homo sapiens" the name would not only be hopelessly verbose but would change all the time: Hominidae was redefined to include the other great apes in a transition starting before 2000 and complieting about 2015.

[> ] Yes, these things are bound to change, and that holds for genealogic trees for languages.  I generally like the multitree approach, where all proposals are documented (cross-tree correspondences of references to individual clades are a little bit more complicated), together with the Glottolog approach to make a well-informed decision, which of course can change over time with new evidence.

[> ] For inner-language variation. I also believe that the varieties classification systems are mostly flat, with some hierarchy for dialects, temporal varieties and possibly sociolects.

-- 

Sent from my phone, excuses for being short

Surely you jest.  "Je n’ai fait celle-ci plus longue que parce que je n’ai pas eu le loisir de la faire plus courte."

---

From: "Sebastian Drude \(personal\)" <[email-masked]>
Date: Sun, 1 Dec 2019 14:21:49 -0300

Dear all,

Please find below my reply to Doug’s mail.

Does somebody have an alternative e-mail address for Doug?  Then please forward this mail to him. His [email-masked] <mailto:[email-masked]>  mailbox seems to be full.

I am looking forward to cooperating with (some of) you in order to make the IETF language tag system (BCP 47 and related mechanisms) work with the future ISO 21636.

Best wishes,

Sebastian

-- 

From: Sebastian Drude (personal) <[email-masked] <mailto:[email-masked]> > 
Sent: 01 December 2019 13:42
To: 'Doug Ewell' <[email-masked] <mailto:[email-masked]> >; 'John Cowan' <[email-masked] <mailto:[email-masked]> >
Cc: 'Christian Galinski' <[email-masked] <mailto:[email-masked]> >; 'Fourney, David' <[email-masked] <mailto:[email-masked]> >; 'Peter Constable' <[email-masked] <mailto:[email-masked]> >; [email-masked]' <[email-masked] <mailto:[email-masked]> >; 'Debra Russell' <[email-masked] <mailto:[email-masked]> >; 'ietf-languages' <[email-masked] <mailto:[email-masked]> >; 'Melinda Lyons' <[email-masked] <mailto:[email-masked]> >; 'Gary Simons' <[email-masked] <mailto:[email-masked]> >; '105-5-03 Hein, Anja' <[email-masked] <mailto:[email-masked]> >
Subject: RE: [EXTERNAL] Re: [Ietf-languages] language identifiers for sign languages (incl. sgn) vs. attribute for indicating the representation of an individual language in "sign language modality"

Thanks a lot, dear Doug, for your detailed comments and suggestions.

Again, my comments are in-line below.

Best wishes,

Sebastian

-- 

From: Doug Ewell <[email-masked] <mailto:[email-masked]> > 
Sent: 29 November 2019 22:00
To: 'Sebastian Drude' <[email-masked] <mailto:[email-masked]> >; 'John Cowan' <[email-masked] <mailto:[email-masked]> >
Cc: 'Christian Galinski' <[email-masked] <mailto:[email-masked]> >; 'Fourney, David' <[email-masked] <mailto:[email-masked]> >; 'Peter Constable' <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> ; 'Debra Russell' <[email-masked] <mailto:[email-masked]> >; 'ietf-languages' <[email-masked] <mailto:[email-masked]> >; 'Melinda Lyons' <[email-masked] <mailto:[email-masked]> >; 'Gary Simons' <[email-masked] <mailto:[email-masked]> >; '105-5-03 Hein, Anja' <[email-masked] <mailto:[email-masked]> >
Subject: RE: [EXTERNAL] Re: [Ietf-languages] language identifiers for sign languages (incl. sgn) vs. attribute for indicating the representation of an individual language in "sign language modality"

If you are serious, and it sounds very much like you are, about making the new standard work well with BCP 47, 

[> ] What would be the alternative?  To have a (consistent, I believe) framework for inner-language variation in ISO, and an unconnected BCP?

I would suggest a few things:

[> ] The way you write, it sounds to me as if you perceive this a personal enterprise of me as a single person.  In my understanding, this should be a common enterprise between the IETF language group and the ISO TC37/SC2/WG1, and possibly other stakeholders.  Shouldn’t it be a common and shared goal to make these frameworks work well one with another?  I am certainly willing to contribute, and even to take a leading role where needed (as far as my time allows; this is all outside my regular job), but only if major stakeholders agree that we all should build something what works in a constructive dialogue.

Read BCP 47, essentially cover-to-cover, 

[> ] I have, a number of times, first around 2013 if I remember it right.  I do not know it by heart, but  I think I have a good basic understanding.

so that you come away feeling you have a very strong grasp on both the syntax and the intended use scenarios. You will want 21636 to fit into  BCP 47 the way 639 and 3166 and 15924 and UN M49 already do, so this understanding is of utmost importance.

[> ] I agree.

Keep in mind that all types of subtag, except the primary language subtag, are optional and any or all can be used together. That is to say, it might not make sense to use a script subtag together with a 21636-based subtag indicating “signed”, but short of that, almost any combination is possible.

[> ] Indeed.

Study the BCP 47 syntax carefully so you are in a position to propose a reasonable and compatible structure for 21636-based subtags. 

[> ] Again, I do not think that this a task only for me as a single person.  I would love to contribute to a small working group that has this goal.

This may be hard because we didn’t leave much in the way of “reserved” patterns for a projected new type of subtag. 

[> ] Yes, I am aware of that, and I have not yet seen a good solution.

One pattern that might possibly be workable is 3 characters, 1 digit followed by 2 letters.

[> ] This would give us 6760 combinations, less then the number of currently recognized languages, which therefore certainly is not sufficient for tagging all language varieties, in particular all regional varieties and dialects, where you need, for the majority of languages, at least two and for some up to hundreds of varieties.

[> ] I would rather envisage one implementation (subtag/extension, whatever works for each dimension) for each of the 8 dimensions.

There aren’t any existing subtags like that, so it might be possible to update the syntax to carve this pattern out of the existing syntax. I’m just throwing ideas out here.

[> ] Thanks for that.  It is a start on how to make advances on this.

Remember that BCP 47 can RECOMMEND using or not using certain subtag values together, but cannot enforce it. Users will do what they do. BCP 47 gives an example of "tlh-Kore-AQ-fonipa" (Klingon, Korean script, as used in Antarctica, IPA phonetic transcription) as a tag that is silly, but perfectly valid syntactically, and even perhaps semantically. Think of combinations that might exist when your subtags are added.

[> ] Sure, but I do not see this as a general objection; it holds already now for BCP 47.

Understand how your subtags will participate in matching. Keep in mind that many processes use simplified matching, and might return results in “en” in response to a request for “en-with-some-new-subtag-for-haptic”, which might not be a great match in practice. Be ready to suggest what processes should do in certain cases. Remember software isn’t updated overnight.

[> ] I have only a very basic understanding of matching and the respective implementations.  Again, I would love to contribute and work together with others who understand this better.

Be prepared to participate in the IETF process of updating BCP 47, 

[> ] I am, but again, I hope I will not be alone, and I hope that also group members from IETF share the goal and do not act only as gatekeepers.

because if you want these to be full-fledged subtags (not an extension), then we will have to go through that process and your input will be needed. It’s a lengthy and sometimes difficult process; if you think WE’RE asking tough questions here, just wait.

[> ] I hope we can figure this out together; I am aware that I do no have all the answers and probably lack the needed expertise in some areas to develop them on my own.

OR… you might take a different path entirely and consider creating an extension for 21636 identifiers instead. (If you’re not sure what an “extension” is, go back to “Read BCP 47” above.) You would need to write an RFC to define the extension, from several specific angles, as described in BCP 47, and get that approved through IETF.

[> ] Again, I hope this does not mean me as a single person.

You will still need to have stable identifiers, meaning they don’t change in a way that makes existing language tags invalid.

[> ] Sure.  

[> ] We do not have yet any concrete proposal for a registration system for varieties, but stability and compatibility with BCP 47 as it is implemented now are certainly important criteria.

And the identifiers need to be publicly available, not something one needs to pay for or set up an account to view.

[> ] Absolutely agreed.

Going the extension route might also allow you to recreate the hierarchical structure you were describing, in a way that a single subtag would not accommodate.

[> ] I am not advocating for a hierarchical system; very much to the contrary.  But it is a matter of fact that for instance regional varieties / dialects are often arranged in sub-classifications.

[> ] For the time being I am focusing on concluding the ISO procedure for ISO 21636, but I believe that it is now sufficiently advanced to start this discussion.  In this sense, I thank you again for investing your time to make these comments.  

[> ] Please let me know what I need to do to become a member of the 'ietf-languages' [email-masked] <mailto:[email-masked]>  list (if that is the working group you are referring to) and/or of other relevant groups.

--

Doug Ewell | Thornton, CO, US | ewellic.org

From: Sebastian Drude <[email-masked] <mailto:[email-masked]> > 
Sent: Friday, November 29, 2019 5:56
To: John Cowan <[email-masked] <mailto:[email-masked]> >
Cc: Doug Ewell <[email-masked] <mailto:[email-masked]> >; Christian Galinski <[email-masked] <mailto:[email-masked]> >; Fourney, David <[email-masked] <mailto:[email-masked]> >; Peter Constable <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> ; Debra Russell <[email-masked] <mailto:[email-masked]> >; ietf-languages <[email-masked] <mailto:[email-masked]> >; Melinda Lyons <[email-masked] <mailto:[email-masked]> >; Gary Simons <[email-masked] <mailto:[email-masked]> >; 105-5-03 Hein, Anja <[email-masked] <mailto:[email-masked]> >
Subject: Re: [EXTERNAL] Re: [Ietf-languages] language identifiers for sign languages (incl. sgn) vs. attribute for indicating the representation of an individual language in "sign language modality"

Indeed, ISO 639-6 failed, and (in my view and that of many colleagues dealing with language diversity) rightly so, although it had much valid research and some interesting insights.

To begin with, a single flat hierarchy mixing dialects and modalities etc. without cross-classifications is doomed, given the multidimensionality of linguistic variation (cf. ISO 21636). Then, an attempt to exhaustively list all varieties of all languages in the world by basically a single person or very small group must fail; this clearly needs a community effort where many experts contribute. 

Best, Sebastian 

-- 

-- 

drude@xs4all - +55 (91) 983 733 319

On Fri, Nov 29, 2019 at 12:47 AM -0300, "John Cowan" <[email-masked] <mailto:[email-masked]> > wrote:

On Thu, Nov 28, 2019 at 10:15 AM <[email-masked] <mailto:[email-masked]> > wrote:

In my understanding, once ISO 21636 is established / accepted, the next step would be to set up a central registration mechanism for individual varieties.

That is exactly what ISO 639-6 was intended to be, and it was withdrawn.  There are other people on this list and elsewhere who probably understand why better than I do, but Peter Constable's post to this list (at <https://www.alvestrand.no/pipermail/ietf-languages/2014-October/012167.html>) said:  "While ISO 639-6 did get approved and published, the code table for 639-6 has never been made fully available in a usable manner. What data has been available has been looked at by lots of people with a response that they don't find it particularly useful for any practical application. Moreover, the agency that was designated as registration authority appears to have ceased its operations. In a nutshell, 639-6 had in many respects failed."

---

From: John Cowan <[email-masked]>
Date: Sun, 1 Dec 2019 15:19:36 -0500

On Sun, Dec 1, 2019 at 11:42 AM Sebastian Drude (personal) <[email-masked]>
wrote:

As to your specific questions, the Glottolog evaluation is:

My questions were rhetorical, but thanks for the links.  I simply picked a
few well-known areas of disagreement.

> I am not sure I understand what you refer to in this context by
> “identification”,
>

I mean that our variant subtags, like ISO 639, 15924, and 3166 code
elements, serve only to identify particular language varieties (or in a few
cases groups of varieties); they contain no classificatory information.
All you can determine from the 639-3 code element "djk" is that it
identifies the living individual language named "Eastern Maroon Creole"; by
the same token, all you can determine from the subtag "aluki" is that it
refers to the Aluki dialect of this language.

and I was not aware that this WG ‘is’ a registration mechanism (that seems
> to be a complicated statement already for ontological reasons 😉);
>

Technically we are not an IETF WG because our activities are not limited in
time; we are most closely analogous to an ISO Registration Authority, but
without corporate identity. The Language Subtag Reviewer is an IETF
appointee, however.

> where one can read about that; what are the procedures and criteria?
>

In RFC 5646 (the first part of BCP 47) particularly sections 2.2.5
(definition of variant subtags), 3.1.8 (how the connection between
particular variants and particular choices of ISO code elements is
established), and 3.5 (the registration procedure).  In brief, someone who
wishes to register a variant fills out a form, sends it to this mailing
list where it is discussed for two weeks or when discussion dies down
(whichever comes last), the Language Subtag Reviewer decides to accept or
reject the registration (technically subject to appeal to the IETF, but
this has never happened), and if accepted it is sent to IANA (the formal
registration authority for the IETF) for publication.

Which are the varieties already established/identified/registered?

In the file <
https://www.iana.org/assignments/language-subtag-registry/language-subtag-registry>,
the sections containing "Type: variant".  Further details that were used to
validate the registration appear in the directory <
https://www.iana.org/assignments/lang-subtags-templates/lang-subtags-templates.xhtml
>.

John Cowan          http://vrici.lojban.org/~cowan        [email-masked]
Assent may be registered by a signature, a handshake, or a click of a
computer
mouse transmitted across the invisible ether of the Internet. Formality
is not a requisite; any sign, symbol or action, or even willful inaction,
as long as it is unequivocally referable to the promise, may create a
contract.
       --Specht v. Netscape

---

From: "Sebastian Drude \(personal\)" <[email-masked]>
Date: Sun, 1 Dec 2019 18:25:54 -0300

Thanks, dear John,

All points well taken.

I did get the spirit of your examples, but thought that by pointing to how the Glottolog deals with these specific examples would illustrate well how it functions generally.

By the way, I have recently written about the different language catalogues, highlighting ISO and the Glottolog: http://hdl.handle.net/10125/24814.

Best,

Sebastian

-- 

From: Ietf-languages <[email-masked]> On Behalf Of John Cowan
Sent: 01 December 2019 17:20
To: ietf-languages <[email-masked]>
Subject: Re: [Ietf-languages] [EXTERNAL] Re: language identifiers for sign languages (incl. sgn) vs. attribute for indicating the representation of an individual language in "sign language modality"

On Sun, Dec 1, 2019 at 11:42 AM Sebastian Drude (personal) <[email-masked] <mailto:[email-masked]> > wrote:

My questions were rhetorical, but thanks for the links.  I simply picked a few well-known areas of disagreement.

I am not sure I understand what you refer to in this context by “identification”, 

I mean that our variant subtags, like ISO 639, 15924, and 3166 code elements, serve only to identify particular language varieties (or in a few cases groups of varieties); they contain no classificatory information.  All you can determine from the 639-3 code element "djk" is that it identifies the living individual language named "Eastern Maroon Creole"; by the same token, all you can determine from the subtag "aluki" is that it refers to the Aluki dialect of this language.

and I was not aware that this WG ‘is’ a registration mechanism (that seems to be a complicated statement already for ontological reasons 😉);

Technically we are not an IETF WG because our activities are not limited in time; we are most closely analogous to an ISO Registration Authority, but without corporate identity. The Language Subtag Reviewer is an IETF appointee, however.

In RFC 5646 (the first part of BCP 47) particularly sections 2.2.5 (definition of variant subtags), 3.1.8 (how the connection between particular variants and particular choices of ISO code elements is established), and 3.5 (the registration procedure).  In brief, someone who wishes to register a variant fills out a form, sends it to this mailing list where it is discussed for two weeks or when discussion dies down (whichever comes last), the Language Subtag Reviewer decides to accept or reject the registration (technically subject to appeal to the IETF, but this has never happened), and if accepted it is sent to IANA (the formal registration authority for the IETF) for publication.

In the file <https://www.iana.org/assignments/language-subtag-registry/language-subtag-registry>, the sections containing "Type: variant".  Further details that were used to validate the registration appear in the directory <https://www.iana.org/assignments/lang-subtags-templates/lang-subtags-templates.xhtml>.

John Cowan          http://vrici.lojban.org/~cowan        [email-masked] <mailto:[email-masked]> 
Assent may be registered by a signature, a handshake, or a click of a computer
mouse transmitted across the invisible ether of the Internet. Formality
is not a requisite; any sign, symbol or action, or even willful inaction,
as long as it is unequivocally referable to the promise, may create a contract.
       --Specht v. Netscape