Subject: Re: [Ietf-languages] Forms for ISO 639-3 changes

From: "Doug Ewell" <[email-masked]>
Date: Sat, 14 Mar 2020 16:40:35 -0600

A few questions arose off-list concerning some of the proposed changes posted yesterday.

1. Character encoding

If you see garbage characters in the record and/or registration form for subtags 'huc' (Part 4) and 'dgr' (Part 5), try changing the encoding to UTF-8 in the text editor or browser you are using to view the forms.

2. Errors in URLs

Most web browsers (probably all) will convert the URLs in the posted registration forms to actual clickable links. Some browsers apparently introduce errors in a few of these links, converting a single dot to two consecutive dots, which makes the link fail. If you see this, try copying and pasting the text from the registration form into your browser.

One of the URLs in the 'dgr' registration form was followed immediately by a period (full stop). Most browsers can handle this, but in the past, some erroneously included the extra dot in the clickable link, also making the link fail. I've corrected this form to avoid this potential problem; the corrected form is below.

---

LANGUAGE SUBTAG REGISTRATION FORM

1. Name of requester: Doug Ewell
2. E-mail address of requester: doug at ewellic.org

3. Record Requested:

Type: language
Subtag: dgr
Description: Dogrib
Description: Tłı̨chǫ

4. Intended meaning of the subtag:

5. Reference to published description of the language (book or article):

6. Any other relevant information:

This registration tracks a change made to ISO 639-3 effective
2020-01-23, adding the additional name "Tłı̨chǫ" for the existing
code element 'dgr'.

For more information about this ISO 639-3 change, see the change request
page at https://iso639-3.sil.org/request/2019-052 . As of 2020-03-08,
the change was shown as "Pending" on the change request page and was not
listed in
https://iso639-3.sil.org/sites/iso639-3/files/reports/639-3_ChangeRequests_2019_Summary.pdf
but was present in the code set files.

--
Doug Ewell | Thornton, CO, US | ewellic.org

---

From: "Doug Ewell" <[email-masked]>
Date: Sat, 21 Mar 2020 11:31:13 -0600

As a reminder, today is the halfway point of our two-week review for 62 updates to the Registry triggered by ISO 639-3 changes.

Please try to find some time to review these. I have a process for converting these from ISO 639-3 data, but a lot of the process is manual and there is always a chance of errors.

Lots of people are working from home at present; this could be a good opportunity for review.