Subject: [Ietf-languages] Language subtag registrFroation form: Inuktun

From: Leon Derczynski <[email-masked]>
Date: Sun, 21 Jun 2020 19:46:08 +0000

For the Inuktun language of Greenland. 

LANGUAGE SUBTAG REGISTRATION FORM
   1. Name of requester: Leon Strømberg-Derczynski
   2. E-mail address of requester: [email-masked]
   3. Record Requested:

      Type: language
      Subtag: inu
      Description: Inuktun
      Description: Avanersuarmiutut
      Description: Nordgrønlandsk
      Macrolanguage: iu

   4. Intended meaning of the subtag: 
     The Inuktun language, spoken by the Inughuit who inhabit Qaanaaq and
     environs in Northern Greenland. The language is an Eskimo–Aleut language
     and dialectologically it is in between the Greenlandic Kalaallisut and
     the Canadian Inuktitut. Inuktun differs from Kalaallisut in phonology,
     consonant combinations, grammar and orthography. 

   5. Reference to published description of the language (book or article):
      Wikipedia entry:
        https://en.wikipedia.org/wiki/Inuktun
      Fortescue, Michael, 1991, Inuktun: an introduction to the language of
        Qaanaaq, Thule, Institut for Eskimologi 15, Københavns Universitet
      Erik Holtved. Remarks on the Polar Eskimo Dialect. International Journal
        of American Linguistics. Vol. 18, No. 1 (Jan., 1952), pp. 20-24
      Present on Glottolog:
        https://glottolog.org/resource/languoid/id/pola1254
        
   6. Any other relevant information:
     The Greenlandic name and Danish name (the region in which the language
     is spoken being part of Denmark) are given as second and third
     descriptions.
     Macrolanguage is a suggestion; there is "multiple inheritance" with other
     Aleut languages.

Natural Language Processing, Department of Computer Science
IT University of Copenhagen  http://www.derczynski.com/itu/  +45 5157 4948

---

From: Michael Everson <[email-masked]>
Date: Sun, 21 Jun 2020 22:15:18 +0100

Should the subtag not be “inuktun”?

> On 21 Jun 2020, at 20:46, Leon Derczynski <[email-masked]> wrote:
> 
> _______________________________________________
> Ietf-languages mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-languages

---

From: Mark Davis ☕️ <[email-masked]>
Date: Sun, 21 Jun 2020 14:32:58 -0700

That's premature at this point. They must go to ISO 639 first, and the bar
is quite high if they fail at ISO.

Cf.

3.6 <https://tools.ietf.org/rfc/bcp/bcp47.html#section-3.6>.
Possibilities for Registration

   Possibilities for registration of subtags or information about
   subtags include:

   o  Primary language subtags for languages not listed in ISO 639 that
      are not variants of any listed or registered language MAY be
      registered.  At the time this document was created, there were no
      examples of this form of subtag.  Before attempting to register a
      language subtag, there MUST be an attempt to register the language

Phillips & Davis         Best Current Practice                 [Page 46]

------------------------------

RFC 5646 <https://www.rfc-editor.org/rfc/rfc5646>
Language Tags                September 2009

      with ISO 639.  Subtags MUST NOT be registered for languages
      defined by codes that exist in ISO 639-1, ISO 639-2, or ISO 639-3;
      that are under consideration by the ISO 639 registration
      authorities; or that have never been attempted for registration
      with those authorities.  If ISO 639 has previously rejected a
      language for registration, it is reasonable to assume that there
      must be additional, very compelling evidence of need before it
      will be registered as a primary language subtag in the IANA
      registry (to the extent that it is very unlikely that any subtags
      will be registered of this type).

Mark

---

From: "Doug Ewell" <[email-masked]>
Date: Sun, 21 Jun 2020 15:33:51 -0600

Leon Derczynski wrote:

> [...]

We don't register language subtags on our own. Those need to have an ISO 639 code element first.

I would suggest writing a proposal for the ISO 639-3 Registration Authority, following their guidelines.

https://iso639-3.sil.org/
https://iso639-3.sil.org/code_changes/submitting_change_requests

Be sure to read in particular the RA's criteria for "macrolanguage" before deciding whether you want to request that Inuktitut be converted to a macrolanguage, which would probably also require creating a new individual language code element for Inuktitut proper, and perhaps for other languages. Macrolanguages are an ISO 639-3 concept, and they are very frequently misunderstood.

--
Doug Ewell | Thornton, CO, US | ewellic.org

---

From: "Doug Ewell" <[email-masked]>
Date: Sun, 21 Jun 2020 16:24:48 -0600

Mark Davis wrote:

> That's premature at this point. They must go to ISO 639 first, and the
> bar is quite high if they fail at ISO.

Yes, and my response was also premature. We do register language subtags on our own, at least in theory. But we do require evidence that the requester has tried registering the language with ISO 639 first, and what their rejection rationale was. And we would need some very strong evidence that ISO 639 made an error in not accepting the registration, which as Mark said is a difficult challenge, because that’s what ISO 639 does.

And if we did accept such a registration, as Michael alluded, the subtag would have to be 5 to 8 letters, to avoid conflict with any future assignment of the 3-letter code element by ISO. And we would not in any event make the “macrolanguage” determination.

---

From: Leon Derczynski <[email-masked]>
Date: Tue, 23 Jun 2020 08:33:24 +0000

Dear Doug,

Thanks. I'll petition the ISO 639-3 RA. The macrolanguage fits following current ISO 639-3 status (iu is registered as a macrolanguage and, as far as I can see, is the applicable one here).

Leon
________________________________
From: Doug Ewell <[email-masked]>
Sent: 21 June 2020 23:33
To: Leon Derczynski <[email-masked]>; [email-masked] <[email-masked]>
Subject: RE: [Ietf-languages] Language subtag registrFroation form: Inuktun

---

From: "Doug Ewell" <[email-masked]>
Date: Tue, 23 Jun 2020 07:53:20 -0600

Sorry, you are correct. Inuktitut [iku] is already an ISO 639-3 macrolanguage. I don’t know how I missed that.

 �

--

 �

From: Ietf-languages <[email-masked]> On Behalf Of Leon Derczynski
Sent: Tuesday, June 23, 2020 2:33
To: Doug Ewell <[email-masked]>; [email-masked]
Subject: Re: [Ietf-languages] Language subtag registrFroation form: Inuktun

 �

Dear Doug,

 �

 �

Leon

  _____  

From: Doug Ewell <[email-masked] <mailto:[email-masked]> >
Sent: 21 June 2020 23:33
To: Leon Derczynski <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]>  <[email-masked] <mailto:[email-masked]> >
Subject: RE: [Ietf-languages] Language subtag registrFroation form: Inuktun 

 �

Leon Derczynski wrote:

> � � � � � Type: language
> � � � � � Subtag: inu
> � � � � � Description: Inuktun
> � � � � � Description: Avanersuarmiutut
> � � � � � Description: Nordgrønlandsk
> � � � � � Macrolanguage: iu