Subject: Re: [Ietf-languages] Recommendation not to register variant subtags of the form 0nnn

From: "Phillips, Addison" <[email-masked]>
Date: Wed, 29 Jul 2020 15:48:40 +0000

That would not happen with a 4-digit variant starting with a digit: they would always come at the end of a language tag. I tend to agree that we should avoid confusables and thus should be careful not to register such subtags just generally. But never is a long time and I could see someone (attempting to) register e.g. Gregorian year based subtags for well-attested years pre-1000, e.g. “ar-0661” (or maybe “ar-0072” ;-))

As I said, I agree in general principle, but wouldn’t we discuss it in specific at the time?

Addison

Addison Phillips
Sr. Principal SDE – I18N (Amazon)
Chair (W3C I18N WG)

Internationalization is not a feature.
It is an architecture.

From: Ietf-languages [mailto:[email-masked]] On Behalf Of John Cowan
Sent: Wednesday, July 29, 2020 8:09 AM
To: Martin J. Dürst <[email-masked]>
Cc: IETF Languages Discussion <[email-masked]>
Subject: RE: [EXTERNAL] [Ietf-languages] Recommendation not to register variant subtags of the form 0nnn

I don't think so.  But I want to avoid in such contexts as spreadsheets the "U.S. postal code problem", whereby the code 07104 becomes 7104 because Excel thinks it's a number rather than a string of digits.

On Wed, Jul 29, 2020 at 1:08 AM Martin J. Dürst <[email-masked]<mailto:[email-masked]>> wrote:

On 29/07/2020 11:43, John Cowan wrote:
> While BCP 47 does not forbid 4-digit variant subtags that begin with 0, I
> am hereby suggesting to the Tyrant and his Good Right Arm that such tags
> never be registered.  It would be very easy to confuse '0029' with '029'
> (Caribbean).
>
> What say you all?

Sounds good. Has such a case actually come up?

Regards,   Martin.

>
> John Cowan          http://vrici.lojban.org/~cowan        [email-masked]<mailto:[email-masked]>
> A poetical purist named Cowan                   [that's me]
> Once put the rest of us dowan.                  [on xml-dev]
> "Your verse would be sweeter / If it only had metre
> And rhymes that didn't force me to frowan."     [overpacked line!]
> --Michael Kay

---

From: John Cowan <[email-masked]>
Date: Wed, 29 Jul 2020 12:25:49 -0400

---------- Forwarded message ---------
From: John Cowan <[email-masked]>
Date: Wed, Jul 29, 2020 at 12:20 PM
Subject: Re: [Ietf-languages] Recommendation not to register variant
subtags of the form 0nnn
To: Phillips, Addison <[email-masked]>

On Wed, Jul 29, 2020 at 11:48 AM Phillips, Addison <[email-masked]>
wrote:

That would not happen with a 4-digit variant starting with a digit: they
> would always come at the end of a language tag.
>

It's true there is no actual ambiguity: 004 is always going to be a region
and 0004 is always going to be a variant, and so "qq-004" is Cuecue as used
in Africa, whereas "qq-0004" is some variant of Cuecue, not necessarily
date-based.  But human beings could easily make a mistake, because we are
used to the idea that leading zeros have no semantic meaning in a number.

> I tend to agree that we should avoid confusables and thus should be
> careful not to register such subtags just generally. But never is a long
> time and I could see someone (attempting to) register e.g. Gregorian year
> based subtags for well-attested years pre-1000, e.g. “ar-0661” (or maybe
> “ar-0072” ;-))
>

I'd go with ar-ce661 and ar-ce72 in those cases.  When speaking or writing,
I would always use a phrase like "the year 72" even when I wouldn't bother
with "the year 1958".

>  As I said, I agree in general principle, but wouldn’t we discuss it in

We would; this is just nemawashi.

John Cowan          http://vrici.lojban.org/~cowan        [email-masked]
        "Not to know The Smiths is not to know K.X.U."  --K.X.U.

---

From: "Doug Ewell" <[email-masked]>
Date: Wed, 29 Jul 2020 14:56:58 -0600

I understand the intent, although there are plenty of opportunities already for confusion.

 �

I have a colleague who often refers to the bogus tag ”en-EN” by analogy with “fr-FR” and “es-ES” and “it-IT”. (The organization doesn’t fully get that region subtags aren’t always necessary or desirable.)

 �

Our existing UN M49-based region subtags that begin with “0” are already subject to this. One of them, “en-029”, even has some currency. I don’t know if there has been any confusion around the leading zero. I know from a quick web scan that there is plenty of confusion from people who think a region subtag can only be an ISO 3166-1 code element, or who are still stuck in RFC 1766 and think a language subtag can only be two letters.

 �

I appreciate the nemawashi and suggest that we try to not enact any firm decisions, but keep this idea in mind whenever an all-numeric variant subtag is being floated.

 �

--

Doug Ewell | Thornton, CO, US | ewellic.org

 �

---

From: Peter Constable <[email-masked]>
Date: Thu, 30 Jul 2020 16:54:35 +0000

This:
> Our existing UN M49-based region subtags that begin with “0” are already subject to this.

If it hasn’t been a problem over the past 10+ years for existing and in-use numeric region subtags, it’s not clear why we would need to change anything for hypothetical variant subtags.

Peter

From: Ietf-languages <[email-masked]> On Behalf Of Doug Ewell
Sent: Wednesday, July 29, 2020 1:57 PM
To: 'John Cowan' <[email-masked]>; 'IETF Languages Discussion' <[email-masked]>
Subject: Re: [Ietf-languages] Fwd: Recommendation not to register variant subtags of the form 0nnn

---

From: John Cowan <[email-masked]>
Date: Thu, 30 Jul 2020 15:13:08 -0400

What I am suggesting is simplicity itself:

Even though 4-digit variant subtags are legal, do not register any that
begin with 0.

Instead ask the requester to use some other subtag.  Exactly what other
subtag can be settled case-by-case when the time comes.

On Thu, Jul 30, 2020 at 12:54 PM Peter Constable <[email-masked]> wrote:

> If it hasn’t been a problem over the past 10+ years for existing and
> in-use numeric region subtags, it’s not clear why we would need to change
> anything for hypothetical variant subtags.
>
>
>
>
>
> Peter
>
>
>
> *From:* Ietf-languages <[email-masked]> *On Behalf Of *Doug
> Ewell
> *Sent:* Wednesday, July 29, 2020 1:57 PM
> *To:* 'John Cowan' <[email-masked]>; 'IETF Languages Discussion' <
> [email-masked]>
> *Subject:* Re: [Ietf-languages] Fwd: Recommendation not to register
> variant subtags of the form 0nnn
>
>
>
> I have a colleague who often refers to the bogus tag ”en-EN” by analogy
> with “fr-FR” and “es-ES” and “it-IT”. (The organization doesn’t fully get
> that region subtags aren’t always necessary or desirable.)
>
>
>
> Our existing UN M49-based region subtags that begin with “0” are already
> subject to this. One of them, “en-029”, even has some currency. I don’t
> know if there has been any confusion around the leading zero. I know from a
> quick web scan that there is plenty of confusion from people who think a
> region subtag can only be an ISO 3166-1 code element, or who are still
> stuck in RFC 1766 and think a language subtag can only be two letters.
>
>
>
> I appreciate the nemawashi and suggest that we try to not enact any firm
> decisions, but keep this idea in mind whenever an all-numeric variant
> subtag is being floated.
>
>
>
> --
>

---

From: "Phillips, Addison" <[email-masked]>
Date: Thu, 30 Jul 2020 19:53:28 +0000

Hi John,

I suspect the problem is:

We don’t intend to open up BCP47 to add this to the official rules, thus this is merely a guideline or best practice that is only enforced by the judgement of the registrar as advised by this list. If we intend for there to be guidelines/best practices/learnings/policies that tag requesters should adhere to or at least consider (as learnings from having operated a subtag registry for some years now) and if these were to be written down, that might make a suitable addition for this forum to debate. It seems reasonable to me as an observation. Having a sort of “history of past debates that will inform your tag choices” in a wiki or other document might even be advisable—I am not volunteering to write it though.

We could just all say “ sure, John” and then go back to our lives, safe in the knowledge that if such a variant were proposed, the proposal being legal, the net effect would be the same—someone would have to remember and apply this as guidance and then we’d have to debate it if the requester didn’t like the proposal, with the ultimate arbiter being Michael (and/or the appeals process).

Is what you’re looking for a milestone in the archives where someone (probably Michael) says: “all things being equal, this will be my policy going forwards” so that there is something to point to later? This won’t fix the above case, but at least this group has debated it as a quondam policy upon later consumption.

Addison

From: Ietf-languages [mailto:[email-masked]] On Behalf Of John Cowan
Sent: Thursday, July 30, 2020 12:13 PM
To: Peter Constable <[email-masked]>
Cc: IETF Languages Discussion <[email-masked]>; Doug Ewell <[email-masked]>
Subject: RE: [EXTERNAL] [Ietf-languages] Fwd: Recommendation not to register variant subtags of the form 0nnn

CAUTION: This email originated from outside of the organization. Do not click links or open attachments unless you can confirm the sender and know the content is safe.

Even though 4-digit variant subtags are legal, do not register any that begin with 0.

Instead ask the requester to use some other subtag.  Exactly what other subtag can be settled case-by-case when the time comes.

On Thu, Jul 30, 2020 at 12:54 PM Peter Constable <[email-masked]<mailto:[email-masked]>> wrote:

Peter

From: Ietf-languages <[email-masked]<mailto:[email-masked]>> On Behalf Of Doug Ewell
Sent: Wednesday, July 29, 2020 1:57 PM
To: 'John Cowan' <[email-masked]<mailto:[email-masked]>>; 'IETF Languages Discussion' <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Ietf-languages] Fwd: Recommendation not to register variant subtags of the form 0nnn

--
Doug Ewell | Thornton, CO, US | ewellic.org<http://ewellic.org>