Subject: Re: [Ietf-languages] First cut at a BCP 47 extension structure for ISO TR 21636 (was: Language subtag registration form)

From: "Doug Ewell" <[email-masked]>
Date: Sat, 28 Nov 2020 23:20:48 -0700

Mark Davis wrote:
 
> The main purpose of that clause is that if variant1 modifies prefix1
> in a particular way, then variant1 shouldn't modify prefix2 in a very
> different way. It doesn't apply when there isn't a prefix, such as
> with fonipa, or anything else that represents a well-defined
> modification of previous subtags.
 
I know we once discussed a proposal to register variants 'western' and
'eastern' for Armenian, and I remember that you opposed them and cited
them for some time thereafter as an example of what not to do. I don't
remember whether those proposals included the prefix 'hy' or no prefix.
 
> It also doesn't apply to defined extensions; it is up to the spec for
> that extension to determine the right mechanisms.
 
That is certainly true.
 
> Moreover, for the highest degree of utility, the functional
> application of each value should be applicable across languages. For
> example, if 'formal' for one language is reserved for the emperor,
> while 'formal' in another language is for any people that you don't
> know well, then it becomes very difficult for developers to apply the
> value consistently.
 
This really speaks to the way these values are defined in the TR itself,
not how they translate to subtags in a BCP 47 extension.
 
> I would advise proceeding slowly and carefully; as remarked earlier
> you need to guarantee that there will not be backwards compatibility
> problems or people won't touch the extension with a 10 foot pole. So
> it would be best to make sure that each dimension's core values are
> well defined, with lots of examples from multiple languages, before
> adding each of them.
 
I agree completely. I hope that defining the framework for an extension
now will prevent rushing into it later, and allow folks to focus on
defining the values with an eye toward how they would work within that
extension and within BCP 47 generally.
 
--
Doug Ewell, CC, ALB | Thornton, CO, US | ewellic.org

---

From: Peter Constable <[email-masked]>
Date: Sun, 29 Nov 2020 20:05:12 +0000

Observation: In the case of "eastern" and "western", their meaning depends on what it is the qualify. ('East' relative to what?...) But in the case of "fonipa", there is a unique meaning that's independent of what it is qualifying.

Peter

-----Original Message-----
From: Ietf-languages <[email-masked]> On Behalf Of Doug Ewell
Sent: Saturday, November 28, 2020 10:21 PM
To: Mark Davis ☕️ <[email-masked]>
Cc: [email-masked]; Sebastian Drude <[email-masked]>
Subject: Re: [Ietf-languages] First cut at a BCP 47 extension structure for ISO TR 21636 (was: Language subtag registration form)

> modification of previous subtags.
 
I know we once discussed a proposal to register variants 'western' and 'eastern' for Armenian, and I remember that you opposed them and cited them for some time thereafter as an example of what not to do. I don't remember whether those proposals included the prefix 'hy' or no prefix.

That is certainly true.
 
> know well, then it becomes very difficult for developers to apply the 
 
This really speaks to the way these values are defined in the TR itself, not how they translate to subtags in a BCP 47 extension.
 
> well defined, with lots of examples from multiple languages, before 
 
I agree completely. I hope that defining the framework for an extension now will prevent rushing into it later, and allow folks to focus on defining the values with an eye toward how they would work within that extension and within BCP 47 generally.

_______________________________________________
Ietf-languages mailing list
[email-masked]
https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fietf-languages&amp;data=04%7C01%7C%7Ce1090e928b3142eb02bd08d8942f1173%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637422277157200948%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=sHm39ZvrgyqGz9JDZLxCjt3DTv91rcroKeqpz9aZ%2FO4%3D&amp;reserved=0