Subject: Re: [Ietf-languages] adjectival usage of variant subtags

From: Michael Everson <[email-masked]>
Date: Sat, 5 Dec 2020 03:32:11 +0000

This is why we have preferred specific subtags referring to specific entities, rather than 

northern, southern. eastern, western, northeastern, southeastern, northwestern, southwestern, central, peripheral, secret, male, female, hill, valley, plains, mountain, coastal, insular, archaic, old, middle, catholic, protestant… all of this is too vague and there would be scores of additional geographical or social generic tags. It is not wise to try to enumerate these.

Michael

> On 30 Nov 2020, at 00:16, Mark Davis ☕️ <[email-masked]> wrote:
> 
> Well, if the registry had {eastern, western, northern, southern, central} variants, then someone could have sv-northern. The meaning would be the customary meaning of 'northern' — a variety spoken in the northern part of the area of the Earth in which that language is typically spoken. It is quite common to distinguish varieties based on general geographical location: look at Kurdish.
> 
> For many languages that 'adjective' would not be particularly useful, and like any subtag, should be avoided where it does not mark a useful distinction. For example, for English it would not be particularly useful. 
>

---

From: Mark Davis ☕️ <[email-masked]>
Date: Sun, 6 Dec 2020 15:07:18 -0800

That's a strawman; one doesn't need to enumerate them.

One can have a simple policy for when it comes time to add a variant that
could have general applicability, such as "vestland" (for 'Western
Norwegian' = vestlandsk). In such a case, use the corresponding general
word "western" instead, and add to the description the example 'no-western
= Norwegian Vestlandsk'. Then there is no need to have a special variant
for Western Slovak dialects, and innumerable other cases.

Of course, where such a variant is not applicable (eg, there is no dialect
of Chickasaw that it would make sense to call 'Western'), there is no
purpose to using that variant. But that is no different than
other productive uses of language subtags, say, ja-AQ.

Mark

On Fri, Dec 4, 2020 at 7:32 PM Michael Everson <[email-masked]> wrote:

> northern, southern. eastern, western, northeastern, southeastern,
> northwestern, southwestern, central, peripheral, secret, male, female,
> hill, valley, plains, mountain, coastal, insular, archaic, old, middle,
> catholic, protestant… all of this is too vague and there would be scores of
> additional geographical or social generic tags. It is not wise to try to
> enumerate these.
>
> Michael
>
> > Well, if the registry had {eastern, western, northern, southern,
> central} variants, then someone could have sv-northern. The meaning would
> be the customary meaning of 'northern' — a variety spoken in the northern
> part of the area of the Earth in which that language is typically spoken.
> It is quite common to distinguish varieties based on general geographical
> location: look at Kurdish.
> >
> > For many languages that 'adjective' would not be particularly useful,
> and like any subtag, should be avoided where it does not mark a useful
> distinction. For example, for English it would not be particularly useful.
> >
>
> _______________________________________________
> Ietf-languages mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-languages
>

---

From: Michael Everson <[email-masked]>
Date: Mon, 7 Dec 2020 16:08:12 +0000

Northern, southern, eastern, and western are not the only valid “generic” categories. If we had these as subtags it would not help for language variants which did not “fit” the cardinal direction points. In such a case many more “generic” categories would be required. That would be a genuine instance where floodgates would be open. 

This isn’t a straw man. A straw man is “an intentionally misrepresented proposition that is set up because it is easier to defeat than an opponent’s real argument”. I know that you disagree with my long-standing decision to avoid generic subtags like this, Mark, but that does not mean that your “real” argument is better or satisfies my objections. Or that I “intentionally misrepresent” your position.

Productive use of “-AQ” is not analogous to that of “western” or “central” or “coastal” or “catholic”. 

Michael

> On 6 Dec 2020, at 23:07, Mark Davis ☕️ <[email-masked]> wrote:
> 
> One can have a simple policy for when it comes time to add a variant that could have general applicability, such as "vestland" (for 'Western Norwegian' = vestlandsk). In such a case, use the corresponding general word "western" instead, and add to the description the example 'no-western = Norwegian Vestlandsk'. Then there is no need to have a special variant for Western Slovak dialects, and innumerable other cases. 
> 
> Of course, where such a variant is not applicable (eg, there is no dialect of Chickasaw that it would make sense to call 'Western'), there is no purpose to using that variant. But that is no different than other productive uses of language subtags, say, ja-AQ.
> 
> Mark
> 
>

---

From: "Doug Ewell" <[email-masked]>
Date: Mon, 7 Dec 2020 16:06:31 -0700

Mark Davis wrote:

> One can have a simple policy for when it comes time to add a variant
> that could have general applicability, such as "vestland" (for
> 'Western Norwegian' = vestlandsk). In such a case, use the
> corresponding general word "western" instead, and add to the
> description the example 'no-western = Norwegian Vestlandsk'. Then
> there is no need to have a special variant for Western Slovak
> dialects, and innumerable other cases. 

I hope we never use the Description field to list examples of variant usage like this. There has got to be a better way. I know that some of the values provided by CLDR for the 'u' and 't' extensions are like this.

--
Doug Ewell, CC, ALB | Thornton, CO, US | ewellic.org

---

From: Peter Constable <[email-masked]>
Date: Tue, 8 Dec 2020 20:42:49 +0000

I think it should be ascertained that there aren’t cases in which “Western [language x]” is used by different communities to mean different language varieties. “Western” is relative—west of _something_---and different people might have different somethings in mind.

Peter

From: Ietf-languages <[email-masked]> On Behalf Of Mark Davis ??
Sent: Sunday, December 6, 2020 3:07 PM
To: Michael Everson <[email-masked]>
Cc: ietflang IETF Languages Discussion <[email-masked]>
Subject: Re: [Ietf-languages] adjectival usage of variant subtags

Mark

On Fri, Dec 4, 2020 at 7:32 PM Michael Everson <[email-masked]<mailto:[email-masked]>> wrote:
This is why we have preferred specific subtags referring to specific entities, rather than

Michael

> On 30 Nov 2020, at 00:16, Mark Davis ☕️ <[email-masked]<mailto:[email-masked]>> wrote:
>

_______________________________________________
Ietf-languages mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ietf-languages<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fietf-languages&data=04%7C01%7C%7C2c3562afab7a4980166408d89a3d2b42%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C1%7C637428934789433730%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=xJHDFaeUzC24RWlpHTLVLCj9smsC3Izmq1wzZBYtJnQ%3D&reserved=0>

---

From: Sebastian Drude <[email-masked]>
Date: Tue, 8 Dec 2020 17:57:17 -0300

I am possibly not knowledgeable enough to have a real valid informed 
opinion (this evidently has a long history that I am not aware of), but 
I do not see any problem with having a sub-tag like "western" which has 
a different interpretation depending on the language subtag or other 
subtags in the same language tag.

Sure, there are many languages which will not need that subtag, and 
others who will need different subtags which are only relevant to a 
small group of languages, and again others, probably the most frequent 
case, which are only relevant for one specific language (there is no 
Bavarian dialect in any other language than German).

Still, I do not see why  tags which are "adaptingly" useful for many 
languages should be ruled out in principle.  If somebody uses such a 
subtag with a language where there is no agreed "western" variety, it 
will be cryptical, but so would the combination of English and Bavarian be.

Sebastian

-- 

Museu P.E. Goeldi, CCH, Linguistica ▪ Av. Perimetral, 1901
Terra Firme, CEP: 66077-530 ▪ Belém do Pará – PA ▪ Brazil
[email-masked] ▪ +55 (91) 3217 6024 ▪ +55 (91) 983733319
Priv: Tv. Juvenal Cordeiro, 184, Apt 104 ▪ 66070-300 Belém

On 08/12/2020 17:42, Peter Constable wrote:
>
> I think it should be ascertained that there aren’t cases in which 
> “Western [language x]” is used by different communities to mean 
> different language varieties. “Western” is relative—west of 
> _/something/_---and different people might have different somethings 
> in mind.
>
> Peter
>
> *From:* Ietf-languages <[email-masked]> *On Behalf Of 
> *Mark Davis ??
> *Sent:* Sunday, December 6, 2020 3:07 PM
> *To:* Michael Everson <[email-masked]>
> *Cc:* ietflang IETF Languages Discussion <[email-masked]>
> *Subject:* Re: [Ietf-languages] adjectival usage of variant subtags
>
> Of course, where such a variant is not applicable (eg, there is no 
> dialect of Chickasaw that it would make sense to call 'Western'), 
> there is no purpose to using that variant. But that is no different 
> than other productive uses of language subtags, say, ja-AQ.
>
> Mark
>
>     northwestern, southwestern, central, peripheral, secret, male,
>     female, hill, valley, plains, mountain, coastal, insular, archaic,
>     old, middle, catholic, protestant… all of this is too vague and
>     there would be scores of additional geographical or social generic
>     tags. It is not wise to try to enumerate these.
>
>     Michael
>
>     central} variants, then someone could have sv-northern. The
>     meaning would be the customary meaning of 'northern' — a variety
>     spoken in the northern part of the area of the Earth in which that
>     language is typically spoken. It is quite common to distinguish
>     varieties based on general geographical location: look at Kurdish.
>     >
>     > For many languages that 'adjective' would not be particularly
>     useful, and like any subtag, should be avoided where it does not
>     mark a useful distinction. For example, for English it would not
>     be particularly useful.
>     >
>
>     [email-masked] <mailto:[email-masked]>
>     <https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fietf-languages&data=04%7C01%7C%7C2c3562afab7a4980166408d89a3d2b42%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C1%7C637428934789433730%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=xJHDFaeUzC24RWlpHTLVLCj9smsC3Izmq1wzZBYtJnQ%3D&reserved=0>
>
>

---

From: Richard Wordingham <[email-masked]>
Date: Tue, 8 Dec 2020 23:14:33 +0000

On Tue, 8 Dec 2020 20:42:49 +0000
Peter Constable <[email-masked]> wrote:

> _something_---and different people might have different somethings in
> mind.

Does 'Western Lao' count?  It's apparently an old name for Northern
Thai (= nod), while Wikipedia uses the term for a dialect of Lao spoken
only in Thailand, so technically a dialect of Northeastern Thai (=tts).

Northern Tai is the northern part of Zhuang, Northern Thai is the main
local language of northern Thailand, Tai Nuea (literally 'Northern
Thai') is a language spoken near the Sino-Burman border, and Tai Lue is
yet another region in the language - I've seen it claimed that 'Lue'
means 'northern'.

The southern part of Zhuang is a Central Tai language (or group), but
Central Thai is Siamese (=th), a South-Western Tai language.

Which side of the Atlantic is southern English spoken?

Richard.

---

From: Peter Constable <[email-masked]>
Date: Thu, 10 Dec 2020 06:45:08 +0000

> If somebody uses such a subtag with a language where there is no agreed "western" variety,…

That’s not a situation I’m concerned about. My concern would be the possibility that “Western X” is meaningful, but means different things to different people.

Peter

From: Sebastian Drude <[email-masked]>
Sent: Tuesday, December 8, 2020 12:57 PM
To: Peter Constable <[email-masked]>; Mark Davis ☕ <[email-masked]>; Michael Everson <[email-masked]>
Cc: ietflang IETF Languages Discussion <[email-masked]>
Subject: Re: [Ietf-languages] adjectival usage of variant subtags

I am possibly not knowledgeable enough to have a real valid informed opinion (this evidently has a long history that I am not aware of), but I do not see any problem with having a sub-tag like "western" which has a different interpretation depending on the language subtag or other subtags in the same language tag.

Sure, there are many languages which will not need that subtag, and others who will need different subtags which are only relevant to a small group of languages, and again others, probably the most frequent case, which are only relevant for one specific language (there is no Bavarian dialect in any other language than German).

Still, I do not see why  tags which are "adaptingly" useful for many languages should be ruled out in principle.  If somebody uses such a subtag with a language where there is no agreed "western" variety, it will be cryptical, but so would the combination of English and Bavarian be.

Sebastian

--

[email-masked]<mailto:[email-masked]> ▪ +55 (91) 3217 6024 ▪ +55 (91) 983733319

Peter

From: Ietf-languages <[email-masked]><mailto:[email-masked]> On Behalf Of Mark Davis ??
Sent: Sunday, December 6, 2020 3:07 PM
To: Michael Everson <[email-masked]><mailto:[email-masked]>
Cc: ietflang IETF Languages Discussion <[email-masked]><mailto:[email-masked]>
Subject: Re: [Ietf-languages] adjectival usage of variant subtags

Mark

Michael

_______________________________________________
Ietf-languages mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ietf-languages<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fietf-languages&data=04%7C01%7C%7C8f9a39a9ac2a4b537ae608d89bbbdea5%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637430578482739976%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=k9LF%2BEtXN%2B1u8tIScP6sIolGnyXu9Qu%2FQu3hJpiPIRE%3D&reserved=0>

https://www.ietf.org/mailman/listinfo/ietf-languages<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fietf-languages&data=04%7C01%7C%7C8f9a39a9ac2a4b537ae608d89bbbdea5%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637430578482989831%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=uEboBvGWT3tcrzIuAxlSQEWFtIHlR4C1Fc9DW5g3Rdw%3D&reserved=0>

---

From: Mark Davis ☕️ <[email-masked]>
Date: Fri, 11 Dec 2020 12:03:22 -0800

Thanks for raising that as a concern (it's the first one that's made sense
to me). I don't know how much of an issue this would be in practice.
Unfortunately there isn't a formal mechanism with variants to add
descriptions of combinations, such as:

ku-northern : also known as  Kurmanji

Mark

On Wed, Dec 9, 2020 at 10:45 PM Peter Constable <[email-masked]> wrote:

> That’s not a situation I’m concerned about. My concern would be the
> possibility that “Western X” is meaningful, but means different things to
> different people.
>
>
>
>
>
> Peter
>
>
>
> *From:* Sebastian Drude <[email-masked]>
> *Sent:* Tuesday, December 8, 2020 12:57 PM
> *To:* Peter Constable <[email-masked]>; Mark Davis ☕ <[email-masked]>;
> Michael Everson <[email-masked]>
> opinion (this evidently has a long history that I am not aware of), but I
> do not see any problem with having a sub-tag like "western" which has a
> different interpretation depending on the language subtag or other subtags
> in the same language tag.
>
> Sure, there are many languages which will not need that subtag, and others
> who will need different subtags which are only relevant to a small group of
> languages, and again others, probably the most frequent case, which are
> only relevant for one specific language (there is no Bavarian dialect in
> any other language than German).
>
> languages should be ruled out in principle.  If somebody uses such a subtag
> with a language where there is no agreed "western" variety, it will be
> cryptical, but so would the combination of English and Bavarian be.
>
> Sebastian
>
>
>
> --
>
>
>
> I think it should be ascertained that there aren’t cases in which “Western
> [language x]” is used by different communities to mean different language
> varieties. “Western” is relative—west of _*something*_---and different
> people might have different somethings in mind.
>
>
>
>
>
> Peter
>
>
>
> *From:* Ietf-languages <[email-masked]>
> <[email-masked]> *On Behalf Of *Mark Davis ??
> *To:* Michael Everson <[email-masked]> <[email-masked]>
> <[email-masked]>
> <https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fietf-languages&data=04%7C01%7C%7C8f9a39a9ac2a4b537ae608d89bbbdea5%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637430578482739976%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=k9LF%2BEtXN%2B1u8tIScP6sIolGnyXu9Qu%2FQu3hJpiPIRE%3D&reserved=0>
>
>
>
> https://www.ietf.org/mailman/listinfo/ietf-languages <https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fietf-languages&data=04%7C01%7C%7C8f9a39a9ac2a4b537ae608d89bbbdea5%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637430578482989831%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=uEboBvGWT3tcrzIuAxlSQEWFtIHlR4C1Fc9DW5g3Rdw%3D&reserved=0>
>
>

---

From: "Doug Ewell" <[email-masked]>
Date: Fri, 11 Dec 2020 15:00:20 -0700

> ku-northern : also known as  Kurmanji

There can always be multiple Comments fields:

Type: variant
Subtag: northern
Description: <some suitably general description>
Added: 20xx-xx-xx
Comments: "ku-northern" is also known as Kurmanji
Comments: "qa-northern" is also known as This
Comments: "qb-northern" is also known as That
...

---

From: Mark Davis ☕️ <[email-masked]>
Date: Fri, 11 Dec 2020 14:31:30 -0800

Ah, good point.

Mark