Subject: Re: [Ietf-languages] Script subtag registrations

From: Sebastian Drude <[email-masked]>
Date: Mon, 1 Feb 2021 18:38:08 -0300

Dear Doug, all,

As you know, I am new to this, so please bear with me...

I see that the information provided is rather sketchy, no references to 
external documents...

Probably this is due to the fact that these changes are being proposed 
merely in order to sync with ISO 15924, where the respective material 
that  support these new script records have already been checked -- is 
that correct?  In that case, I have no objections.  Otherwise I would 
like to know whether this forum always decides on such a (in my view) 
thin basis?

Contentwise, there is of course no doubt to me that these scripts did 
exist, were different from other scripts and that they should receive 
codes if these are needed.

Best,

Sebastian (Drude)

-- 

Museu P.E. Goeldi, CCH, Linguistica ▪ Av. Perimetral, 1901
Terra Firme, CEP: 66077-530 ▪ Belém do Pará – PA ▪ Brazil
[email-masked] ▪ +55 (91) 3217 6024 ▪ +55 (91) 983733319
Priv: Tv. Juvenal Cordeiro, 184, Apt 104 ▪ 66070-300 Belém

On 28/01/2021 20:53, Doug Ewell wrote:
> Five new script code elements have been added to ISO 15924:
>
> Ougr — Old Uyghur
> Pcun — Proto-Cuneiform
> Pelm — Proto-Elamite
> Psin — Proto-Sinaitic
> Ranj — Ranjana
>
> Below are the proposed records and registration forms for the five that have been approved. Please review them during the two-week review period ending Thursday, February 11 AoE.
>
> Another two scripts will likely be added to 15924 in the coming weeks. If those two are available before these first five are submitted to IANA, I suggest we wait and submit all seven to IANA at once, to streamline things a bit for them.
>
> --
>
> LANGUAGE SUBTAG MODIFICATION
> File-Date: 2021-xx-xx
> %%
> Type: script
> Subtag: Ougr
> Description: Old Uyghur
> Added: 2021-xx-xx
> %%
>
> --
>
> LANGUAGE SUBTAG REGISTRATION FORM
>
> 1. Name of requester: Doug Ewell
> 2. E-mail address of requester: doug at ewellic.org
>
> 3. Record Requested:
>
> Type: script
> Subtag: Ougr
> Description: Old Uyghur
>
> 4. Intended meaning of the subtag:
>
> 5. Reference to published description of the language (book or article):
>
> 6. Any other relevant information:
>
> This registration tracks a change made to ISO 15924 effective
> 2021-01-25, adding the code element 'Ougr' for Old Uyghur.
>
> --
>
> LANGUAGE SUBTAG MODIFICATION
> File-Date: 2021-xx-xx
> %%
> Type: script
> Subtag: Pcun
> Description: Proto-Cuneiform
> Added: 2021-xx-xx
> %%
>
> --
>
> LANGUAGE SUBTAG REGISTRATION FORM
>
> 1. Name of requester: Doug Ewell
> 2. E-mail address of requester: doug at ewellic.org
>
> 3. Record Requested:
>
> Type: script
> Subtag: Pcun
> Description: Proto-Cuneiform
>
> 4. Intended meaning of the subtag:
>
> 5. Reference to published description of the language (book or article):
>
> 6. Any other relevant information:
>
> This registration tracks a change made to ISO 15924 effective
> 2021-01-25, adding the code element 'Pcun' for Proto-Cuneiform.
>
> --
>
> LANGUAGE SUBTAG MODIFICATION
> File-Date: 2021-xx-xx
> %%
> Type: script
> Subtag: Pelm
> Description: Proto-Elamite
> Added: 2021-xx-xx
> %%
>
> --
>
> LANGUAGE SUBTAG REGISTRATION FORM
>
> 1. Name of requester: Doug Ewell
> 2. E-mail address of requester: doug at ewellic.org
>
> 3. Record Requested:
>
> Type: script
> Subtag: Pelm
> Description: Proto-Elamite
>
> 4. Intended meaning of the subtag:
>
> 5. Reference to published description of the language (book or article):
>
> 6. Any other relevant information:
>
> This registration tracks a change made to ISO 15924 effective
> 2021-01-25, adding the code element 'Pelm' for Proto-Elamite.
>
> --
>
> LANGUAGE SUBTAG MODIFICATION
> File-Date: 2021-xx-xx
> %%
> Type: script
> Subtag: Psin
> Description: Proto-Sinaitic
> Added: 2021-xx-xx
> %%
>
> --
>
> LANGUAGE SUBTAG REGISTRATION FORM
>
> 1. Name of requester: Doug Ewell
> 2. E-mail address of requester: doug at ewellic.org
>
> 3. Record Requested:
>
> Type: script
> Subtag: Psin
> Description: Proto-Sinaitic
>
> 4. Intended meaning of the subtag:
>
> 5. Reference to published description of the language (book or article):
>
> 6. Any other relevant information:
>
> This registration tracks a change made to ISO 15924 effective
> 2021-01-25, adding the code element 'Psin' for Proto-Sinaitic.
>
> --
>
> LANGUAGE SUBTAG MODIFICATION
> File-Date: 2021-xx-xx
> %%
> Type: script
> Subtag: Ranj
> Description: Ranjana
> Added: 2021-xx-xx
> %%
>
> --
>
> LANGUAGE SUBTAG REGISTRATION FORM
>
> 1. Name of requester: Doug Ewell
> 2. E-mail address of requester: doug at ewellic.org
>
> 3. Record Requested:
>
> Type: script
> Subtag: Ranj
> Description: Ranjana
>
> 4. Intended meaning of the subtag:
>
> 5. Reference to published description of the language (book or article):
>
> 6. Any other relevant information:
>
> This registration tracks a change made to ISO 15924 effective
> 2021-01-25, adding the code element 'Ranj' for Ranjana.
>
> --
> Doug Ewell, CC, ALB | Thornton, CO, US | ewellic.org
>
>
> _______________________________________________
> Ietf-languages mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-languages

---

From: "Doug Ewell" <[email-masked]>
Date: Mon, 1 Feb 2021 15:16:37 -0700

Hi Sebastian,

This is a good question for someone new to the system.

We register two broad classes of subtags into the Language Subtag Registry:

1. those that are based on one of the core standards, and
2. those that are not.

Primary language subtags that are 2 or 3 letters long, extended language (extlang) subtags, script subtags, and region subtags are based on one of ISO 639-1, 639-2, 639-3, 639-5, 3166-1, 15924, or UN M49. When a change is made to the code list of one of these standards, we register one or more subtags to reflect that change, and in that case the only justification that is needed is to keep up with the core standards. They have their own review committees and we do not second-guess their decisions. The main purpose of the two-week review is to check the proposed subtag for clerical errors, such as typos. These proposals are almost never rejected.

Variant subtags are proposed on this list by individuals (who may represent an organization or group). The list may debate whether the variant actually exists, whether the subtag value and Description field(s) are "good" (i.e. representative of the variant, meaningful, unlikely to be confused with another), whether the references are sufficient, and so on. Good justification is usually required to support the request, since we are the review committee. At the end of the review period, the Reviewer either accepts or rejects the proposal or extends the review period for more discussion; all of these outcomes commonly occur.

The latter scenario would also apply to primary language subtags 5 to 8 letters long, although we have never registered one and there would be intense resistance against any attempt to do so.

Hope this helps,

-----Original Message-----
From: Ietf-languages <[email-masked]> On Behalf Of Sebastian Drude
Sent: Monday, February 1, 2021 14:38
To: Doug Ewell <[email-masked]>; [email-masked]
Subject: Re: [Ietf-languages] Script subtag registrations

Dear Doug, all,

I see that the information provided is rather sketchy, no references to external documents...

Probably this is due to the fact that these changes are being proposed merely in order to sync with ISO 15924, where the respective material that  support these new script records have already been checked -- is that correct?  In that case, I have no objections.  Otherwise I would like to know whether this forum always decides on such a (in my view) thin basis?

Contentwise, there is of course no doubt to me that these scripts did exist, were different from other scripts and that they should receive codes if these are needed.

Best,

Sebastian (Drude)

-- 

Museu P.E. Goeldi, CCH, Linguistica ▪ Av. Perimetral, 1901 Terra Firme, CEP: 66077-530 ▪ Belém do Pará – PA ▪ Brazil [email-masked] ▪ +55 (91) 3217 6024 ▪ +55 (91) 983733319
Priv: Tv. Juvenal Cordeiro, 184, Apt 104 ▪ 66070-300 Belém

---

From: Sebastian Drude <[email-masked]>
Date: Mon, 1 Feb 2021 19:52:04 -0300

Thanks, dear Hugh and Doug,

for your explanations!  This is all very clear and along the lines I 
would have expected.

I cannot see any misspellings or errors.  I do not yet know how to 
access the database with all registered subtags, so I cannot well judge 
whether any confusion with existing language subtags is likely.

Thanks again,

Sebastian

--

---

From: "Doug Ewell" <[email-masked]>
Date: Mon, 1 Feb 2021 16:10:08 -0700

> I do not yet know how to access the database with all registered
> subtags

https://www.iana.org/assignments/language-subtag-registry

---

From: Sebastian Drude <[email-masked]>
Date: Mon, 1 Feb 2021 20:43:45 -0300

Great, thanks!

Sebastian

--