Subject: [Ietf-languages] Region codes

From: "David Mediavilla" <[email-masked]>
Date: Mon, 19 Apr 2021 23:47:16 +0000

About the standardizing of prefixes for the subtags for variants of the Occitan language, I understand that the use of region codes does not interfere with the prefixes, does it?
Examples:
* https://oc.wikipedia.org/wiki/La_G%C3%A0rdia tells me that in Guardia Piemontese, Calabria, Italy, a local version of Vivaro-Alpine is spoken (oc-IT-vivaraup, I guess).
* https://en.wikipedia.org/wiki/Pig%C3%BC%C3%A9 Pigüé in Argentina was colonized by Occitans. I guess their language would be tagged as oc-AR-lengadoc.

While I don't know if these concrete examples are important, I wanted to make sure that the possibility of tagging the regions is not lost with the new prefixes.

Thanks for looking at the issue.
--
David Mediavilla

---

From: "Doug Ewell" <[email-masked]>
Date: Tue, 20 Apr 2021 09:19:28 -0600

David Mediavilla wrote:

> About the standardizing of prefixes for the subtags for variants of 
> the Occitan language, I understand that the use of region codes does 
> not interfere with the prefixes, does it?

Correct. You can freely interpose a region (and/or script) subtag into such a tag, even when using multiple variants where the first variant is part of the Prefix value for the second.

The general rule about region and script subtags is that they should be used in language tags only when they add information. Your example "oc-AR-lengadoc" is syntactically fine, but the region subtag 'AR' should be used only if the usage of Languedocien in Argentina differs in some meaningful way from its usage elsewhere.

--
Doug Ewell, CC, ALB | Lakewood, CO, US | ewellic.org