Subject: [Ietf-languages] More information on Gallo and a call for action

From: "Doug Ewell" <[email-masked]>
Date: Tue, 20 Jul 2021 13:06:39 -0600

A longtime contributor to this list, who may or may not wish to remain anonymous, pointed out in private correspondence that the website of the Institut du Galo has plenty of Gallo text samples:

	https://institutdugalo.bzh/go/se-former-2/
	"La bone arive > Aprendr

	"Le galo s’aprend a l’entour de céz vous !
	Nen peut aprendr le galo long la vie. Nen chaot pouint qu’ous sejiéz ebluçons ou ben qu’ous sonjiéz qu’ous caozéz déja ben la langue, vous pouéz terouer une grande ôfr d’ensegnement pour le monde venû den hardi d’endrets."

In fact, as you might guess, the site offers plenty of pages of Gallo content, not just this one passage. Web pages are one of the classic examples of content that is suitable for BCP 47 tags.

Unfortunately, in the absence of an appropriate tag, the Institut has chosen to invent its own, non–private-use tagging:

<!--[if lt IE 7 ]><html class="ie ie6" lang="go-GO"> <![endif]-->
<!--[if IE 7 ]><html class="ie ie7" lang="go-GO"> <![endif]-->
<!--[if IE 8 ]><html class="ie ie8" lang="go-GO"> <![endif]-->
<!--[if (gte IE 9)|!(IE)]><!--><html lang="go-GO"> <!--<![endif]-->
<head>
	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=edge">
	<meta name="viewport" content="width=device-width, initial-scale=1">

	<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<link rel="alternate" href="https://institutdugalo.bzh/go/linstitut-2/" hreflang="go" />
<link rel="alternate" href="https://institutdugalo.bzh/fr/linstitut/" hreflang="fr" />

There is no 'go' language subtag, for Gallo or any other language. (The tag "go-GO" is even worse: there is no 'GO' region subtag either; there is no country called "Gallo" or similar that such a subtag would represent; the correct region subtag would be 'FR' for France; and of course such a subtag is unnecessary anyway since there is no need to distinguish "Gallo as used in France" from Gallo as used anywhere else.)

The site's UI also offers users a choice to click "GO" for the Gallo version of the site, or "FR" for the French version.

The designers probably won't change the UI to offer "FR-GALLO" versus "FR" — that might not be catchy enough for UI — but we can at least provide a subtag that would allow all this internal "go" and "go-GO" nonsense to be replaced with real BCP 47 tagging.

BCP 47 does not require that the requester of a subtag be in personal possession of material that would be tagged with the proposed subtag. In fact, I'm not sure it even requires evidence that such content exists at all, although we generally expect some sort of proof of that. For Gallo, this appears to be well covered.

I ask the Reviewer to state, formally and promptly, whether this request is accepted, rejected, or held for a two-week extension of the review period.

--
Doug Ewell, CC, ALB | Lakewood, CO, US | ewellic.org

---

From: Michael Everson <[email-masked]>
Date: Wed, 21 Jul 2021 23:13:25 +0100

Extend for two weeks, to ask:

Is there one or more than one more or less agreed spelling for this? I would be happier with references that were, you know, orthographic and somewhat normative. (Such things exist for varieties of Walloon.) Can anything be found?

Thank you
Michael

---

From: Hugh Paterson III <[email-masked]>
Date: Wed, 21 Jul 2021 20:06:54 -0400

While it is not in my preview to directly challenge the decision for
extension to look for standardized “spelling resources”... how is such a
decision to apply for or be relevant to the tagging of audio documents?

- Hugh

On Wed, Jul 21, 2021 at 6:13 PM Michael Everson <[email-masked]>
wrote:

> Is there one or more than one more or less agreed spelling for this? I
> would be happier with references that were, you know, orthographic and
> somewhat normative. (Such things exist for varieties of Walloon.) Can
> anything be found?
>
> Thank you
> Michael
>
> _______________________________________________
> Ietf-languages mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-languages
>
-- 
All the best,
-Hugh

Sent from my iPhone
Paris, France

---

From: "Doug Ewell" <[email-masked]>
Date: Wed, 21 Jul 2021 18:25:14 -0600

> somewhat normative. (Such things exist for varieties of Walloon.) Can

This is an interesting question. Rembert has not mentioned anything about orthography or needing to tag as to orthography, but for some applications it might be desirable or even necessary.

The French Wikipedia article on Gallo (https://fr.wikipedia.org/wiki/Gallo#%C3%89criture) identifies five orthographies: ELG ("écrire le gallo"), Aneit, Vantyé, MOGA, and ABCD (for its developers). The differences are due to such features as "classical" versus "modern" spelling, imitation of French or Breton norms versus independence from them, and attempts to optimize for the Gallo spoken in a particular subregion.

This article contains a fairly extensive published bibliography and a list of 125 "other sources." Someone more fluent in French than I am (that's not hard) can go through the references and probably find what Michael is looking for, but I did spot these at a minimum which appear to be orthography-related:

http://gallo-es-ecole.net/_media/ens/ecriture_abcd.pdf
http://www.chubri-galo.bzh/docs/files/z-ortograf/Regles-orthograph-gallo-moga-05-2016.pdf
https://web.archive.org/web/20071130165010/http://www.maezoe.com/graphie5.htm

Appropriate sub-subtags for Gallo orthographies, if desired, would require a bit of thought. 'aneit' and 'vantye' would be straightforward, but 'elg' and 'moga' and 'abcd' don't meet the length requirements. This shouldn't be difficult. Of course, these should have the Prefix value "fr-gallo".

With all of this said, I would think that 'gallo' could be registered on its own — again, Rembert hasn't asked for orthography tagging — and then the sub-subtags could always be registered later if there is a need. We've done that before. BCP 47 explicitly mentions "lack of a standardized orthography" as a non–deal-breaker for registering a variant. And of course Hugh's argument applies as well: not all content in language or dialect X needs to be tagged as to spelling, least of all spoken content.

---

From: Sebastian Drude <[email-masked]>
Date: Wed, 21 Jul 2021 21:45:29 -0300

Wow.  That was a very quick and comprehensive answer to this question.  
I agree with the last paragraph entirely.

Sebastian

-- 
Museu P.E. Goeldi, CCH, Linguistica ▪ Av. Perimetral, 1901
Terra Firme, CEP: 66077-530 ▪ Belém do Pará – PA ▪ Brazil
[email-masked] ▪ +55 (91) 3217 6024 ▪ +55 (91) 983733319
Priv: Tv. Juvenal Cordeiro, 184, Apt 104 ▪ 66070-300 Belém

---

From: Michael Everson <[email-masked]>
Date: Thu, 22 Jul 2021 23:36:27 +0100

I would like the record to assist users by giving citations of one or more of the better and better-used sources for orthographic choices. It is not unusual for me to look for dictionaries. 

Thank you. A fortnight should be enough.

Michael Everson

> On 22 Jul 2021, at 01:25, Doug Ewell <[email-masked]> wrote:
> 
> Michael Everson wrote:
>

---

From: "Doug Ewell" <[email-masked]>
Date: Thu, 22 Jul 2021 21:30:36 -0600

> I would like the record to assist users by giving citations of one or
> more of the better and better-used sources for orthographic choices.
> It is not unusual for me to look for dictionaries.

By "the record" I assume you mean the registration form, in Section 5, "Reference to published description of the language (book or article)." Putting such a reference literally in the record that goes into the Registry, as a Comments value, would be unprecedented and a bit bizarre.

I still don't think this has traditionally been a requirement, but I'll work with Rembert to pick the most common orthography/ies and make sure the registration form has reference/s to it/them. This may not be an obvious choice: ELG is the oldest and possibly the best established; Aneit may be promoted by the often-cited Bertègn Galèzz association; ABCD was co-created by Régis Auffray, one of whose works Rembert has already cited.

---

From: Arthur Rosendahl <[email-masked]>
Date: Fri, 23 Jul 2021 12:14:38 +0200

> I still don't think this has traditionally been a requirement, but I'll work with Rembert to pick the most common orthography/ies and make sure the registration form has reference/s to it/them. Thi…

  It does seem like the most authoritative source on all these
orthographies is, after all, the French-language Wikipedia article.
It’s otherwise very hard to find a reference that mentions more than a
couple of them, and the context is usually advocacy of one particular
orthography.  I did find https://www.grin.com/document/496899 though,
that looks a little bit like a master’s thesis.

	Arthur

---

From: Shawn Steele <[email-masked]>
Date: Fri, 23 Jul 2021 21:50:01 +0000

I'm a little confused by the suggestion of an orthography being required.  Certainly there are languages/dialects that aren't even written, so that seems like an odd thing to require (to me). 

Granted it might help differentiate variants to have orthographical examples - but I don’t think the registry's the right place to create rules on how to differentiate the things it provides labels for.  The registry's merely providing a convention for folks to use that do know how to/want to differentiate these things.

There seems to me to be enough evidence for Gallo to make it worthy of a subtag.

-Shawn