Subject: Re: [Ietf-languages] subtag registration

From: Saašha Metsärantala <[email-masked]>
Date: Thu, 5 Aug 2021 12:25:16 +0200 (CEST)

Hello!

Thanks a lot to all of you for your helpful answers! (Unfortunately, your answer "Date: Wed, 4 Aug 2021 08:30:32 -0700" was empty when it came to me, Mark)

I have no more questions about this this topic, but I appreciated this concise and focused discussion.

I would like to add a small (but hopefully useful) clarification: I agree that LaTeX is usually more of a markup language, than a mathematical notation. I am also used to MIME types and know that it should of course be used when pointing to a whole document. Nonetheless, in many circumstances, short LaTeX expressions (no whole LaTeX documents) are used to write (short) mathematical expressions within other markup languages (or similar) and I was thinking about such contexts.

An obvious example of that is JATS, which is a very common XML based markup language used for many scientific publications, where mathematical expressions are often written as short LaTeX expressions as textContent in JATS's own XML elements. There are other examples.

Somewhat similarly, Wikipedia often uses short LaTeX expressions to write mathematical expressions within its own markup language.

My original thought was that in XML (or other markup) contexts, when only a short mathematical expression is written in LaTeX within a markup language, the use of xml:lang="zxx-Zmth" could be appropriate to clarify the format of the textual content of the XML element.

Anyway: I am satisfied with this little conversation and I warmly wish you good luck to all of you with the important work you achieve.

Regards!

Saašha,

---

From: Peter Constable <[email-masked]>
Date: Sat, 7 Aug 2021 18:27:44 +0000

Xml:lang should be used to indicate the human language of content, not the nature of markup. If an element <foo> contains a short math expression represented using LaTeX, then <foo xml:lang="zxx"> would be appropriate.

Peter

-----Original Message-----
From: Ietf-languages <[email-masked]> On Behalf Of Saašha Metsärantala
Sent: August 5, 2021 3:25 AM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [Ietf-languages] subtag registration

Hello!

Regards!

Saašha,

_______________________________________________
Ietf-languages mailing list
[email-masked]
https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fietf-languages&amp;data=04%7C01%7C%7Ce2d5b017526f49e9567e08d957fb5d8b%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637637559388404382%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=wU52P%2Fi0N%2B77tz8rg5%2FehtuHfnlknSruurU6fntRIGI%3D&amp;reserved=0

---

From: Shawn Steele <[email-masked]>
Date: Mon, 9 Aug 2021 21:25:24 +0000

Wouldn't <latex> be more helpful?  Or some other appropriate attribute on the XML markup?  Sure, it's not linguistic content, but I'm not sure how tagging it as not being linguistic helps anything. 

Similar examples, like HTML's <script> tag don't need a linguistic language tag declaration, nor would one be helpful.

This seems like a question more appropriate for whatever document markup specification is being used.  Random XML markup with a private meaning isn't going to help anything unless it's part of a standard other applications are willing to consume.  Otherwise you may as well just tag it as anything as you'll only be talking to yourself.

-Shawn

-----Ursprüngliche Nachricht-----
Von: Ietf-languages <[email-masked]> Im Auftrag von Peter Constable
Gesendet: Saturday, August 7, 2021 11:28 AM
An: Saašha Metsärantala <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Betreff: Re: [Ietf-languages] subtag registration

Peter

-----Original Message-----
From: Ietf-languages <[email-masked]> On Behalf Of Saašha Metsärantala
Sent: August 5, 2021 3:25 AM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [Ietf-languages] subtag registration

Hello!

Regards!

Saašha,

_______________________________________________
Ietf-languages mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf-languages

---

From: Peter Constable <[email-masked]>
Date: Fri, 13 Aug 2021 15:55:08 +0000

I should have been clearer. The intent of my suggestion was that, _if_ you want to specify xml:lang on that element, then "zxx" would be the appropriate value. I wasn't necessarily suggesting it was necessary to assign an xml:lang value for that element, though.

Peter

-----Original Message-----
From: Shawn Steele <[email-masked]> 
Sent: August 9, 2021 2:25 PM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: AW: [Ietf-languages] subtag registration

-Shawn

-----Ursprüngliche Nachricht-----
Von: Ietf-languages <[email-masked]> Im Auftrag von Peter Constable
Gesendet: Saturday, August 7, 2021 11:28 AM
An: Saašha Metsärantala <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Betreff: Re: [Ietf-languages] subtag registration

Peter

-----Original Message-----
From: Ietf-languages <[email-masked]> On Behalf Of Saašha Metsärantala
Sent: August 5, 2021 3:25 AM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [Ietf-languages] subtag registration

Hello!

Regards!

Saašha,

_______________________________________________
Ietf-languages mailing list
[email-masked]
https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fietf-languages&amp;data=04%7C01%7C%7C78f4b746b64444673e4508d95b7c355a%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637641411299963398%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=HYr3mQvaMtqJKnkFYC8R918O4lfLkh7N1dMCWamRAxo%3D&amp;reserved=0

_______________________________________________
Ietf-languages mailing list
[email-masked]
https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fietf-languages&amp;data=04%7C01%7C%7C78f4b746b64444673e4508d95b7c355a%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637641411299963398%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=HYr3mQvaMtqJKnkFYC8R918O4lfLkh7N1dMCWamRAxo%3D&amp;reserved=0