Subject: Re: [Ietf-languages] subtag registration

From: Saašha Metsärantala <[email-masked]>
Date: Wed, 4 Aug 2021 17:30:27 +0200 (CEST)

Hello!

Thanks to all of you who answered my e-mail!

> This should be achieved via a mime-type (application/x-tex or application/x-latex) or similar mechanisms, not a language tag.

Thanks for this clarification!

> We realize that 'Zmth' (Mathematical notation) is a valid BCP 47 script subtag, based on its existence as an ISO 15924 code element. However, it is not really intended to serve as a base for variants

OK! I would suggest to clarify a couple of things in the relevant documents:

• Zmth "is not really intended to serve as a base for variants" (as you wrote above)

• Would you consider xml:lang="zxx-Zmth-x-LaTeX" (with "-x") acceptable in private contexts?

• Would it be appropriate for XML schema designers to use xlink:href="data:application/x-latex;base64,XGRvY3VtZW50Y2xhc3Nb …" (and similar) within an XML attribute instead of an element's textContent?

• Is xml:lang="zxx-Zmth" (without "-LaTeX") still appropriate as a portable attribute for XML elements containing TeX expressions (containing only a mathematical expression) without any human language content?

Thanks a lot to all of you!

Regards!

Saašha,

---

From: "Phillips, Addison" <[email-masked]>
Date: Wed, 4 Aug 2021 15:41:13 +0000

The -x subtag is for private use. You can use it for whatever you want. You should probably bear in mind the cautions on this thread, though.

The tag `zxx-Zmth` is well-formed and valid and one might use it for tagging a mathematical expression, although I'm not sure what value the script subtag is adding there?

Thanks,

Addison

Addison Phillips
Sr. Principal SDE – I18N (Amazon)
Chair I18N WG, Amazon ACRep (W3C)

Internationalization is not a feature.
It is an architecture.

-----Original Message-----
From: Ietf-languages <[email-masked]> On Behalf Of Saašha Metsärantala
Sent: Wednesday, August 4, 2021 8:30 AM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [EXTERNAL] [Ietf-languages] subtag registration

CAUTION: This email originated from outside of the organization. Do not click links or open attachments unless you can confirm the sender and know the content is safe.

Hello!

Regards!

Saašha,

_______________________________________________
Ietf-languages mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf-languages

---

From: "Doug Ewell" <[email-masked]>
Date: Wed, 4 Aug 2021 10:12:51 -0600

My opinion is that LaTeX still isn't a "mathematical notation" but a text markup language, and so "zxx-Zmth" still isn't very appropriate for tagging it.

Private-use tagging is up to you, so in a private context you could certainly use "zxx-Zmth-x-latex". A better choice might be "zxx-x-latex" (leaving out the script subtag as Addison noted). But note that web pages have a habit of not being private contexts for very long. Note also the convention of writing subtags in all lowercase (except region subtags like 'SE' and script subtags).

It might be good if there were a guidance document someplace on how to identify content in computer languages or markup languages, given the long-standing statement that BCP 47 tags aren't it.

--
Doug Ewell, CC, ALB | Lakewood, CO, US | ewellic.org

-----Original Message-----
From: Saašha Metsärantala <[email-masked]> 
Sent: Wednesday, August 4, 2021 9:30
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [Ietf-languages] subtag registration

Hello!

Regards!

Saašha,

---

From: Kent Karlsson <[email-masked]>
Date: Thu, 5 Aug 2021 00:07:14 +0200

See https://www.iana.org/assignments/media-types/media-types.xhtml:

text/troff (troff can format math expressions)
application/mathematica
application/mathml+xml
application/mathml-content+xml	
application/mathml-presentation+xml
text/vnd.latex-z (intended for Z notation via LaTeX, but otherwise very close to what you seem to be looking for)
application/vnd.wolfram.mathematica
application/vnd.wolfram.mathematica.package

You seem to be looking for something like those. You can use "text/x.latex-math" (a private use media type) without registering it.

You also need to consider that LaTeX math expressions often depend on document specific definitions of symbols, and they are often ”far away” from the math expression itself. You probably want each labelled math expression to be ”self-contained” in that it only depends on what is built-in to LaTeX.

/Kent K

> 4 aug. 2021 kl. 17:30 skrev Saašha Metsärantala <[email-masked]>:
> 
> Hello!
>