Subject: [Ietf-languages] Forms for ISO 639-3 changes: part 4

From: "Doug Ewell" <[email-masked]>
Date: Wed, 9 Feb 2022 23:50:44 -0700

Here is part 4 of the ISO 639-3 changes, "Updates: Name, Scope, Macrolanguage membership, Denotation changes."

This section mostly consists of new Description fields added to existing subtags, but there are a few twists. Some 639-3 code elements had their type changed from "living" to "extinct" or back. This is not a field we mirror in the Registry, so no change was made. In other cases, a code element was noted as having its scope expanded by inclusion of another language, which really means the code element for the second language was retired. These are treated similarly to the deprecations in part 1. 

---

LANGUAGE SUBTAG MODIFICATION
File-Date: 2022-xx-xx
%%
Type: language
Subtag: fit
Description: Tornedalen Finnish
Description: Meänkieli
Added: 2009-07-29
%%

---

LANGUAGE SUBTAG REGISTRATION FORM

1. Name of requester: Doug Ewell
2. E-mail address of requester: doug at ewellic.org

3. Record Requested:

Type: language
Subtag: fit
Description: Tornedalen Finnish
Description: Meänkieli

4. Intended meaning of the subtag:

5. Reference to published description of the language (book or article):

6. Any other relevant information:

This registration tracks a change made to ISO 639-3 effective
2022-01-20, adding the additional name "Meänkieli" for the existing code
element 'fit'.

For more information on the ISO 639-3 change, refer to:
https://iso639-3.sil.org/sites/iso639-3/files/reports/639-3_ChangeRequests_2021_Summary.pdf

---

LANGUAGE SUBTAG MODIFICATION
File-Date: 2022-xx-xx
%%
Type: language
Subtag: brb
Description: Brao
Description: Lave
Added: 2009-07-29
%%

---

LANGUAGE SUBTAG REGISTRATION FORM

1. Name of requester: Doug Ewell
2. E-mail address of requester: doug at ewellic.org

3. Record Requested:

Type: language
Subtag: brb
Description: Brao
Description: Lave

4. Intended meaning of the subtag:

5. Reference to published description of the language (book or article):

6. Any other relevant information:

This registration tracks a change made to ISO 639-3 effective
2022-01-20, adding "Brao" as the reference name for 'brb' and retaining
"Lave" as an additional name.

For more information on the ISO 639-3 change, refer to:
https://iso639-3.sil.org/sites/iso639-3/files/reports/639-3_ChangeRequests_2021_Summary.pdf

---

LANGUAGE SUBTAG MODIFICATION
File-Date: 2022-xx-xx
%%
Type: language
Subtag: xmx
Description: Salawati
Description: Maden
Added: 2009-07-29
%%

---

LANGUAGE SUBTAG REGISTRATION FORM

1. Name of requester: Doug Ewell
2. E-mail address of requester: doug at ewellic.org

3. Record Requested:

Type: language
Subtag: xmx
Description: Salawati
Description: Maden

4. Intended meaning of the subtag:

5. Reference to published description of the language (book or article):

6. Any other relevant information:

This registration tracks a change made to ISO 639-3 effective
2022-01-20, adding "Salawati" as the reference name for 'xmx' and
retaining "Maden" as an additional name.

For more information on the ISO 639-3 change, refer to:
https://iso639-3.sil.org/sites/iso639-3/files/reports/639-3_ChangeRequests_2021_Summary.pdf

---

LANGUAGE SUBTAG MODIFICATION
File-Date: 2022-xx-xx
%%
Type: language
Subtag: pzn
Description: Jejara Naga
Description: Para Naga
Added: 2009-07-29
%%

---

LANGUAGE SUBTAG REGISTRATION FORM

1. Name of requester: Doug Ewell
2. E-mail address of requester: doug at ewellic.org

3. Record Requested:

Type: language
Subtag: pzn
Description: Jejara Naga
Description: Para Naga

4. Intended meaning of the subtag:

5. Reference to published description of the language (book or article):

6. Any other relevant information:

This registration tracks a change made to ISO 639-3 effective
2022-01-20, adding "Jejara Naga" as the reference name for 'pzn' and
retaining "Para Naga" as an additional name.

For more information on the ISO 639-3 change, refer to:
https://iso639-3.sil.org/sites/iso639-3/files/reports/639-3_ChangeRequests_2021_Summary.pdf

---

LANGUAGE SUBTAG MODIFICATION
File-Date: 2022-xx-xx
%%
Type: language
Subtag: xkk
Description: Kachok
Description: Kaco'
Added: 2009-07-29
%%

---

LANGUAGE SUBTAG REGISTRATION FORM

1. Name of requester: Doug Ewell
2. E-mail address of requester: doug at ewellic.org

3. Record Requested:

Type: language
Subtag: xkk
Description: Kachok
Description: Kaco'

4. Intended meaning of the subtag:

5. Reference to published description of the language (book or article):

6. Any other relevant information:

This registration tracks a change made to ISO 639-3 effective
2022-01-20, adding "Kachok" as the reference name for 'xkk' and
retaining "Kaco'" as an additional name.

For more information on the ISO 639-3 change, refer to:
https://iso639-3.sil.org/sites/iso639-3/files/reports/639-3_ChangeRequests_2021_Summary.pdf

---

LANGUAGE SUBTAG MODIFICATION
File-Date: 2022-xx-xx
%%
Type: language
Subtag: env
Description: Enwan (Edo State)
Added: 2009-07-29
%%

---

LANGUAGE SUBTAG REGISTRATION FORM

1. Name of requester: Doug Ewell
2. E-mail address of requester: doug at ewellic.org

3. Record Requested:

Type: language
Subtag: env
Description: Enwan (Edo State)

4. Intended meaning of the subtag:

5. Reference to published description of the language (book or article):

6. Any other relevant information:

This registration tracks a change made to ISO 639-3 effective
2022-01-20, changing the reference name for 'env' from "Enwan (Edu
State)" to "Enwan (Edo State)". (Note correction in spelling of state.)

For more information on the ISO 639-3 change, refer to:
https://iso639-3.sil.org/sites/iso639-3/files/reports/639-3_ChangeRequests_2021_Summary.pdf

---

LANGUAGE SUBTAG MODIFICATION
File-Date: 2022-xx-xx
%%
Type: language
Subtag: trv
Description: Sediq
Description: Seediq
Description: Taroko
Added: 2009-07-29
%%

---

LANGUAGE SUBTAG REGISTRATION FORM

1. Name of requester: Doug Ewell
2. E-mail address of requester: doug at ewellic.org

3. Record Requested:

Type: language
Subtag: trv
Description: Sediq
Description: Seediq
Description: Taroko

4. Intended meaning of the subtag:

5. Reference to published description of the language (book or article):

6. Any other relevant information:

This registration tracks a change made to ISO 639-3 effective
2022-01-20, adding "Sediq" as the reference name and "Seediq" as an
additional name for 'trv', and retaining "Taroko" as an additional name.

For more information on the ISO 639-3 change, refer to:
https://iso639-3.sil.org/sites/iso639-3/files/reports/639-3_ChangeRequests_2021_Summary.pdf

---

LANGUAGE SUBTAG MODIFICATION
File-Date: 2022-xx-xx
%%
Type: language
Subtag: snb
Description: Sebuyau
Added: 2009-07-29
Deprecated: 2022-xx-xx
Preferred-Value: iba
%%

---

LANGUAGE SUBTAG REGISTRATION FORM

1. Name of requester: Doug Ewell
2. E-mail address of requester: doug at ewellic.org

3. Record Requested:

Type: language
Subtag: snb
Description: Sebuyau
Deprecated: 2022-xx-xx
Preferred-Value: iba

4. Intended meaning of the subtag:

5. Reference to published description of the language (book or article):

6. Any other relevant information:

This registration tracks a change made to ISO 639-3 effective
2022-01-20, merging 'snb' for Sebuyau into 'iba'.

For more information on the ISO 639-3 change, refer to:
https://iso639-3.sil.org/sites/iso639-3/files/reports/639-3_ChangeRequests_2021_Summary.pdf
This change is mentioned indirectly, in the context of expanding the
denotation of 'iba' to include 'snb'.

---

LANGUAGE SUBTAG MODIFICATION
File-Date: 2022-xx-xx
%%
Type: language
Subtag: lak
Description: Laka (Nigeria)
Added: 2009-07-29
Deprecated: 2022-xx-xx
Preferred-Value: ksp
%%

---

LANGUAGE SUBTAG REGISTRATION FORM

1. Name of requester: Doug Ewell
2. E-mail address of requester: doug at ewellic.org

3. Record Requested:

Type: language
Subtag: lak
Description: Laka (Nigeria)
Deprecated: 2022-xx-xx
Preferred-Value: ksp

4. Intended meaning of the subtag:

5. Reference to published description of the language (book or article):

6. Any other relevant information:

This registration tracks a change made to ISO 639-3 effective
2022-01-20, merging 'lak' for Laka (Nigeria) into 'ksp'.

For more information on the ISO 639-3 change, refer to:
https://iso639-3.sil.org/sites/iso639-3/files/reports/639-3_ChangeRequests_2021_Summary.pdf
This change is mentioned indirectly, in the context of expanding the
denotation of 'ksp' to include 'lak'.

---

LANGUAGE SUBTAG MODIFICATION
File-Date: 2022-xx-xx
%%
Type: language
Subtag: smd
Description: Sama
Added: 2009-07-29
Deprecated: 2022-xx-xx
Preferred-Value: kmb
%%

---

LANGUAGE SUBTAG REGISTRATION FORM

1. Name of requester: Doug Ewell
2. E-mail address of requester: doug at ewellic.org

3. Record Requested:

Type: language
Subtag: smd
Description: Sama
Deprecated: 2022-xx-xx
Preferred-Value: kmb

4. Intended meaning of the subtag:

5. Reference to published description of the language (book or article):

6. Any other relevant information:

This registration tracks a change made to ISO 639-3 effective
2022-01-20, merging 'smd' for Sama into 'kmb'.

For more information on the ISO 639-3 change, refer to:
https://iso639-3.sil.org/sites/iso639-3/files/reports/639-3_ChangeRequests_2021_Summary.pdf
This change is mentioned indirectly, in the context of expanding the
denotation of 'kmb' to include 'smd'.

---

LANGUAGE SUBTAG MODIFICATION
File-Date: 2022-xx-xx
%%
Type: language
Subtag: psc
Description: Iranian Sign Language
Description: Persian Sign Language
Added: 2009-07-29
%%

---

LANGUAGE SUBTAG REGISTRATION FORM

1. Name of requester: Doug Ewell
2. E-mail address of requester: doug at ewellic.org

3. Record Requested:

Type: language
Subtag: psc
Description: Iranian Sign Language
Description: Persian Sign Language

4. Intended meaning of the subtag:

5. Reference to published description of the language (book or article):

6. Any other relevant information:

This registration tracks a change made to ISO 639-3 effective
2022-01-20, adding "Iranian Sign Language" as the reference name for
'psc' and retaining "Persian Sign Language" as an additional name. Both
the primary language subtag and the extended language subtag
corresponding to this code element were updated.

For more information on the ISO 639-3 change, refer to:
https://iso639-3.sil.org/sites/iso639-3/files/reports/639-3_ChangeRequests_2021_Summary.pdf

---

LANGUAGE SUBTAG MODIFICATION
File-Date: 2022-xx-xx
%%
Type: extlang
Subtag: psc
Description: Iranian Sign Language
Description: Persian Sign Language
Added: 2009-07-29
Preferred-Value: psc
Prefix: sgn
%%

---

LANGUAGE SUBTAG REGISTRATION FORM

1. Name of requester: Doug Ewell
2. E-mail address of requester: doug at ewellic.org

3. Record Requested:

Type: extlang
Subtag: psc
Description: Iranian Sign Language
Description: Persian Sign Language
Preferred-Value: psc
Prefix: sgn

4. Intended meaning of the subtag:

5. Reference to published description of the language (book or article):

6. Any other relevant information:

This registration tracks a change made to ISO 639-3 effective
2022-01-20, adding "Iranian Sign Language" as the reference name for
'psc' and retaining "Persian Sign Language" as an additional name. Both
the primary language subtag and the extended language subtag
corresponding to this code element were updated.

For more information on the ISO 639-3 change, refer to:
https://iso639-3.sil.org/sites/iso639-3/files/reports/639-3_ChangeRequests_2021_Summary.pdf

--
Doug Ewell, CC, ALB | Lakewood, CO, US | ewellic.org

---

From: "Doug Ewell" <[email-masked]>
Date: Mon, 14 Feb 2022 09:54:14 -0700

I received some comments over the weekend. As a general note, it's best to send comments and corrections to the list, not to me personally. As it turned out, I was out of town and busy this weekend, so a detailed email response was not practical. Someone else on the list might have been able to address these comments.

> Regarding the subtag: [env]:
>
> "This registration tracks a change made to ISO 639-3 effective
> State)" to "Enwan (Edo State)". (Note correction in spelling of
> state.)"
>
> Can you change the last sentence to read instead, "(Note correction in
> spelling of state name.")" -- since it is not the word "state" that
> has been corrected, but "Edu" has changed to "Edo"?

Although I doubt anyone would have been confused, this is an easy update to make and doesn't affect the two-week review period. The updated form is in the bottom section of this post. Note that this change is only to an explanatory field in the registration form, and won't affect what goes into the Registry.

> Also, a change was adopted --
> "2021-020 
> aeb 
> Tunisian Arabic
> Denotation Tunisian Arabic
> update by including [ajt] Judeo-Tunisian
> Arabic"
> ***
> Should there be an entry for this? I do not see it!

The Summary of Outcomes document listed this change in two places: in part 1, where [ajt] was retired, and in part 4, where [aeb] had its denotation expanded accordingly. We don't directly reflect the denotation change in the Registry. The fact that 'ajt' will have a Preferred-Value of 'aeb' takes care of this. No additional form or change is needed.

> A "nit"
> -- regarding [iba] -- which now includes [snb] -- should not the old
> reference name "Iban" be mentioned in the note?:
> "This registration tracks a change made to ISO 639-3 effective
> 2022-01-20, merging 'snb' for Sebuyau into 'iba'."
>
> Thanks! (If so, then the same would apply to the next subtag, [ksp]
> which now includes [lak], and to [kmb] which now includes [smd])

The Summary of Outcomes document listed each of these changes in only ONE place: in part 4, where [iba] and [ksp] and [kmb] now include [snb] and [lak] and [smd] respectively. The changes in the Registry, as I mentioned at the top of the Part 4 post, are to deprecate the subtags in the second group, which is what I have done with 'snb' and 'lak' and 'smd'.

I have updated these three registration forms to include the name of each Preferred-Value language under item 6, as well as the subtag value. Note again that these changes don't affect the review period, and won't go into the Registry. Note also that the Description fields for the "surviving" subtags are easily found by looking in the Registry.

---

3. Record Requested:

Type: language
Subtag: env

This registration tracks a change made to ISO 639-3 effective
2022-01-20, changing the reference name for 'env' from "Enwan (Edu
State)" to "Enwan (Edo State)". (Note correction in spelling of state
name.)

---

3. Record Requested:

Type: language
Subtag: snb
Description: Sebuyau
Deprecated: 2022-02-25
Preferred-Value: iba

This registration tracks a change made to ISO 639-3 effective
2022-01-20, merging 'snb' for Sebuyau into 'iba' ("Iban").

---

3. Record Requested:

Type: language
Subtag: lak
Deprecated: 2022-02-25
Preferred-Value: ksp

This registration tracks a change made to ISO 639-3 effective
2022-01-20, merging 'lak' for Laka (Nigeria) into 'ksp' ("Kaba").

---

3. Record Requested:

Type: language
Subtag: smd
Description: Sama
Deprecated: 2022-02-25
Preferred-Value: kmb

This registration tracks a change made to ISO 639-3 effective
2022-01-20, merging 'smd' for Sama into 'kmb' ("Kimbundu").

---

From: CE Whitehead <[email-masked]>
Date: Mon, 14 Feb 2022 17:35:30 +0000

Thanks for taking the trouble to make all these "nit" changes; I hope I get time to look more carefully over the rest of the changes!

Best,
--C. E. Whitehead
[email-masked]

________________________________
De : Ietf-languages <[email-masked]> de la part de Doug Ewell <[email-masked]>
Envoyé : lundi 14 février 2022 11:54
À : [email-masked] <[email-masked]>
Objet : Re: [Ietf-languages] Forms for ISO 639-3 changes: part 4

---

3. Record Requested:

Type: language
Subtag: env

For more information on the ISO 639-3 change, refer to:
https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fiso639-3.sil.org%2Fsites%2Fiso639-3%2Ffiles%2Freports%2F639-3_ChangeRequests_2021_Summary.pdf&amp;data=04%7C01%7C%7C8221debd20e740d51f8008d9efdac032%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637804545084808980%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=9kRSc%2BMHcxVMdnOWLafKs23sy086Tqa0nm6VNdU1wek%3D&amp;reserved=0

---

3. Record Requested:

Type: language
Subtag: snb
Description: Sebuyau
Deprecated: 2022-02-25
Preferred-Value: iba

For more information on the ISO 639-3 change, refer to:
https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fiso639-3.sil.org%2Fsites%2Fiso639-3%2Ffiles%2Freports%2F639-3_ChangeRequests_2021_Summary.pdf&amp;data=04%7C01%7C%7C8221debd20e740d51f8008d9efdac032%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637804545084965224%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=E8PTxrNzNMsUKDo%2FeFpnfj3qcEWhmXWysPIz4J%2FItk4%3D&amp;reserved=0
This change is mentioned indirectly, in the context of expanding the
denotation of 'iba' to include 'snb'.

---

3. Record Requested:

Type: language
Subtag: lak

For more information on the ISO 639-3 change, refer to:
https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fiso639-3.sil.org%2Fsites%2Fiso639-3%2Ffiles%2Freports%2F639-3_ChangeRequests_2021_Summary.pdf&amp;data=04%7C01%7C%7C8221debd20e740d51f8008d9efdac032%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637804545084965224%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=E8PTxrNzNMsUKDo%2FeFpnfj3qcEWhmXWysPIz4J%2FItk4%3D&amp;reserved=0
This change is mentioned indirectly, in the context of expanding the
denotation of 'ksp' to include 'lak'.

---

3. Record Requested:

Type: language
Subtag: smd
Description: Sama
Deprecated: 2022-02-25
Preferred-Value: kmb

For more information on the ISO 639-3 change, refer to:
https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fiso639-3.sil.org%2Fsites%2Fiso639-3%2Ffiles%2Freports%2F639-3_ChangeRequests_2021_Summary.pdf&amp;data=04%7C01%7C%7C8221debd20e740d51f8008d9efdac032%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637804545084965224%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=E8PTxrNzNMsUKDo%2FeFpnfj3qcEWhmXWysPIz4J%2FItk4%3D&amp;reserved=0
This change is mentioned indirectly, in the context of expanding the
denotation of 'kmb' to include 'smd'.

_______________________________________________
Ietf-languages mailing list
[email-masked]
https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fietf-languages&amp;data=04%7C01%7C%7C8221debd20e740d51f8008d9efdac032%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637804545084965224%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=rU74JItFk6eHaipED0rEXPXuEuxxMqIMZ5WQQnQbtcc%3D&amp;reserved=0