Subject: [ietf-mentors] First experience meeting 'mentees'

From: "Carlos M. Martinez" <[email-masked]>
Date: Mon, 29 Jul 2013 11:01:03 +0200

Hello all,

Yesterday many of us had a 'first', in terms of meeting our mentees (or
is it 'mentorees', sorry if I got it wrong :-) )

For me it was a great experience, and I felt the mentee also perceived
the meeting as highly useful.

As silly as it may sound, there might be a need for a 'meeting
protocol', I ended up relying up on the features of my t-shirt, but
maybe something in the badges, like the 'New Attendee' band but in a
different color could be useful.

Cheers,

~Carlos

---

From: Jeff Haas <[email-masked]>
Date: Mon, 29 Jul 2013 11:08:18 +0200

The person I was mentoring and I exchanged pictures ahead of the meeting. 

Jeff

On Jul 29, 2013, at 11:01, "Carlos M. Martinez" <[email-masked]> wrote:

> _______________________________________________
> ietf-mentors mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-mentors

---

From: Randy Bush <[email-masked]>
Date: Mon, 29 Jul 2013 11:30:58 +0200

> The person I was mentoring and I exchanged pictures ahead of the meeting. 

i did not want to scare my mentee 

randy

---

From: Dave Crocker <[email-masked]>
Date: Mon, 29 Jul 2013 12:29:38 +0200

> The person I was mentoring and I exchanged pictures ahead of the meeting.

I had sent mine a note ahead of time, with a pointer to a photo.

I didn't hear back from them and couldn't find them at the newcomer 
reception.

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 29 Jul 2013 12:38:25 +0200

> I didn't hear back from them and couldn't find them at the newcomer

I had two mentees:

1. For the first, I reached out originally and heard back, then sent a
reply and never heard further.

2. For the second, I reached out and we had a bit of an email
conversation, but the person found much help within their WG of greatest
interest and discovered that I wasn't as necessary as originally foreseen.

(Unfortunately I was not able to attend the opening reception.)

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Robert Sparks <[email-masked]>
Date: Mon, 29 Jul 2013 13:03:34 +0200

Anyone else not able to make contact (that expected to make contact by now)?

RjS

---

From: George Michaelson <[email-masked]>
Date: Mon, 29 Jul 2013 13:15:28 +0200

My mentee is a one-day registrant and so far, I don't believe has registered.

-G

On 29/07/2013, at 1:03 PM, Robert Sparks <[email-masked]> wrote:

>> I didn't hear back from them and couldn't find them at the newcomer reception.
>> 
>> d/
>> 
>> 
>

---

From: Brian Rosen <[email-masked]>
Date: Mon, 29 Jul 2013 13:39:59 +0200

My mentee and I exchanged a couple of emails, which he found useful.  We met at the newcomers reception and chatted.  

I think he will have a better first experience, and it was well worth the very little time it took me.

Brian

---

From: Karen O'Donoghue <[email-masked]>
Date: Mon, 29 Jul 2013 07:56:43 -0400

Here are my experiences for what they are worth...

I met three mentees at the meet and greet reception that couldn't find 
their mentors and hadn't coordinated in advance about meeting. I believe 
at least one indicated that they hadn't heard from their mentor in 
advance. I talked to each of them and pointed them in the direction of 
people with interests related to theirs ( as part of what I usually do 
at the meet and greet by looking for folks with new attendee badges 
standing off by themselves and asking them if the need help or have any 
questions). The room was a bit undersized and too warm to easily 
mingle... but you all already know that...

I found my mentee at the opening reception. I had coordinated meeting 
him, but I didn't discuss his needs or expectations in advance. Upon 
meeting, he indicated that he was attending with colleagues who had been 
to the IETF before, and he was already connected into the work he was 
interested in. He just signed up because he was a new attendee, but he 
didn't feel he needed mentoring. I told him I was happy to answer any 
questions he had... feel free to wave me down or send me email, etc... A 
pleasant exchange, but I'm not sure I was much help to him...

FWIW...
Karen

---

From: Suresh Krishnan <[email-masked]>
Date: Mon, 29 Jul 2013 14:06:30 +0200

I found my mentee just fine. We had corresponded earlier to exchange
interests. I did find some newcomers without mentors (not sure if they
were mentees - did not ask) and was connecting them to some chairs/ADs
based on their areas of interest.

Thanks
Suresh

---

From: Arturo Servin <[email-masked]>
Date: Mon, 29 Jul 2013 14:14:30 +0200

Are we (or somebody) planning to do a survey to mentors and mentees?

	My personal experience with my mentees, what I saw, listened, and read
now in this list points that there were things that worked and some that
didn't and it would be good to know them to improve this in the future.

	My personal experience was very good (hopefully it was good to them
too), I interchanged emails with my mentees in advance, I recommended
documents, made general recommendations about the IETF (what to do,
where WG to go, etc.) and I introduced them to key people that may be
relevant to their work (in my personal experience as a new participant,
it was difficult to get a network or people).

Regards,
as

---

From: Ulrich Herberg <[email-masked]>
Date: Mon, 29 Jul 2013 14:20:34 +0200

My experience was also very good. We had breakfast together and I
explained him things about the IETF in general, as well as pointed him
to specific WGs and people whom could be relevant for him. We may meet
a second time this week after he has attended a few WG sessions.

Ulrich

---

From: Alissa Cooper <[email-masked]>
Date: Mon, 29 Jul 2013 14:21:15 +0200

> 	Are we (or somebody) planning to do a survey to mentors and mentees?

Yes. Was hoping to write it up last week for distribution at the end of this week, but that did not happen so it will be a bit delayed.
Alissa

---

From: Jouni Korhonen <[email-masked]>
Date: Mon, 29 Jul 2013 15:22:05 +0300

I found my mentee quite easily after some initial confusion. Prior the IETF
email exchange + pictures etc were used to make sure we could locate each
other. I actually spent several hours with him on Sunday going around and
stuff.

Our technical interest profiles hardly matched, which probably lowered the
intended outcome of the mentoring since I did not know key players or
technical areas deeply enough. I naively assumed that the mentee was also
selected based on my "profile" and did not check that in advance with my
mentee.

- JOuni

---

From: Arturo Servin <[email-masked]>
Date: Mon, 29 Jul 2013 14:22:08 +0200

This sounds interesting.

Regards,
as

On 7/29/13 2:20 PM, Ulrich Herberg wrote:
> We may meet

---

From: Alissa Cooper <[email-masked]>
Date: Mon, 29 Jul 2013 14:37:01 +0200

> selected based on my "profile" and did not check that in advance with my

The coordinators tried to match on substance as best as possible, but in the final days that became difficult because most of the mentors were already assigned. I think next time we will set a deadline for sign-ups.

Alissa

---

From: "Eggert, Lars" <[email-masked]>
Date: Mon, 29 Jul 2013 12:47:54 +0000

Hi,

reading through the current email thread, I see a lot of posts saying "my experience WAS great/pleasant/didn't happen" (my emphasis.)

Maybe us mentoring coordinators didn't communicate this well enough, but the idea was not (only) to bring mentors and mentees together during the meet&greet. The idea was that the mentor and mentee would (ideally) form a longer-term relationship that continued past this IETF meeting, and past the meet&greet. The meet&greet provided a convenient sync point for the initial contact. Mentoring goes way beyond a brief Q&A over beer. (But it's a good start!)

Obviously, that won't happen in all or maybe even very many cases. If the newcomer has colleagues, or otherwise finds the help he/she needs to get up to speed, the mentor won't be needed. 

Let's see if some of these relationships continue past this week. To me personally, that'd send a signal that the experiment is useful to continue. If it turns out that our newcomers mostly really only need to be briefly introduced to the folks they want to meet, the meet&greet should provide that without a separate mentoring program.

In any event, THANK YOU ALL for volunteering to mentor! We couldn't do the experiment without you!

Lars

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Mon, 29 Jul 2013 13:46:54 +0000

My mentee was pretty well matched.  In fact, he has been following the WG
that I chair. :-)

We met today for an hour (could have talked longer but I had another
commitment) -- talked about technology, but I think he found most useful
information about how the IETF worked and how to build up his reputation.
We planned to informally keep in touch in the future.

Alvaro.

---

From: Karen O'Donoghue <[email-masked]>
Date: Mon, 29 Jul 2013 09:56:31 -0400

First, I didn't mean my previous comments as criticisms as observations 
from the first time run of the experiment. I think guidelines or 
suggestions for mentors would be helpful. And (also not a complaint)... 
I signed up late, and I got my mentee email on the day that I left to 
come to Berlin. There was very limited advance coordination as a result 
of this. Having said this, I think some people probably signed up for 
mentors without thinking about whether they really wanted them or would 
find one helpful.

I look forward to refinements to the experiment...

Karen

---

From: Brian Haberman <[email-masked]>
Date: Mon, 29 Jul 2013 10:32:29 -0400

> In any event, THANK YOU ALL for volunteering to mentor! We couldn't do the experiment without you!

Some of this is covered in the mentor FAQs.  I would be very interested 
in feedback from mentors on what could be added to that to clarify the 
expectations on the mentoring relationships.

Regards,
Brian

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 30 Jul 2013 10:38:31 +0200

> reply and never heard further.

Update: I heard from this mentee, who experienced a family emergency and
was unable to attend the IETF meeting.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Tony Hansen <[email-masked]>
Date: Tue, 30 Jul 2013 05:20:58 -0400

My mentee and I exchanged a couple of emails and I was able to answer a
couple first-order issues that he had, such as "do I need permission
from the WG chair to come to the WG meeting or join the mailing list?"

We agreed to meet up at the newcomers meet and greet and were actually
able to do so. We then spent a good half hour talking. I also spent some
time talking with other mentees who had not found their mentors.

I too feel that my mentee will have a better first experience.

I think the key is providing a space where "no question is too dumb to
ask and no question is off the table". For my mentee and some of the
others I spoke with, something I noticed was that once they got over the
shyness of asking the first question, and found that I was open and
willing to answer it, a whole flood of other questions started pouring out.

    Tony

---

From: "Mankin, Allison" <[email-masked]>
Date: Tue, 30 Jul 2013 09:34:36 +0000

My mentee answered email but did not find me at the meet n greet though i spent a nigh tropical hour by the rendezvous table.  I offered quite a number of meeting options. The mentee wrote back he couldnt fit any of them in, so, I left it that if he needs any info etc, he will email.

My suspicion is that it depends on career stage and temperament whether people feel during first IETF that they might benefit from a mentor. People sometimes sign up for things they don't really want.

I hope I am not missing some signal...

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Wed, 31 Jul 2013 11:35:32 +0000

One other point I detected is that my mentee reported that he has already 3-4 mentors, which was kind of surprising and de-motivated myself concerning my responsibility for being a good-mentor.

Is it intentional that a mentee gets assigned multiple mentors?

I don't think this is a categorically bad idea but obviously influences the mentee-2-mentor interface.

Cheers, 
Mehmet 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of ext Mankin, Allison
> Sent: Tuesday, July 30, 2013 11:35 AM
> To: Eggert, Lars; Brian Haberman; Alissa Cooper
> Cc: [email-masked]
> Subject: Re: [ietf-mentors] what does mentoring mean
> 
> My mentee answered email but did not find me at the meet n greet though i spent a
> nigh tropical hour by the rendezvous table.  I offered quite a number of meeting
> options. The mentee wrote back he couldnt fit any of them in, so, I left it that if he
> needs any info etc, he will email.
> 
> My suspicion is that it depends on career stage and temperament whether people feel
> during first IETF that they might benefit from a mentor. People sometimes sign up for
> things they don't really want.
> 
> > reading through the current email thread, I see a lot of posts saying "my experience
> WAS great/pleasant/didn't happen" (my emphasis.)
> >
> > Maybe us mentoring coordinators didn't communicate this well enough, but the idea
> was not (only) to bring mentors and mentees together during the meet&greet. The
> idea was that the mentor and mentee would (ideally) form a longer-term relationship
> that continued past this IETF meeting, and past the meet&greet. The meet&greet
> provided a convenient sync point for the initial contact. Mentoring goes way beyond a
> brief Q&A over beer. (But it's a good start!)
> >
> > Obviously, that won't happen in all or maybe even very many cases. If the
> newcomer has colleagues, or otherwise finds the help he/she needs to get up to speed,
> the mentor won't be needed.
> >
> > Let's see if some of these relationships continue past this week. To me personally,
> that'd send a signal that the experiment is useful to continue. If it turns out that our
> newcomers mostly really only need to be briefly introduced to the folks they want to
> meet, the meet&greet should provide that without a separate mentoring program.
> >

---

From: Brian Haberman <[email-masked]>
Date: Wed, 31 Jul 2013 07:37:31 -0400

> Is it intentional that a mentee gets assigned multiple mentors?

If he has multiple mentors, they did not come via this program.  I do 
know that several of the ISOC Fellows (who have an ISOC-selected mentor) 
signed up for this mentoring program as well.

> I don't think this is a categorically bad idea but obviously influences the mentee-2-mentor interface.

Agreed.

Regards,
Brian

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 31 Jul 2013 13:39:06 +0200

> One other point I detected is that my mentee reported that he has already 3-4 mentors, which was kind of surprising and de-motivated myself concerning my responsibility for being a good-mentor.

Were you using the mentor-2-mentee protocol or the Mehmet-2-mentee
protocol? ;-)

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Robert Sparks <[email-masked]>
Date: Wed, 31 Jul 2013 13:42:17 +0200

Mehmet -

I think what happened is that the person you were matched with is 
participating in more than one program this time around.
As best I can tell, _this_ effort only matched him with you.

We've already identified the need to be more aware of overlap next time.

RjS

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Wed, 31 Jul 2013 11:46:50 +0000

Obviously my mentee had multiple mentee-2-mentor relationships and was most likely confused who to talk to.
OTOH we cannot avoid that a mentee knows already some people at IETF and does not rely on the mentor enthusiastically trying to be helpful.

We might indeed need a standard RFC for this protocol ;-{)

Cheers, 
Mehmet 

> From: ext Peter Saint-Andre [mailto:[email-masked]]
> Sent: Wednesday, July 31, 2013 1:39 PM
> To: Ersue, Mehmet (NSN - DE/Munich)
> Cc: [email-masked]; Eggert, Lars
> > One other point I detected is that my mentee reported that he has already 3-4
> mentors, which was kind of surprising and de-motivated myself concerning my
> responsibility for being a good-mentor.
>