Subject: [ietf-privacy] Wouldn't it be nice if...

From: Stephen Farrell <[email-masked]>
Date: Tue, 19 Mar 2013 10:10:03 +0000

...people wanted to come along to the IETF and
standardise the kind of application protocol described
in the "solution" section of this [1] paper. (Just
seen on /. ) I'm not saying that that solution is
wonderful as-is, but it does appear to be a design
that tries hard to be privacy friendly and to
prevent false reporting.

>From the paper, it looks like the Google and Waze
protocols that the authors analyse have serious
shortcomings that would likely have been spotted had
those protocols been developed more openly. There is
mention of open-source licensing, but however
those were developed, the result appears to show
a lack of security/privacy clue somewhere.

I'm not sure what, if anything, we could do to
encourage folks to bring such work here, but it
does really look like they could have deployed
something quite that  if they had
done that.

S.

[1]
https://media.blackhat.com/eu-13/briefings/Jeske/bh-eu-13-floating-car-data-jeske-wp.pdf

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Tue, 19 Mar 2013 12:37:14 +0100

* Stephen Farrell wrote:
>in the "solution" section of this [1] paper.

>https://media.blackhat.com/eu-13/briefings/Jeske/bh-eu-13-floating-car-data-jeske-wp.pdf

The smartphone tracking problem discussed on page eight of the paper got
a partial solution in 2011 (use the suffix "_nomap" in your network id
to opt it out of databases), which I picked up in an Internet-Draft, see
<http://tools.ietf.org/html/draft-hoehrmann-nomap-00>. I can't say I've
seen any interest in pursuing that any further...
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/