Subject: [ietf-privacy] old RFC reviews - please try this...

From: Stephen Farrell <[email-masked]>
Date: Tue, 20 May 2014 10:23:34 +0100

Hiya,

A while back Scott and Avri sent out a link [1] to
where you can put reviews of old RFCs. So far, that
hasn't seen overwhelming activity, which is a pity,
but maybe understandable, since we're all busy and
doing this is probably not top of anyone's todo list.

As a reminder, the goal is to get folks to review
old RFCs for privacy and pervasive monitoring related
issues, so that if/when we do more work on those
protocols we have a head-start. And also maybe to
motivate people to do such work, or to think a bit
more about how those protocols are now actually
deployed, which may be a lot different compared to
the assumptions made when they were developed.

Anyway, in a perhaps silly attempt to kick-start
that, I've done up a bit of a web page that tries
to make getting some work done here a bit easier.
Basically, go to [2] and it'll randomly select an
RFC and give you a field where you can type your
review and then it'll craft the mail for you to send
to this list. How much easier could it be? :-)

If you've a few minutes, please give it a try and
see what you find and post your review to this list.

If this does prove useful, we can try make it better
later. If not, then I wasted a little of my time,
and we can move on to try think of other ways to
get folks to do this work.

Of course, you can still just go read any old RFC
and send your review here or create a ticket, that
does still work too:-)

Thanks,
S.

PS: I guess send bug reports to me, I'm sure there
will be bugs.

[1] https://trac.tools.ietf.org/group/ppm-legacy-review/wiki
[2] http://down.dsg.cs.tcd.ie/ppm/

---

From: Scott Brim <[email-masked]>
Date: Tue, 20 May 2014 07:04:41 -0400

Here's a further suggestion: use the random draw as a starting point for an
RFC cluster. For example, if you get 5068, follow the normative references
toward the critical RFCs for mail and make sure those get done too.

Scott

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Wed, 21 May 2014 11:32:14 -0400

For the record, this is seriously awesome and kind of fun... Stephen
may be on the way to "gamify" RFC privacy/PPM reviews. ::)

One practical question: My first draw was RFC 963 "SOME PROBLEMS WITH
THE SPECIFICATION OF THE MILITARY STANDARD INTERNET PROTOCOL" from 1985.

Since the first year I remember there being things called "years" was
1982, I'm thinking that a review of this might not be that useful, no?

So, is there a quick rubric for RFCs to review that might be
particularly useful? E.g., should we focus on more recent ones?

best, Joe

On 5/20/14, 5:23 AM, Stephen Farrell wrote:
> 
> Hiya,
> 
> A while back Scott and Avri sent out a link [1] to where you can
> put reviews of old RFCs. So far, that hasn't seen overwhelming
> activity, which is a pity, but maybe understandable, since we're
> all busy and doing this is probably not top of anyone's todo list.
> 
> As a reminder, the goal is to get folks to review old RFCs for
> privacy and pervasive monitoring related issues, so that if/when we
> do more work on those protocols we have a head-start. And also
> maybe to motivate people to do such work, or to think a bit more
> about how those protocols are now actually deployed, which may be a
> lot different compared to the assumptions made when they were
> developed.
> 
> Anyway, in a perhaps silly attempt to kick-start that, I've done up
> a bit of a web page that tries to make getting some work done here
> a bit easier. Basically, go to [2] and it'll randomly select an RFC
> and give you a field where you can type your review and then it'll
> craft the mail for you to send to this list. How much easier could
> it be? :-)
> 
> If you've a few minutes, please give it a try and see what you find
> and post your review to this list.
> 
> If this does prove useful, we can try make it better later. If not,
> then I wasted a little of my time, and we can move on to try think
> of other ways to get folks to do this work.
> 
> Of course, you can still just go read any old RFC and send your
> review here or create a ticket, that does still work too:-)
> 
> Thanks, S.
> 
> PS: I guess send bug reports to me, I'm sure there will be bugs.
> 
> 
> [1] https://trac.tools.ietf.org/group/ppm-legacy-review/wiki [2]
> http://down.dsg.cs.tcd.ie/ppm/
> 
> _______________________________________________ ietf-privacy
> mailing list [email-masked] 
> https://www.ietf.org/mailman/listinfo/ietf-privacy
> 

- -- 
Joseph Lorenzo Hall
Chief Technologist
Center for Democracy & Technology
1634 I ST NW STE 1100
Washington DC 20006-4011
(p) 202-407-8825
(f) 202-637-0968
[email-masked]
PGP: https://josephhall.org/gpg-key
fingerprint: 3CA2 8D7B 9F6D DBD3 4B10  1607 5F86 6987 40A9 A871

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 21 May 2014 16:43:51 +0100

Hiya,

On 21/05/14 16:32, Joseph Lorenzo Hall wrote:
> One practical question: My first draw was RFC 963 "SOME PROBLEMS
> WITH THE SPECIFICATION OF THE MILITARY STANDARD INTERNET PROTOCOL"
> from 1985.
> 
> Since the first year I remember there being things called "years"
> was 1982, I'm thinking that a review of this might not be that
> useful, no?
> 

I'd say lets suck it and see. Hitting refresh is easy:-)

I figure that matching the complexity/importance of the RFC
to the amount of time you have available is entirely reasonable.

And its also ok to write a "nothing to see here, move along"
review. Who knows - someone might disagree with you (e.g. as
SM correctly did with mine), so those can be useful too.

And when/if we start getting reviews then we can see how to
improve things (either the tool or guidance or whatever).

For now, just getting it going is my goal...

Cheers,
S.

>> privacy and pervasive monitoring related issues, so that if/when
>> we do more work on those protocols we have a head-start. And
>> also maybe to motivate people to do such work, or to think a bit
>> more about how those protocols are now actually deployed, which
>> may be a lot different compared to the assumptions made when they
>> were developed.
> 
>> Anyway, in a perhaps silly attempt to kick-start that, I've done
>> up a bit of a web page that tries to make getting some work done
>> here a bit easier. Basically, go to [2] and it'll randomly select
>> an RFC and give you a field where you can type your review and
>> then it'll craft the mail for you to send to this list. How much
>> easier could it be? :-)
> 
>> If you've a few minutes, please give it a try and see what you
>> find and post your review to this list.
> 
>> If this does prove useful, we can try make it better later. If
>> not, then I wasted a little of my time, and we can move on to try
>> think of other ways to get folks to do this work.
>

---

From: Scott Brim <[email-masked]>
Date: Wed, 21 May 2014 12:26:08 -0400

> particularly useful? E.g., should we focus on more recent ones?

:-)

Not necessarily recent, but essential, like TCP and DNS. We started
out with people choosing areas important to them and exploring them. I
think that's a good way to continue. However, the random pick is great
if you want to get out of your usual rut. I plan on using it some. I
like discovering unexplored regions of the IETF's oeuvre. If the
random pick gives you an RFC you don't think is worth reviewing, just
spin again -- it's free!

Scott

---

From: "Christian Huitema" <[email-masked]>
Date: Wed, 21 May 2014 10:14:43 -0700

> Not necessarily recent, but essential, like TCP and DNS. 

My preference: go to the RFC index and check for RFC that are on the
standard track (status set to proposed, draft or standard) and that are not
obsoleted by another RFC.

-- Christian Huitema