Subject: [ietf-privacy] Checking an old protocol, RTSP

From: "Christian Huitema" <[email-masked]>
Date: Tue, 20 May 2014 23:27:27 -0700

I am currently taking a look at RFC 2326: Real Time Streaming Protocol. The
design of RTSP/1.0 is pretty close to that of HTTP/1.0, with very similar
security and privacy considerations, but RTSP did not evolve as quickly as
HTTP. In particular, I cannot find a profile for running RTSP over SSL or
TLS in the RFC series. Is that defined elsewhere?

Also, RTSP was widely used in the 90’s. Is that still the case?

-- Christian Huitema

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Wed, 21 May 2014 06:39:48 +0000

On May 20, 2014, at 11:27 PM, Christian Huitema <[email-masked]> wrote:

> I am currently taking a look at RFC 2326: Real Time Streaming Protocol. The design of RTSP/1.0 is pretty close to that of HTTP/1.0, with very similar security and privacy considerations, but RTSP did not evolve as quickly as HTTP. In particular, I cannot find a profile for running RTSP over SSL or TLS in the RFC series. Is that defined elsewhere?
>  

You could take a look at RFC 4567. It does not specify TLS or SSL; it defines a key exchange for SDP and RTSP.

---

From: Martin Stiemerling <[email-masked]>
Date: Wed, 21 May 2014 09:24:41 +0200

Hi Christian, 

> I am currently taking a look at RFC 2326: Real Time Streaming Protocol. The design of RTSP/1.0 is pretty close to that of HTTP/1.0, with very similar security and privacy considerations, but RTSP d…

I don’t think so, but there is an updated version of RTSP 1.0 which is RTSP 2.0 and this is in the RFC editor’s queue (https://ietf.org/doc/draft-ietf-mmusic-rfc2326bis/). RTSP 2.0 has support for TLS, actually it is MTI.

> Also, RTSP was widely used in the 90’s. Is that still the case?

It is still in closed environments, such as cable networks, but much less on the public Internet.

Pure HTTP and Dynamic Adaptive Streaming over HTTP (DASH) is what is used across  the public Internet for video streaming by today. 

  Martin

>  
> -- Christian Huitema
>  
>  
> _______________________________________________
> ietf-privacy mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-privacy

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 21 May 2014 08:56:09 +0100

> TLS in the RFC series. Is that defined elsewhere?

I recall commenting on RTSP and TLS when we did IESG review of that.
Main comment I had (that I recall;-) was there's no equivalent of
HTTP CONNECT.

S.