Subject: [ietf-smtp] Security considerations issues for Internet Mail - draft-moonesamy-mail-security-01

From: S Moonesamy <[email-masked]>
Date: Mon, 08 Jul 2013 14:44:26 -0700

Hello,

I submitted the initial version of draft-moonesamy-mail-security (see 
http://tools.ietf.org/html/draft-moonesamy-mail-security-01 ) a few 
years ago.  The draft discusses about security consideration issues 
for Internet Mail.  Comments are welcome.

Regards,
S. Moonesamy

---

From: Barry Leiba <[email-masked]>
Date: Tue, 9 Jul 2013 13:17:10 -0400

> http://tools.ietf.org/html/draft-moonesamy-mail-security-01 ) a few years
> ago.  The draft discusses about security consideration issues for Internet
> Mail.  Comments are welcome.

I honestly don't get the point of the document.  It seems scattered,
and doesn't appear to say anything that I can find useful.

As an example of the scatteredness, Section 2.4 talks about social
attacks and cites Appendix B... and Appendix B is about homographs.
Now, maybe if you cited this it would relate better:
http://xkcd.com/538/

What's really your goal with this document?  What would you like to see it be?

Barry

---

From: S Moonesamy <[email-masked]>
Date: Tue, 09 Jul 2013 11:12:24 -0700

Hi Barry,
>and doesn't appear to say anything that I can find useful.

I agree that the document is scattered.  The document needs a lot of 
work before it is even in a useful state.

>Now, maybe if you cited this it would relate better:

I was thinking about http://xkcd.com/1181/

Appenfix B is about homoglyphs.  It is used in social engineering.  A 
user will not notice on quick expectation that the "L" was 
substituted for an "i".

>What's really your goal with this document?  What would you like to see it be?

The goal is to reduce the number of long discussions about email 
issues which cannot be fixed.  I would like to have actual examples 
(see Appendix) so that people can at least read and maybe understand, 
for example, why one would not try to fix some issues.

Regards,
S. Moonesamy