Subject: Re: [ietf-smtp] [Uri-review] Registration request for smtp:// and submit:// URI schemes (draft-melnikov-smime-msa-to-mda-04)

From: Alexey Melnikov <[email-masked]>
Date: Tue, 1 Apr 2014 09:44:23 +0100

Hi Dave,

> On 31 Mar 2014, at 20:12, Dave Thaler <[email-masked]> wrote:
> 
> Alexey Melnikov wrote:
>> I am also registering submit:// URI
>> scheme, which is a similar URI schemes, but for designating Mail Submission
>> Agents.
> 
> My understanding from your email and from a glance at
> draft-melnikov-smime-msa-to-mda is that the proposed "submit" scheme is
> not currently widely deployed, and hence the actual name is flexible.

Yes, ...
> My feedback is that the name "submit" is not a good name for the proposed use.
> Specifically, RFC 4395 states:
>> Avoid using names that are either very general purpose or associated
>> in the community with some other application or protocol.
> 
> There are many types of things you can "submit" (HTTP forms, etc.)
> and since the proposed use here is specific to specific to SMTP, it should
> not use a general purpose word like "submit" along.
> 
> "smtpsubmit" or similar would be much more appropriate.

I would rather use the same label as used by DNS SRV for the same service: "submission". (I think keeping them different would be a bad thing.). Thoughts?

Best Regards,
Alexey

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 1 Apr 2014 09:49:28 +0100

> On 1 Apr 2014, at 04:59, "Robert A. Rosenberg" <[email-masked]> wrote:
> 
> At 15:33 -0700 on 03/31/2014, Bill McQuillan wrote about Re: [ietf-smtp] [Uri-review] Registration request for smtp::
> 
>>>> On Mon, 2014-03-31, Dave Thaler wrote:
>>>> Alexey Melnikov wrote:
>> I hope that whichever keyword is used, it is clearly
>> distinguished from "mailto".
> 
> Mailto invokes a MUA and supplies the To data and optionally other headers such as subject, message body, cc, bcc, etc for a created message.

Right.
>> I know I'm a bit confused about this proposal. Is "submit"
>> intended to be a lower abstraction level? Or a replacement?
> 
> From reading the proposal, Submit seems to be a way of supplying the SMTP server to be used to inject email into the system (ie: What you would enter into a MUA "SMTP Server" Parm). It is a SMTP Server dedicated as the Mail Submission Agent role as opposed to the more generic MTA role (which is listed in a MX record) which can not only the target of a MUA injection connection but also a SMTP Server to SMTP Server message forwarding connection. The SMTP type seems to be a generic Server of the latter type/function.

Almost. I think of MTAs as being a different type of service from the one provided by MSAs, although they speak almost the same protocol.
So the intent was to use "smtp" only for server to server transfers. But I am open to suggestions on whether this is reasonable or not.

---

From: Alessandro Vesely <[email-masked]>
Date: Tue, 01 Apr 2014 20:54:18 +0200

On Tue 01/Apr/2014 10:44:23 +0200 Alexey Melnikov wrote:
> I would rather use the same label as used by DNS SRV for the same
> service: "submission". (I think keeping them different would be a
> bad thing.). Thoughts?

+1, that name also appears in /etc/services, as registered in
http://www.iana.org/assignments/service-names-port-numbers/service-names-port-numbers.xhtml?search=587

("submit" seems to be related to oldish port 773)

Ale