Subject: [ietf-smtp] BSMTP deployment?

From: Dave Crocker <[email-masked]>
Date: Fri, 23 May 2014 10:07:07 -0700

Hi.  I'm curious about the extent of BSMTP deployment and use that there
has been, including a sense of the range of implementations.

Nothing precise, just a sense of whether it has only been very narrowly
adopted, or more broadly.

Thanks.

d/
-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Ned Freed <[email-masked]>
Date: Fri, 23 May 2014 10:32:06 -0700 (PDT)

> adopted, or more broadly.

We have the support in place, but we've never bothered to put it in our
product because nobody has asked for it.

OTOH, PMDF has supported it for years. It's pretty simple to set up, so there's
no real way to tell how much use it gets.

				Ned

---

From: Dave Crocker <[email-masked]>
Date: Fri, 23 May 2014 11:26:48 -0700

> no real way to tell how much use it gets.

Well, my interest is about industry experience, rather than about
technical ease.

I've got a use case that needs something like it, but of course most
folk don't know about it and, so, aren't automatically inclined to use
it.  The fact that the spec has been around a long time and that there
has been "some" use isn't compelling to them.  I'm lazier than they are...

d/

---

From: Ned Freed <[email-masked]>
Date: Fri, 23 May 2014 11:31:22 -0700 (PDT)

> Well, my interest is about industry experience, rather than about

OK, then the fact that the entirety of BITNET - thousands of nodes at least -
ran on BSMTP for several decades might count as some "industry experience".

				Ned

---

From: John C Klensin <[email-masked]>
Date: Fri, 23 May 2014 14:43:18 -0400

--On Friday, 23 May, 2014 11:26 -0700 Dave Crocker
<[email-masked]> wrote:

>...
> I've got a use case that needs something like it, but of
> course most folk don't know about it and, so, aren't
> automatically inclined to use it.  The fact that the spec has
> been around a long time and that there has been "some" use
> isn't compelling to them.  I'm lazier than they are...

If that is the question, it is perhaps useful to remember that,
using a different protocol for transport, essentially the same
protocol was the basis for email (including Revised LISTSERV
list distribution and its predecessors and competitors) on
BITNET/NETNORTH/EARN for most of the lives of those networks.
If your associates/ clients are concerned about whether the
protocol has been tested by actual use at scale, the email
activity on those networks would push the answer several orders
of magnitude past "some".   

In that context, the PDMF channel for those networks that Ned
mentioned was one of two really major implementations when
measured in traffic volume.

So the answer to your question depends somewhat on what the
question really is.  For the contemporary public Internet, I'd
agree with "probably some" although in the end game period for
Internet dialup service, I was aware of a few enterprises that
used it as part of a de facto submission service for clients
that mostly offline and came online only to synchronize.  In
that regard, think about BSMTP as a complement to IMAP Offline
mode, appropriate when one typically accumulated a lot of
outbound messages before coming online and then wanting to be
online for as short a time as possible.

Hope that helps,
   john