Subject: Re: [ietf-smtp] Error in RFC 5321 concerning SPF and DKIM

From: Frank Ellermann <[email-masked]>
Date: Sun, 14 Sep 2014 11:57:01 +0200

> I think any reference to DKIM better belongs to a hypothetical 5322bis.
> Whatever it does, it's not related to the envelope.

Makes sense, that's how SPF + DKIM were designed.  SPF for SMTP
+ DNS + Return-Path, DKIM not depending on SMTP for full message
header lines including a From:.

> I agree some reference to SPF would make sense (for the purposes
> of Dave's erratum though I think removing the sentence in question
> is the best solution).

Not mentioning SPF would be odd, after all its "FAIL" feature fixes a
serious 2821-SMTP issue.  It could go into the security considerations.

-Frank

---

From: Douglas Otis <[email-masked]>
Date: Tue, 23 Sep 2014 14:28:26 -0700

> serious 2821-SMTP issue.  It could go into the security considerations.

Dear Frank,

SPF -all assertion caused erroneous message handling (~ few percent) generally leading to the assertion being ignored on received email unless accepted but bounced for other policy reasons.  IMHO, this failure caused DMARC to require combined failures of DKIM and SPF as a rejection basis.  As such, DMARC needs to recommend against SPF only rejection.  Attempts to defined this separately could lead to contradictions.

Regards,
Douglas Otis