Subject: [ietf-smtp] A trivial question about line lengths

From: Steve Atkins <[email-masked]>
Date: Sun, 30 Nov 2014 17:54:23 -0800

RFC 5322 discusses line lengths both in terms of the maximum line length an MTA can be required to handle (998 bytes) but also a more conservative 78 character limit, driven by the requirement to support user interfaces that are only 78 characters wide.

If I'm wrapping a header by breaking a line with "\r\n\t", and I'm trying to comply with the spirit of the RFC, how many characters am I allowed to put on the continuation line?

Is it 77, as I have a single tab character already, and I'm allowed 78 total? Or is it 72, as in the glass teletype world the RFC seems to live in the tab character will consume 8 display characters to the first tab stop, leaving me another 72 before I run into the right edge of the screen?

Cheers,
  Steve

---

From: Mark Andrews <[email-masked]>
Date: Mon, 01 Dec 2014 13:23:27 +1100

In message <[email-masked]>, Steve Atki
ns writes:
> RFC 5322 discusses line lengths both in terms of the maximum line length
> an MTA can be required to handle (998 bytes) but also a more conservative 78
> character limit, driven by the requirement to support user interfaces that
> are only 78 characters wide.

80 characters wide.
 
> If I'm wrapping a header by breaking a line with "\r\n\t", and I'm trying
> to comply with the spirit of the RFC, how many characters am I allowed to
> put on the continuation line?
>
> Is it 77, as I have a single tab character already, and I'm allowed 78
> total?  Or is it 72, as in the glass teletype world the RFC seems to live
> in the tab character will consume 8 display characters to the first tab
> stop, leaving me another 72 before I run into the right edge of the
> screen?

Assume tab stop of 8.
 
> Cheers,
>   Steve
> 
> _______________________________________________
> ietf-smtp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-smtp
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]