Subject: [ietf-smtp] [IANA #817403] Evaluation: <draft-klensin-smtp-521code-05.txt> to Proposed Standard

From: "Pearl Liang via RT" <[email-masked]>
Date: Tue, 14 Apr 2015 17:59:04 +0000

IESG:

IANA NOT OK.  Comments in tracker
IANA Actions - YES

1) A question posted in the tracker and in the IANA Last Call comments.

2) Expert review is depended on a clarification to the question.

Thank you,

Pearl Liang
ICANN

On Mon Apr 06 15:53:25 2015, [email-masked] wrote:
> Evaluation for <draft-klensin-smtp-521code-05.txt> can be found at
> http://datatracker.ietf.org/doc/draft-klensin-smtp-521code/
> 
> Last call to expire on: 2015-04-02 00:00 PDT
> 
> 
> Please return the full line with your position.
> 
> Yes  No-Objection  Discuss  Abstain
> Barry Leiba          [ X ]     [   ]      [   ]    [   ]
> 
> 
> Needs 9 more YES or NO OBJECTION positions to pass.
> 
> DISCUSSES AND COMMENTS
> ======================
> 
> ---- following is a DRAFT of message to be sent AFTER approval ---
> From: The IESG <[email-masked]>
> To: IETF-Announce <[email-masked]>
> Cc: RFC Editor <[email-masked]>
> Subject: Protocol Action: 'SMTP 521 and 556 Reply Codes' to Proposed
> Standard (draft-klensin-smtp-521code-05.txt)
> 
> The IESG has approved the following document:
> - 'SMTP 521 and 556 Reply Codes'
>   (draft-klensin-smtp-521code-05.txt) as Proposed Standard
> 
> This document has been reviewed in the IETF but is not the product of
> an
> IETF Working Group.
> 
> The IESG contact person is Barry Leiba.
> 
> A URL of this Internet Draft is:
> http://datatracker.ietf.org/doc/draft-klensin-smtp-521code/
> 
> 
> 
> 
> Technical Summary
> 
> This memo defines two Simple Mail Transfer Protocol (SMTP) reply
> codes, 521 and 556.  The 521 code was originally described in an
> Experimental RFC in 1995 and is in wide use, but has not previously
> been formally incorporated into SMTP.  The 556 code was created for
> RFC-nullMX.  These codes are used to indicate that an Internet host
> does not accept incoming mail at all (not just under particular
> circumstances).
> 
> This is presented for publication as a Proposed Standard, as it adds
> codes
> to RFC 5321, which is already standards track.
> 
> 
> Review and Consensus
> 
> This document came out of discussions on both the apps discuss and
> ietf-smtp
> mailing lists about (1) moving RFC 1846 to the standards track, and
> (2) the
> nullMX idea. There was wide-spread agreement on both of those efforts,
> including accepting nullMX as an APPS WG document.
> 
> The decision to create this document was mostly due to administrative
> ease so
> that there was only one document updating RFC 5321 instead of two. The
> nullMX document was then rewritten to point to this document. (The
> nullMX
> document has been through 10 revisions since becoming an APPS WG
> document.)
> 
> There is widespread implementation of both of these return codes.
> 
> 
> Personnel
> 
> Tony Hansen is the Document Shepherd. Barry Leiba is the responsible
> Area Director. This document is an individual submission.

---

From: Ned Freed <[email-masked]>
Date: Tue, 14 Apr 2015 11:53:52 -0700 (PDT)

No doubt I'm missing something obvious, but where do I see this comments
on the new datatracker?

				Ned

> _______________________________________________
> ietf-smtp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-smtp

---

From: Barry Leiba <[email-masked]>
Date: Tue, 14 Apr 2015 15:12:56 -0400

> No doubt I'm missing something obvious, but where do I see this comments

In the "History" tab.  Trouble is that the IANA review isn't well
marked (never has been).

Barry

---

From: Ned Freed <[email-masked]>
Date: Tue, 14 Apr 2015 12:21:45 -0700 (PDT)

> In the "History" tab.  Trouble is that the IANA review isn't well

So today's message refers to the comments made two weeks ago?

This seems odd, but OK.

				Ned

---

From: "Pearl Liang via RT" <[email-masked]>
Date: Tue, 14 Apr 2015 20:02:29 +0000

Hi Barry,

> In the "History" tab.  Trouble is that the IANA review isn't well

Any suggestions to improve that?  How about to mark our Comments as 
"IANA Comments" in the History tab?

In any case, can you please clarify this?

QUESTION: In the IANA Considerations section, should "X.10.1" actually be "X.1.10," or is the document referring to an entry that will be registered by another document?

Thanks,
~pl

---

From: John C Klensin <[email-masked]>
Date: Tue, 14 Apr 2015 16:38:10 -0400

--On Tuesday, April 14, 2015 12:21 -0700 Ned Freed
<[email-masked]> wrote:

>> > No doubt I'm missing something obvious, but where do I see
>> > this comments on the new datatracker?
> 
>> In the "History" tab.  Trouble is that the IANA review isn't
>> well marked (never has been).
> 

Ned (and others),

That aside, the real issue here is that someone needs to check
the extended code and either reassure IANA that it is correct
(and that the document should say "register the code") or tell
them (and me) that I made a typographical or transcription
error.  As I've told Barry and a few others, my IETF time is
completely tied up with URNBIS, some closely-related issues
(including whether or note the URI scheme registration document
has important side-effects), and some IAB-related stuff.   If
I'm not actually on travel, I would have time to patch some text
into the otherwise-ready-to-go -06 of this document, but not the
bandwidth to study the extended codes.  If someone who is closer
to them than I am could do that, we could probably get this
document cleared rather than wondering what is happening with it.

   john

---

From: Tony Hansen <[email-masked]>
Date: Tue, 14 Apr 2015 17:30:49 -0400

John, you made a transcription error. The code should be X.1.10.

In draft-ietf-appsawg-nullmx-10, it's listed as 5.1.TBD, and IANA 
assigned a 10 to the TBD.

     Tony

---

From: Barry Leiba <[email-masked]>
Date: Tue, 14 Apr 2015 17:35:31 -0400

I'm tired of having to approve every post for having "implicit
destination", so please reply to this one if there's further
discussion; I've added the ietf-smtp list explicitly.

Barry

On Tue, Apr 14, 2015 at 5:30 PM, Tony Hansen <[email-masked]> wrote:
> In draft-ietf-appsawg-nullmx-10, it's listed as 5.1.TBD, and IANA assigned a
> 10 to the TBD.
>
>     Tony
>
>

---

From: Barry Leiba <[email-masked]>
Date: Tue, 14 Apr 2015 17:35:31 -0400

Barry

---

From: John C Klensin <[email-masked]>
Date: Tue, 14 Apr 2015 18:05:40 -0400

Ok.  I've also just changed my address on the ietf-smtp list to
allow me to post to that list as well as
draft-klensin-smtp-521code.all from the same address.

I consider Tony's "transcription error" to be definitive unless
someone speaks up RSN.  Pearl, that means "X.10.1" should indeed
be "X.1.10".

Unless someone (particularly Barry) objects within the next
couple of hours, I will post draft-klensin-smtp-521code-06,
which reflects this change and other changes that seem to be
agreed upon, later this evening or early tomorrow.  The major
change is a rewrite to the discussion of code 556 to make the
client and server relationships more clear as discussed on-list
earlier.

    john

--On Tuesday, April 14, 2015 17:35 -0400 Barry Leiba
<[email-masked]> wrote:

>> In draft-ietf-appsawg-nullmx-10, it's listed as 5.1.TBD, and
>> IANA assigned a 10 to the TBD.
>> 
>>     Tony
>> 
>> 
>>>>> In the "History" tab.  Trouble is that the IANA review
>>>>> isn't well marked (never has been).
>>>> 
>>> That aside, the real issue here is that someone needs to
>>> check the extended code and either reassure IANA that it is
>>> correct (and that the document should say "register the
>>> code") or tell them (and me) that I made a typographical or
>>> transcription error.  As I've told Barry and a few others,
>>> my IETF time is completely tied up with URNBIS, some
>>> closely-related issues (including whether or note the URI
>>> scheme registration document has important side-effects),
>>> and some IAB-related stuff.   If I'm not actually on travel,
>>> I would have time to patch some text into the
>>> otherwise-ready-to-go -06 of this document, but not the
>>> bandwidth to study the extended codes.  If someone who is
>>> closer to them than I am could do that, we could probably
>>> get this document cleared rather than wondering what is
>>> happening with it.
>>> 
>>>     john
>>> 
>>> 
>>> 
>>

---

From: John C Klensin <[email-masked]>
Date: Tue, 14 Apr 2015 18:05:40 -0400

john

---

From: Barry Leiba <[email-masked]>
Date: Tue, 14 Apr 2015 18:13:54 -0400

> someone speaks up RSN.  Pearl, that means "X.10.1" should indeed

That's what I guessed, but guesses aren't good enough.

> agreed upon, later this evening or early tomorrow.

No objection from me, clearly.

b

---

From: Barry Leiba <[email-masked]>
Date: Tue, 14 Apr 2015 18:13:54 -0400

b

---

From: John C Klensin <[email-masked]>
Date: Wed, 15 Apr 2015 07:50:14 -0400

Sorry for delay -- xml2rfc has stopped resolving entity
references to the bibxml library and I didn't have the energy
last night to work around it.  Posted now.

   john

---

From: John C Klensin <[email-masked]>
Date: Wed, 15 Apr 2015 07:50:14 -0400

john

---

From: "Pearl Liang via RT" <[email-masked]>
Date: Wed, 15 Apr 2015 16:53:08 +0000

Ned,

> No doubt I'm missing something obvious, but where do I see this comments

We in general do not send our Evaluation comments to the datatracker.  We 
normally refer to the Last Call comments logged in the tracker.

Thanks,
~pl

---

From: "Pearl Liang via RT" <[email-masked]>
Date: Wed, 15 Apr 2015 18:33:54 +0000

Hi John, et al.

Version 06 has clarified the value.  We are sending this request to the designated
expert for approval.   

Thanks,
~pl

Pearl Liang
ICANN

---

From: "Pearl Liang via RT" <[email-masked]>
Date: Wed, 15 Apr 2015 18:33:54 +0000

Hi John, et al.

Thanks,
~pl

Pearl Liang
ICANN