Subject: [ietf-smtp] MX Priority and Microsoft/GMail adherence

From: "Adrian Neale (iComms)" <[email-masked]>
Date: Sun, 21 Feb 2016 00:34:31 +0000

Hi there, just joined to try and get some knowledge/help on an issue when getting emails delivered from (particularly) Hotmail/Outlook.com but occasionally Gmail addresses.  I consulted RFC5321 and it does say the mail delivery will be tried in order of MX preference.

Background:

We have set up a Sophos UTM which is a pretty sophisticated device.  This is in front of an Exchange server and filters all incoming/outgoing emails.

The domain being used is, say, abc.com

Our MX records for this domain are:

0 autodiscover.abc.com

10 mail.abc.com

20 mxbackup.3rdparty.com

The 3rd priority MX record is in the event of an outage, the emails queue and return to the top MX entry once the mail server returns from e.g. a reboot or Internet downtime.  It is hosted in a different country to the top priority MX records.

What we are finding is that 90% of Hotmail/Outlook.com emails sent to the domain abc.com are coming from mxbackup.3rdparty.com.  All other domains behave as expected and come in via 0 autodiscover.abc.com.  Some Gmails follow this behaviour too.

This is where the IETF comes in as it would appear to go against the RFC for MX delivery.

What brought this to our attention was that our Sophos UTM instantly started rejecting emails from our 3rd party MX provider, all of them from Hotmail/Outlook.com.

It is happening with all 3 of the UTM devices that we have fitted so far, all on different domains, different public IP addresses, all in Gibraltar.  Our 3rd Party MX is located in Manchester, United Kingdom.

We have obviously now added our 3rd Party as an upstream relay but this is not ideal – why are these emails going to the 3rd priority MX record in the first place?

The primary MX public IP addresses on all 3 UTM's are not blacklisted and pretty much have 99% or higher availability.

I am going to be asking Sophos if the UTM is in any way delaying it’s response to the Microsoft mail servers to eliminate it being the UTM taking too long to reply for Hotmail’s/Gmail’s liking.

I do not think that is the case as it is only with these two email providers that we have the issue.

Thanks in advance for any possible help or advice.

Regards,

Adrian.

---

From: Steve Atkins <[email-masked]>
Date: Sat, 20 Feb 2016 17:13:31 -0800

> On Feb 20, 2016, at 4:34 PM, Adrian Neale (iComms) <[email-masked]> wrote:
> 

You'll likely find more help with operational problems on the mailop list - it's much more about ops and less about developing SMTP related protocols.

    https://chilli.nosignal.org/cgi-bin/mailman/listinfo/mailop

There are all sorts of problems you could have with your setup; it's more likely that someone there will be able to help if you share the domains and IP addresses involved, and any bounce or deferral messages or logs.

Cheers,
  Steve

> _______________________________________________
> ietf-smtp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-smtp