Subject: [ietf-smtp] why I'm discussing the spam filtering problem

From: Keith Moore <[email-masked]>
Date: Sun, 4 Oct 2020 22:18:08 -0400

It's because I care about Internet email, and having it work well.   
It's because I hate to see Internet email lose out to FacedOut and 
LockedBook and Tooter and Frop and most of the other profoundly 
dysfunctional toys that people use for interpersonal messaging these 
days.   It's because (and I'll probably regret saying this) RFC821, 
RFC822, and their descendants have actually held up fairly well in terms 
of functionality, especially in comparison to these toys, though there's 
clearly a need for improvement by now.

I'd like to think that other people here also care about having Internet 
email work well, but so far the loudest people just seem to be screaming 
for their right to sabotage it.   Maybe there's some good intent and 
good faith buried in those arguments, but it's hard to see.

Keith

---

From: Scott Kitterman <[email-masked]>
Date: Sun, 04 Oct 2020 23:48:32 -0400

> good faith buried in those arguments, but it's hard to see.

My advice would be stare harder.

In my view, email without spam filtering would be totally unusable.

Spam filtering email may cause problems, but it is still a net benefit.  It's 
necessary precisely because email is such a great messaging system.

What's your solution?  Don't filter and deliver everything isn't a solution.  
It merely transfers the problem to someone else.

Scott K

---

From: Keith Moore <[email-masked]>
Date: Mon, 5 Oct 2020 00:06:25 -0400

> In my view, email without spam filtering would be totally unusable.

Well, in my experience, that depends.   I operate some accounts with no 
spam filtering, some with, using different accounts for different 
purposes.   That has worked fairly well for me.  I do get some spam on 
the unfiltered accounts, but not enough to be terribly bothersome, and 
it's certainly better to leave spam filtering off for those accounts 
than to risk losing a gig.

(I have other accounts that get horrendous amounts of spam despite 
having spam filtering.   I'm phasing those out but it can take a long 
time to update everyone's idea of your email address.)

> Spam filtering email may cause problems, but it is still a net benefit.
I do find spam filtering useful in some instances, but don't see a 
general net benefit.  Sometimes it's a win, sometimes it's a huge lose.

> It's necessary precisely because email is such a great messaging system.
I don't follow that.   Certainly spam filter is sometimes necessary, 
though, because email is so accessible.
> It merely transfers the problem to someone else.

Agree, but I wouldn't expect the optimum to be at such an extreme anyway.

I have some ideas, but I don't think I could work out the entire 
solution by myself.   And in an environment with as much hostility as 
this one, I don't think suggesting something that isn't both 
comprehensive and comprehensible is likely to produce any kind of 
constructive discussion.

Keith

---

From: Scott Kitterman <[email-masked]>
Date: Mon, 05 Oct 2020 00:22:20 -0400

> general net benefit.  Sometimes it's a win, sometimes it's a huge lose.

And anyone who want to receive email without filtering is quite free to do so.

> though, because email is so accessible.

What you said is the same thing I said, just said differently.

> > What's your solution?  Don't filter and deliver everything isn't a
> > solution. It merely transfers the problem to someone else.
> 

I will confess that I haven't been following the recent threads exhaustively, 
but I haven't seen it.  I think the most hostile email I've seen recently is 
yours that I originally replied to where you accused people who disagree with 
you of actively wanting to sabotage email.  I agree that sort of discussion is 
unlikely to be productive.

Scott K

---

From: Laura Atkins <[email-masked]>
Date: Mon, 5 Oct 2020 10:29:44 +0100

> On 5 Oct 2020, at 05:06, Keith Moore <[email-masked]> wrote:
> 
> Well, in my experience, that depends.   I operate some accounts with no spam filtering, some with, using different accounts for different purposes.   That has worked fairly well for me.  I do get some spam on the unfiltered accounts, but not enough to be terribly bothersome, and it's certainly better to leave spam filtering off for those accounts than to risk losing a gig.
> 
I operate all my accounts with no server side spam filtering. It’s actually quite bothersome. But given my client base (people who are falling afoul of filters) the other options for letting potential clients contact me are unappealing to me.
> (I have other accounts that get horrendous amounts of spam despite having spam filtering.   I'm phasing those out but it can take a long time to update everyone's idea of your email address.)
> 
Have you never accidentally deleted a wanted message? I’ll be honest, I won’t believe you if you say no. 
> I do find spam filtering useful in some instances, but don't see a general net benefit.  Sometimes it's a win, sometimes it's a huge lose.

Filtering is about more than blocking spam. It’s about blocking malware and viruses, it’s about blocking phishing. It’s about providing a safer environment for end users. 

> I don't follow that.   Certainly spam filter is sometimes necessary, though, because email is so accessible.
I don’t think having a static IP with a consistent hostname and HELO/EHLO is an extreme requirement in the least. 
> I have some ideas, but I don't think I could work out the entire solution by myself.   And in an environment with as much hostility as this one, I don't think suggesting something that isn't both comprehensive and comprehensible is likely to produce any kind of constructive discussion.
> 
That statement has gone past passive aggressive and is, itself, hostile. And likely a violation of the list code of conduct.

laura

-- 
Having an Email Crisis?  We can help! 800 823-9674 

Laura Atkins
Word to the Wise
[email-masked]
(650) 437-0741		

Email Delivery Blog: https://wordtothewise.com/blog

---

From: Keith Moore <[email-masked]>
Date: Mon, 5 Oct 2020 13:50:35 -0400

> And anyone who want to receive email without filtering is quite free to do so.

Is that generally true?   I haven't done a wide survey, but most of my 
mail accounts don't seem to have the option to disable filtering.

> What you said is the same thing I said, just said differently.

I guessed right for once.

Keith

---

From: Dave Crocker <[email-masked]>
Date: Mon, 5 Oct 2020 13:42:50 -0700

On 10/5/2020 2:29 AM, Laura Atkins wrote:
> That statement has gone past passive aggressive and is, itself, hostile. 
> And likely a violation of the list code of conduct.

Seems to have been a popular tone yesterday.  There were multiple 
postings with the problem.

And it isn't getting acknowledged, in spite of its being noted multiple 
times, by at least 3 different people.

And, yeah, it is totally against IETF code of conduct.  Not that that 
gets enforced reliably.

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: "Bron Gondwana" <[email-masked]>
Date: Tue, 06 Oct 2020 17:01:12 +1100

> (I have other accounts that get horrendous amounts of spam despite having spam filtering.   I'm phasing those out but it can take a long time to update everyone's idea of your email address.)

We reject or discard over 90% of email before it reaches the mailbox for our customers, and still one of the most common complaints is that too much spam gets through.

Brandon has of course worked on a much larger system, as have others in these discussions.

Mostly, given the choice between systems without spam filtering, and systems with spam filtering, people select the ones with spam filtering.  That's a reality that we need to grapple with if we want adoption.

Cheers,

Bron.

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]