Subject: Re: [ietf-smtp] [Emailcore] Proposed ESMTP keyword RCPTLIMIT

From: Jeremy Harris <[email-masked]>
Date: Sun, 18 Apr 2021 20:09:39 +0100

On 17/03/2021 21:19, Jeremy Harris wrote:
> On 15/03/2021 14:59, Ned Freed wrote:
>> I think this extension is an important thing to have, so I've put together the
>> beginnings of a specification:
>>
>>    https://datatracker.ietf.org/doc/draft-freed-smtp-limits/

> an implementation

Now available from the Exim git.
-- 
Cheers,
   Jeremy

---

From: Ned Freed <[email-masked]>
Date: Sun, 18 Apr 2021 13:38:53 -0700 (PDT)

> Now available from the Exim git.

Very cool!

FWIW, I just submitted an updated draft. It should not affect your implementation.

				Ned

---

From: "John Levine" <[email-masked]>
Date: 18 Apr 2021 18:23:05 -0400

>FWIW, I just submitted an updated draft. It should not affect your implementation.

Added it to my tiny MTA, too. The options to set limits were always
there, this just added a tiny plugin to add them to the EHLO response.

$ telnet -4 mail2.iecc.com 25
Trying 64.57.183.52...
Connected to mail2.iecc.com.

220 mail2.iecc.com mailfront ESMTP
ehlo pedro.iecc.com
250-mail2.iecc.com
250-SMTPUTF8
250-AUTH LOGIN
250-LIMTS RCPTMAX=20 MAILMAX=5
250-SIZE 100000000
250-8BITMIME
250-ENHANCEDSTATUSCODES
250-PIPELINING
250-CHUNKING
250 STARTTLS
quit
221 2.0.0 Good bye.

---

From: Hector Santos <[email-masked]>
Date: Mon, 19 Apr 2021 04:44:57 -0400

> 250-LIMTS RCPTMAX=20 MAILMAX=5

LIMTS or LIMITS?

Ned, can you add examples to the draft?

Thanks

-- 
Hector Santos,
https://secure.santronics.com
https://twitter.com/hectorsantos

---

From: Ned Freed <[email-masked]>
Date: Mon, 19 Apr 2021 11:53:25 -0700 (PDT)

> LIMTS or LIMITS?

LIMITS in the specification ;-)

> Ned, can you add examples to the draft?

Good idea. Consider it done.

				Ned

---

From: "John Levine" <[email-masked]>
Date: 19 Apr 2021 16:35:39 -0400

>LIMITS in the specification ;-)

Hey, my degree is in computer science, not orthography.  Fixed.

R's,
John