Subject: [ietf-types] Registration of media type application/calendar+xml (revised)

From: Steven Lees <[email-masked]>
Date: Thu, 4 Nov 2010 23:26:57 +0000

Hello,

Thanks for the earlier feedback on the media type registration for application/calendar+xml. I've published an updated draft that incorporates that feedback: https://datatracker.ietf.org/doc/draft-daboo-et-al-icalendar-in-xml/.

The spec changes based on the discussion feedback include:

1.       Changed media type registration file extension to "xcs"

2.       Changed media type registration follow up email to [email-masked]

3.       Updated several parts of the specification to show how most future extensions to iCalendar can be handled without changing this specification

4.       Updated security concerns in section 5

5.       Updated encoding considerations

Here is the updated media type registration from the current draft:

Type name:
application
Subtype name:
calendar+xml
Required parameters:
none
Optional parameters:
method, component and optinfo as defined for the text/calendar media type in [RFC5545]; charset as defined for application/xml in [RFC3023]; per [RFC3023], use of charset is "STRONGLY RECOMMENDED"
Encoding considerations:
Same as encoding considerations of application/xml as specified in [RFC3023]
Security considerations:
See Section 5.
Interoperability considerations:
This media type provides an alternative format for iCalendar data based on XML.
Published specification:
This specification.
Applications which use this media type:
Applications that currently make use of the text/calendar media type can use this as an alternative.
Additional information:
Magic number(s):
None
File extension(s):
xcs
Macintosh file type code(s):
None specified.
Person & email address to contact for further information:
[email-masked]<mailto:[email-masked]>
Intended usage:
COMMON
Restrictions on usage:
There are no restrictions on where this media type can be used.
Author:
See the "Author's Address" section of this document.
Change controller:
IETF

Thanks,
Steven

---

From: Steven Lees <[email-masked]>
Date: Tue, 9 Nov 2010 03:56:35 +0000

Yes, that seems like a reasonable change, and I'll incorporate it in the next revision.

Thanks,
Steven

From: Paul Libbrecht [mailto:[email-masked]]
Sent: Saturday, November 06, 2010 2:03 AM
To: Steven Lees
Cc: [email-masked]; Cyrus Daboo ([email-masked]); Douglass Mike
Subject: Re: [ietf-types] Registration of media type application/calendar+xml (revised)

On 5 nov. 2010, at 00:26, Steven Lees wrote:

Optional parameters:

Could I recommend it to be the following based on our previous discussion?

paul

Optional parameters:
method, component and optinfo as defined for the text/calendar media type in [RFC5545]; charset as defined for application/xml in [RFC3023]; per [RFC3023], use of the charset parameter with the value utf-8 is "STRONGLY RECOMMENDED"