Subject: Re: [ietf-types] Request for review of standards tree registration request for OpenXPS

From: Brian Clubb <[email-masked]>
Date: Wed, 16 Mar 2011 20:14:40 +0000

I received some feedback directly that did not include the mailing list.  I have verified the feedback and updated the "Magic Number" section in the template.  Having received no further feedback, I am making a "Last Call" request for comment before sending this on.

Thanks!
Brian

TEMPLATE:

Name : Brian Clubb

Email : [email-masked]

MIME media type name : application

MIME subtype name : Standards Tree - openxps

Required parameters : N/A

Optional parameters :
N/A

Encoding considerations : 8-bit

Security considerations :
OpenXPS uses ZIP compression as specified in .ZIP File Format Specification from PKWARE, Inc., version 6.2.0 (2004).  ZIP compressed XML requires parsing untrusted XML data and untrusted ZIP data.  consumer is responsible for validating the .zip archive, the XML structure, and the resource content.  Per spec, there should be no active content provided as part of the OpenXPS format.  The consumer must ensure that no malicious active content is erroneously provided in the OpenXPS document.  Valid content is described in the EMCA-388 specification (http://www.ecma-international.org/publications/standards/Ecma-388.htm)

Also see section E.3 of ECMA-388 specification (http://www.ecma-international.org/publications/standards/Ecma-388.htm)

OpenXPS Documents follow requirements set out in this Standard, as well as other normative references including the Open Packaging Conventions. Implementations may use the following steps to identify an unknown file or stream as an OpenXPS Document within an Open Packaging Conventions payload. 1. Test that the file or stream is a ZIP file a. As required by §9.2 of the Open Packaging Conventions

b. First four bytes correspond to the local file header signature defined in the .ZIP File Format Specification from PKWARE, Inc., version 6.2.0 (2004)  2. Test that a valid Package Relationships zip item exists a. As required by §8.3.4 of the Open Packaging Conventions b. Check that the content type for the package relationships zip item is correctly defined in the Content Types stream (see OPC §8.1.2) as a relationships part 3. Test that the Package Relationships Part contains a relationship (see OPC §8.3) whose Target attribute points to a valid FixedDocumentSequence Part a. As required by §10.2 of this Standard b. Check that the content type for the FixedDocumentSequence part is correctly defined in the Content Types stream as a FixedDocumentSequence part

Interoperability considerations :
application/OpenXPS documents are specified by the XML schemas
   standardized in ECMA-388.
Applications and drivers currently producing/consuming Microsoft XPS content cannot directly produce/consume OpenXPS.  Changes are required to address differences in the two specifications, such as namespace, print ticket usage, use of JPEG XR, etc.

Published specification :
The published Standard ECMA-388 is available at:
http://www.ecma-international.org/publications/standards/Ecma-388.htm

Applications which use this media :
The application/oxps MIME type can be used to identify CSTA XML
(ECMA-388) instance documents.  No published applications or print drivers currently use OpenXPS.  The intent is for any application or driver that can currently produce/consume Microsoft XPS to also adopt OpenXPS.  Examples of such applications would include but are not limited to:  Microsoft XPS Viewer, Microsoft XPS Document Writer, Microsoft Internet Explorer 9.

Additional information :

1. Magic number(s) : ZIP archive CRC-32: 504b 0304 per http://www.pkware.com/documents/APPNOTE/APPNOTE-6.2.0.txt.  Note that is it a requirement of the consumer to ensure that the contents of the ZIP archive is a valid OpenXPS structure.
2. File extension(s) : .oxps
3. Macintosh file type code : org.ecma.oxps conforms to com.pkware.zip-archive
4. Object Identifiers: N/A
5. Windows clipboard name:  "OpenXPS"

To ensure interoperability, the clipboard format must be a complete OpenXPS file with .oxps extension.

Person & email address to contact for further information:
Ecma International Helpdesk
Rue du Rhone114
CH-1204 Geneva
Switzerland
[email-masked]

Person to contact for further information :

1. Name : Ecma International Helpdesk
2. Email : [email-masked]

Intended usage : Common
This type will be used for all documents conforming to the Open XML
   Paper Specifcation's (ECMA-388) Open XPS Document format, published
   by ECMA.

Author/Change controller : The ECMA-388 Standard is developed and
   maintained by the Ecma TC46 Working Group.

---

From: Paul Libbrecht <[email-masked]>
Date: Mon, 21 Mar 2011 21:25:05 +0100

Thank you Brian,

> 3. Macintosh file type code : org.ecma.oxps conforms to com.pkware.zip-archive

should read:

3. Macintosh uniform type identifier : org.ecma.oxps conforms to com.pkware.zip-archive

I promise this is my last word.. ;-).

paul

---

From: Brian Clubb <[email-masked]>
Date: Mon, 21 Mar 2011 20:27:12 +0000

No worries!  I appreciate the feedback!

Here is the corrected template:
Name : Brian Clubb

Optional parameters :
N/A

Additional information :

Intended usage : Common

-----Original Message-----
From: Paul Libbrecht [mailto:[email-masked]] 
Sent: Monday, March 21, 2011 1:25 PM
To: Brian Clubb
Cc: [email-masked]
Subject: Re: [ietf-types] Request for review of standards tree registration request for OpenXPS

Thank you Brian,

should read:

paul