Subject: [ietf-types] Request for review of Notation3 (an RDF serialization) media type: text/n3

From: Eric Prud'hommeaux <[email-masked]>
Date: Fri, 11 Mar 2011 18:36:46 -0500

Believing all of the issues in
<http://www.w3.org/2008/01/rdf-media-types> to be resolved, I'd like a
review of the media type text/n3 . The Published specification
will be <http://www.w3.org/TeamSubmission/2011/SUBM-n3-20110314/>,
which will be the same as
<http://www.w3.org/TeamSubmission/2008/SUBM-n3-20080114/> with
modifications to the media type sections.

Contact:
    Eric Prud'hommeaux
See also:
    How to Register a Media Type for a W3C Specification
    Internet Media Type registration, consistency of use
    TAG Finding 3 June 2002 (Revised 4 September 2002)

The Internet Media Type / MIME Type for Notation3 is "text/n3".

It is recommended that Notation3 files have the extension ".n3" (all lowercase) on all platforms.

It is recommended that sparql query files stored on Macintosh HFS file systems be given a file type of "TEXT".

This information that follows has been submitted to the IESG for review, approval, and registration with IANA.

Type name:
    text
Subtype name:
    n3
Required parameters:
    None
Optional parameters:
    charset — this parameter is required when transfering non-ASCII data. If present, the value of charset is always UTF-8.
Encoding considerations:
    The syntax of Notation3 is expressed over code points in Unicode [UNICODE]. The encoding is always UTF-8 [RFC3629].
    Unicode code points may also be expressed using an \uXXXX (U+0 to U+FFFF) or \UXXXXXXXX syntax (for U+10000 onwards) where X is a hexadecimal digit [0-9A-F]
Security considerations:
    Notation3 is a general-purpose assertion and logic language; built-in functions evaluate given data to infer more assertions. Certain built-in functions may dereference URIs, invoking the security considerations of the scheme for that URI. Note in particular, the privacy issues in [RFC3023] section 10 for HTTP URIs. Data obtained from an inaccurate or malicious data source may lead to inaccurate or misleading conclusions, as well as the dereferencing of unintended URIs. Built-in functions allow one to parameterize the incorporation of data: one example of more careful behavior would be to incorporate a source document only ifs hash matches a stated value and one may incorporate only those assertions matching a stated pattern. Care must be taken to align the trust in consulted resources with the sensitivity of the intended use of the data; inferences of potential medical treatments would likely require different trust than inferences for trip planning.
    Notation3 is used to express arbitrary application data; security considerations will vary by domain of use. Security tools and protocols applicable to text (e.g. PGP encryption, MD5 sum validation, password-protected compression) may also be used on Notation3 documents. Security/privacy protocols must be imposed which reflect the sensitivity of the embedded information.
    Notation3 can express data which is presented to the user, for example, RDF Schema labels. Application rendering strings retrieved from untrusted Notation3 documents must ensure that malignant strings may not be used to mislead the reader. The security considerations in the media type registration for XML ([RFC3023] section 10) provide additional guidance around the expression of arbitrary data and markup.
    Notation3 uses IRIs as term identifiers. Applications interpreting data expressed in Notation3 sould address the security issues of Internationalized Resource Identifiers (IRIs) [RFC3987] Section 8, as well as Uniform Resource Identifier (URI): Generic Syntax [RFC3986] Section 7.
    Multiple IRIs may have the same appearance. Characters in different scripts may look similar (a Cyrillic "о" may appear similar to a Latin "o"). A character followed by combining characters may have the same visual representation as another character (LATIN SMALL LETTER E followed by COMBINING ACUTE ACCENT has the same visual representation as LATIN SMALL LETTER E WITH ACUTE). Any person or application that is writing or interpreting data in Notation3 must take care to use the IRI that matches the intended semantics, and avoid IRIs that make look similar. Further information about matching of similar characters can be found in Unicode Security Considerations [UNISEC] and Internationalized Resource Identifiers (IRIs) [RFC3987] Section 8.
Interoperability considerations:
    There are no known interoperability issues.
Published specification:
    http://www.w3.org/TeamSubmission/2011/SUBM-n3-20110314/
Applications which use this media type:
    No widely deployed applications are known to use this media type. It may be used by some web services and clients consuming their data.
Additional information:
Magic number(s):
    Notation3 documents may have the strings '@prefix' or '@base' (case dependent) near the beginning of the document.
File extension(s):
    ".n3"
Base URI:
    The Notation3 '@base <IRIref>' term can change the current base URI for relative IRIrefs in the query language that are used sequentially later in the document.
Macintosh file type code(s):
    "TEXT"
Person & email address to contact for further information:
    Eric Prud'hommeaux <[email-masked]>
Intended usage:
    COMMON
Restrictions on usage:
    None
Author/Change controller:
    The Notation3 specification is the product of Tim Berners-Lee. A W3C Working Group may assume maintenance of this document; W3C reserves change control over this specifications.

Note, this follows a request for a similar media type text/turtle .
--
-ericP

---

From: Eric Prud'hommeaux <[email-masked]>
Date: Sat, 12 Mar 2011 07:50:29 -0500

* Eric Prud'hommeaux <[email-masked]> [2011-03-11 18:36-0500]

Contact:
    Eric Prud'hommeaux
See also:

It is recommended that Notation3 files stored on Macintosh HFS file systems be given a file type of "TEXT".

Type name:
    text
Subtype name:
    n3
Required parameters:
    None
Optional parameters:
    http://www.w3.org/TeamSubmission/2008/SUBM-n3-20080114/

-- 
-ericP