Subject: [ietf-types] Mimetype approval request for type jcr-cnd

From: Peeter Piegaze <[email-masked]>
Date: Tue, 6 Mar 2012 05:16:19 -0800

The following proposal for a new type was submitted to the ietf types mailing list some time ago.

I would like to move the process forward and request approval for this type.

Cheers,

Peeter Piegaze

Adobe Research Switzerland

Basel Switzerland

==============

Type name: text

Subtype name: jcr-cnd

Required parameters: None

Optional parameters: None

Encoding considerations: 8 bit (UTF-8)

Security considerations: None known

Interoperability considerations: None

Published specification: JSR-283 Content Repository Specification for Java Technology (JCR)
(http://jcp.org/en/jsr/detail?id=283). See especially sections 3.7 and 25.2.
If approved, this MIME type will be included in the next revision of JCR,
which is under development as JCR-333 (http://jcp.org/en/jsr/detail?id=333)

Applications that use this media type: Used by content repositories that implement the
Content Repository For Java API (JCR)

Additional information:
File extension(s): .cnd

Person & email address to contact for further information:
Peeter Piegaze ppiegaze at adobe.com<http://adobe.com>
David Nuescheler uncled at adobe.com<http://adobe.com>

Intended usage: Common

Restrictions on usage: None

Author: JSR-333 Expert Group

Change controller: Peeter Piegaze ppiegaze at adobe.com<http://adobe.com>

Files of this media type define node types in JCR-compliant content repositories. Nodes are the structural components that make up the content storage in a JCR repository. A node type defines the characteristics that a node can have. Files of this media type are typically processed by a repository, thus registering the defined node types, making them available to users of the repository. Files of this media type are typically referred to as Compact Node Type Definition files or CND files.

---

From: Julian Reschke <[email-masked]>
Date: Tue, 06 Mar 2012 17:38:05 +0100

Looks good to me, except parameters/encoding. You may want to steal from 
<http://tools.ietf.org/html/rfc6350#section-10.1>:

-- snip --
    Optional parameters:  version

       "charset": as defined for text/plain [RFC2046]; encodings other
       than UTF-8 [RFC3629] MUST NOT be used.

    Encoding considerations:  8bit
-- snip --

Best regards, Julian

On 2012-03-06 14:16, Peeter Piegaze wrote:
> Person&  email address to contact for further information:
> Peeter Piegaze ppiegaze atadobe.com  <http://adobe.com>
> David Nuescheler uncled atadobe.com  <http://adobe.com>
>
> Intended usage: Common
>
> Change controller: Peeter Piegaze ppiegaze atadobe.com  <http://adobe.com>
>
> _______________________________________________
> ietf-types mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-types

---

From: Peeter Piegaze <[email-masked]>
Date: Wed, 7 Mar 2012 04:02:30 -0800

Thanks Julian, for the correction. The updated proposal for type text/jcr-cnd is as follows:

--------

Type name: text

Subtype name: jcr-cnd

Optional parameters: "charset" as defined for text/plain [RFC2046]; encodings other than UTF-8 [RFC3629] MUST NOT be used.

Published specification: JSR-283 Content Repository Specification for Java Technology (JCR)(http://jcp.org/en/jsr/detail?id=283). See especially sections 3.7 and 25.2. If approved, this MIME type will be included in the next revision of JCR, which is under development as JCR-333 (http://jcp.org/en/jsr/detail?id=333)

Applications that use this media type: Used by content repositories that implement the Content Repository For Java API (JCR) 

Additional information:

    File extension(s): .cnd

Person & email address to contact for further information: Peeter Piegaze <ppiegaze at adobe.com>, David Nuescheler <uncled at adobe.com>

Intended usage: Common

Change controller: Peeter Piegaze <ppiegaze at adobe.com>

-------