Subject: RE: ifIndex and fault tolerant interfaces

From: Faye Ly <[email-masked]>
Date: Wed, 10 Feb 1999 10:42:31 -0800

Brian,

That is a great question!  I have never seen a redundant or secondary
interface being managed under the same ifEntry with the master interface,
but if not, how does NMS make association between the primary and secondary
interfaces?  This is traditionally done via the proprietary MIB.  I guess I
will suggest keeping that way and not mess around with the ifEntry.  Perhaps
another new table in the ifMIB which address this issue?  Does entity MIB
provide any help on this issue?

-faye

Faye Ly 
Copper Mountain Networks
2470 Embarcadero Way
Palo Alto, CA 94303
(650)858-8500 X240

		-----Original Message-----
		From:	Brian Hassink [mailto:[email-masked]]
		Sent:	Tuesday, February 09, 1999 2:50 PM
		To:	[email-masked]
		Subject:	ifIndex and fault tolerant interfaces

		Hello,

		I'm new to this forum, but it seemed like the best place to
pose this
		question. Basically, I'm looking for clarification on how
ifIndex numbers
		are utilized when fault tolerant hardware is involved.

		For example, if I have a device which has a redundant pair
of interface
		cards (i.e. the cards are in a protection group such that
the two physical
		interfaces behave as a single logical interface in a 1+1
sparing model), are
		these two interfaces managed as a single interface (one
ifIndex value and
		one instance of associated MIB information) or are they
managed
		independently (two ifIndex values and two instances of
essentially duplicate
		MIB information)?

		Cheers,
		Brian
		---
		Brian Hassink
		(919) 991-7541, (ESN) 351-7541
		Next Generation Access, Nortel Networks, RTP, North Carolina

---

From: "Brian Hassink" <[email-masked]>
Date: Wed, 10 Feb 1999 16:56:11 -0500

Faye,

My colleagues and I discussed this scenario a bit further today, and we're
beginning to think that this is a subjective problem which depends on the
nature of the MIB objects involved.

For example, if we are configuring a redundant pair of interface cards then we
would prefer to use a single ifIndex to represent both interfaces since
configuration data is common between them. However, if we are evaluating the
relative "health" of each interface then we would require an ifIndex for each
interface since performance data is unique between them.

It would seem that the safest approach is to use an ifIndex for each interface
even though certain MIB objects will apply to and affect both. The Entity MIB
would be a good choice for describing the relationship between the two
interfaces as well. Thanks for the input.

Cheers,
Brian
---
Brian Hassink
(919) 991-7541, (ESN) 351-7541
ATM Development, Next Generation Networks, Carrier Solutions
Nortel Networks, Research Triangle Park, North Carolina