Subject: [ifmib] RE: FWD: Restart ifmib WG?

From: "Dave Thaler" <[email-masked]>
Date: Thu, 1 May 2003 14:56:40 -0700

There's been a number of suggestions on this list
for improvements that would be useful to add in a 
supplemental IF MIB module in a separate RFC.

On this topic, I recently received some IF MIB 
feedback from folks here in Microsoft on things 
they considered to be missing:
> I also see RFC to be inadequate in not being able 
> to report -not known- for -current- link state and 
> speed (and instead using maximum link speed) 
> Not having separate [objects] for xmit and 
> receive link speeds, not having an object for 
> permanent mac address, no support for power 
> management, etc.

-Dave
_______________________________________________
ifmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ifmib

---

From: Keith McCloghrie <[email-masked]>
Date: Fri, 2 May 2003 10:51:57 -0700 (PDT)

Dave,

> > to report -not known- for -current- link state and 

The value 'unknown' is already defined got ifOperStatus.

> > receive link speeds, not having an object for 

The issue of link speed, both unknown speed and different speeds for
xmit/rcv, has been discussed on several previous occasions, and on each
such occasion the WG decided that any additional objects should be
placed in media-specific MIBs.  As I recall, the argument went
something like this: we have done dozens (maybe even hundreds) of
media-specific MIBs; what has changed now that didn't apply to all
those we have already done, and if it didn't apply to all those we
have already done, why is it needed now??

> > permanent mac address, no support for power 

The number of interface types which have MAC addresses and support
"power management" is certainly *less* than the number of interface
types which don't.  Thus, again, this is media-specific.

Keith.