Subject: [Igmp-mld-bis] 11/17 call

From: Brian Haberman <[email-masked]>
Date: Wed, 17 Nov 2021 10:43:23 -0500

All,
      I will not be able to make today's call. I believe there are two 
primary things to do next...

1. Start a discussion on whether to move IGMPv1, IGMPv2, and MLDv1 to 
Historic status,

2. Determine if/what functionality from RFC 4604 needs to be 
incorporated into the bis drafts.

Other items to work on?

Regards,
Brian

---

From: Hitoshi Asaeda <[email-masked]>
Date: Fri, 26 Nov 2021 17:35:38 +0900

Hi Brian and all,

What do you think of remove the EXCLUDE(S,G) filter mode operation from the standard IGMPv3/MLDv2?

There was a draft in PIM WG based on the inquiry to operators about IGMP/MLD implementation and operation status in the global networks. Were there any reports about such filter mode operation? Does someone know there are any specific use cases/applications or precise reasons to keep EXCLUDE(S,G) join in the protocol spec?

I guess EXCLUDE(S,G) is not commonly used by applications to block unnecessary sources. Even if a user wants tp explicitly refuse traffic from some sources in a group, the sources can be ignored by the application itself, not by the protocol or kernel (i.e. IGMP/MLD host side implementation).
In fact, having both INCLUDE(S,G) and EXCLUDE(S,G) filter mode operations makes the state transition in the host side implementation very complex. Even worse, EXCLUDE(S,G) requests to (re)initiate ASM tree ((*,G) tree) even though SSM tree is already created at that time. (Well, in any case, SSM can be easily stopped by receiving an EXCLUDE(S,G) or (*,G) join request, and hence SSM applications must use the SSM address range and any EXCLUDE request must be ignored for them.)

RFC5790, Lightweight IGMPv3/MLDv2, simplifies the full IGMPv3/MLDv2. It also supports/interoperates with the full version; it translates EXCLUDE(S,G) join to (*,G) join when an application requests EXCLUDE(S,G) join.
Lightweight IGMPv3/MLDv2 is hence more feasible than the full version of IGMPv3/MLDv2. But it does not ignore the EXCLUDE(S,G). It requires to implement such translation or "mapping" function, which should be eliminated from the protocol if possible. IMO, to make the protocol simpler, EXCLUDE(S,G) filter mode operation should be completely removed from the protocol.

Any comment?

Regards,

Hitoshi

> On Nov 18, 2021, at 0:43, Brian Haberman <[email-masked]> wrote:
> 
> All,
>     I will not be able to make today's call. I believe there are two primary things to do next...
> 
> 1. Start a discussion on whether to move IGMPv1, IGMPv2, and MLDv1 to Historic status,
> 
> 2. Determine if/what functionality from RFC 4604 needs to be incorporated into the bis drafts.
> 
> Other items to work on?
> 
> Regards,
> Brian
> -- 
> Igmp-mld-bis mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/igmp-mld-bis

---

From: "Mankamana Mishra (mankamis)" <[email-masked]>
Date: Mon, 29 Nov 2021 21:57:47 +0000

I echo same thoughts. I had raised this few IETF earlier that I do not see reason for having ex mode with source list. If there are some real application, it would be good to know.

From: Igmp-mld-bis <[email-masked]> on behalf of Hitoshi Asaeda <asaeda=[email-masked]>
Date: Friday, November 26, 2021 at 12:35 AM
To: Brian Haberman <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: [Igmp-mld-bis] Remove EXCLUDE(S,G) filter mode
Hi Brian and all,

Any comment?

Regards,

Hitoshi

---

From: Brian Haberman <[email-masked]>
Date: Tue, 30 Nov 2021 10:59:35 -0500

I tend to agree that exclude mode is a bit complex, but the survey 
results do show that the feature is both implemented by some vendors and 
enabled by some operators.

Given those statistics, we can't remove the function as a part of the 
process of moving IGMPv3/MLDv2 to full standard.

Brian

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 30 Nov 2021 17:18:34 +0100

What is your feeling about making it MAY or SHOULD as opposed to MUST (which it is right now).
Is that something we could do in a doc aspiring for full STD ?

Cheers
    Toerless

On Tue, Nov 30, 2021 at 10:59:35AM -0500, Brian Haberman wrote:
> I tend to agree that exclude mode is a bit complex, but the survey results
> do show that the feature is both implemented by some vendors and enabled by
> some operators.
> 

-- 
---
[email-masked]

---

From: Brian Haberman <[email-masked]>
Date: Tue, 30 Nov 2021 13:15:19 -0500

That is a gray area... RFCs 2026 and 6410 do not mention changes to the 
2119 language. I think it best to raise that question with our AD or the 
IESG.

Brian

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 30 Nov 2021 23:05:42 +0100

Right.

How about plan B: We do not modify the target IGMP/MLD bis text, but we start a
small new (proposed standard) draft that updates the full-standard bis text and 
deprecates EXCLUDE{S+,G} memberships - similar to how we deprecated interdomain
ASM via rfc8815, except thart its not BCP but stds track as it talks about
protocol functionality. 

Effectively, by being a delta against the IGMP/MLD bis text it would hopefully
be a much simpler version of the "light" variant.

Cheers
    Toerless

On Tue, Nov 30, 2021 at 01:15:19PM -0500, Brian Haberman wrote:
> That is a gray area... RFCs 2026 and 6410 do not mention changes to the 2119
> language. I think it best to raise that question with our AD or the IESG.
> 
> Brian
> 

-- 
---
[email-masked]

---

From: "Mankamana Mishra (mankamis)" <[email-masked]>
Date: Tue, 30 Nov 2021 22:11:57 +0000

I agree, this looks better approach. It gives flexibility for some of potential user of EXCLUDE (S,G) to keep using the spec as is. And lighter version makes it simpler.

Mankamana

From: Igmp-mld-bis <[email-masked]> on behalf of Toerless Eckert <[email-masked]>
Date: Tuesday, November 30, 2021 at 2:06 PM
To: Brian Haberman <[email-masked]>
Cc: [email-masked] <[email-masked]>, Mankamana Mishra (mankamis) <[email-masked]>, Hitoshi Asaeda <asaeda=[email-masked]>
Subject: Re: [Igmp-mld-bis] Remove EXCLUDE(S,G) filter mode
Right.

Cheers
    Toerless

--
---
[email-masked]