Subject: [Ila] review comments on ] draft-ietf-dmm-srv6-mobile-uplane-00.txt

From: "Bogineni, Kalyani" <[email-masked]>
Date: Mon, 5 Feb 2018 20:24:11 +0000

Satoru et al:

Can you show how your protocol interacts with SMF in the 5G architecture? 

The attached deck shows everything for 4G network. Slide 24 shows network slicing
which is a 5G feature. Do you have a deck that shows 5G architecture, procedures
and services for your functions?

Kalyani

---

From: "Bogineni, Kalyani" <[email-masked]>
Date: Tue, 6 Feb 2018 13:23:06 +0000

Satoru:

Your slide 6 shows one implementation (other operators may have other implementations).

Below is the Figure from CT4 TR 29.891. Can you show how your slide 7 impacts this

end-to-end protocol stack and which interfaces are impacted?

Your slides 9 - 13 show interactions between UPFs and SMF. There are 2 kinds of UPFs:

Anchor type UPF and service function type UPF. What are the functionalities of these?

What are the changes in SMF functionalities to support SRv6? Is the interface between

SMF and UPFs based on N4/Sx (PFCP in TS 29.244)?

Also you show IPv6/SRv6 nodes in those slides. Are the UPFs 'overlaid' on IPv6/SRv6 nodes?

Are these UPFs VNFs? Or are UPFs implemented on IPv6/SRv6 nodes?

It would be beneficial if you can provide clarifications and add a section to your draft.

Kalyani

-----Original Message-----
From: Satoru Matsushima [mailto:[email-masked]]
Sent: Tuesday, February 6, 2018 2:53 AM
To: Bogineni, Kalyani <[email-masked]>
Subject: [E] Re: review comments on ] draft-ietf-dmm-srv6-mobile-uplane-00.txt

Hello Kalyani,

>  Do you have a deck that shows 5G architecture, procedures and

> services for your functions?

Hope you find it in a tdoc from the following link:

https://urldefense.proofpoint.com/v2/url?u=http-3A__www.3gpp.org_ftp_tsg-5Fct_WG4-5Fprotocollars-5Fex-2DCN4_TSGCT4-5F81-5FReno_Docs_C4-2D176177.zip&d=DwIFAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=v2OzLQOmEladDjJ7cnv7BOUHOIJU3q5_zuGVajrMM6U&s=vvhsviIu1Hxx94-BJWqR63wLWmlzMdhh_X8op2Xv_y4&e=

Cheers,

--satoru

---

From: Satoru Matsushima <[email-masked]>
Date: Wed, 7 Feb 2018 15:04:17 +0900

Hello Kalyani,

Thank you for your feedbacks. I’ll take it into account.

And yes, slide 6 shows just one deployment scenario. A spreadsheet which I shared in my google drive would help to see the rest of scenarios.
Perhaps those would be deployed on somewhere in operators.

Cheers,
--satoru

> 2018/02/06 22:23、Bogineni, Kalyani <[email-masked]>のメール:
> 
> Satoru:
>  
> Your slides 9 – 13 show interactions between UPFs and SMF. There are 2 kinds of UPFs:
> Also you show IPv6/SRv6 nodes in those slides. Are the UPFs ‘overlaid’ on IPv6/SRv6 nodes?
> <oledata.mso>

---

From: Satoru Matsushima <[email-masked]>
Date: Thu, 8 Feb 2018 18:00:16 +0900

Hello Kalyani,

> [..snip..]

> Anchor type UPF and service function type UPF. What are the functionalities of these?

Please find some functionalities in the SRv6 mobile Uplane draft:
https://tools.ietf.org/html/draft-ietf-dmm-srv6-mobile-uplane-00#section-5

When it comes to anchor, it should be equivalent with PSA, PDU Session Anchor, in TS23.501 of 3GPP 5G_ph1 terminology.

You would also find various SRv6 functions in the network programming draft:
https://tools.ietf.org/html/draft-filsfils-spring-srv6-network-programming-03

Maybe you can see SRv6 mobile uplane as a set of SRv6 functions like a SRv6 profile for mobile with some augment.

When it comes to service function type UPF, you name it. Following draft exhibits how service chain can be done by SRv6:
https://tools.ietf.org/html/draft-xuclad-spring-sr-service-chaining-00

> SMF and UPFs based on N4/Sx (PFCP in TS 29.244)?

SMF functionalities seems still work in progress so that I couldn’t say clearly what the change to it.
In CUPS architecture for both Rel-14 and Rel-15, PFCP is expected as Sx and N4 for SRv6 Uplane with no change to over-the-wire messages in basic mode operation:
https://tools.ietf.org/html/draft-ietf-dmm-srv6-mobile-uplane-00#section-8.1

> Are these UPFs VNFs? Or are UPFs implemented on IPv6/SRv6 nodes?

When you see UPF specifically it should be controlled by SMF through N4, they are not the UPFs.
But you might see them as UPFs if a SMF doesn’t control them directly but the SMF can put the sessions to it through some other means.
3GPP SA2 has studied on that case (ETSUN). We consider how SMF deal with that case and SRv6 may help to solve the issues to it in simpler way.
Please let me know if you are interested in.

Cheers,
--satoru

---

From: "Bogineni, Kalyani" <[email-masked]>
Date: Thu, 8 Feb 2018 13:23:55 +0000

Satoru:

Thank you for pointing out further documents.

Responses inline:

-----Original Message-----
From: ila [mailto:[email-masked]] On Behalf Of Satoru Matsushima
Sent: Thursday, February 8, 2018 4:00 AM
To: Bogineni, Kalyani <[email-masked]>
Cc: [email-masked]; dmm <[email-masked]>
Subject: Re: [Ila] [E] Re: review comments on ] draft-ietf-dmm-srv6-mobile-uplane-00.txt

Hello Kalyani,

Please find some functionalities in the SRv6 mobile Uplane draft:
[KB] Your section 5.2 means that UPF closer to radio network is like SGW and your section 5.3 means that
     UPF closer to Internet is like PGW. 

When it comes to anchor, it should be equivalent with PSA, PDU Session Anchor, in TS23.501 of 3GPP 5G_ph1 terminology.
[KB] in 5G, the functionality of the 2 UPFs can be implemented as one combined function or could be implemented as 
    2 separate functions with N9 in between. 

When it comes to service function type UPF, you name it. Following draft exhibits how service chain can be done by SRv6:
 [KB] I think these are non-mobility functions as being discussed on the email thread with Marco Liebsch.

> What are the changes in SMF functionalities to support SRv6? Is the 
> interface between SMF and UPFs based on N4/Sx (PFCP in TS 29.244)?

[KB] CUPS does not support branching point function as in 5G. 

[KB] is there a TR for ETSUN that I can read?

[KB] I think your document needs to separate out 3 architectures: one for 4G - SGW/PGW; one for 4G - CUPS; and one for 5G - UPF.

[KB] I am also still not clear if the blue icons (which I think represent IP/MPLS nodes) in your slides are included in SRv6 architecture or not.

Cheers,
--satoru
_______________________________________________
ila mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ila&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=dR68JI_amykfLiJQo5cQmTXwKdX_Pn7g-Th7RudMVeM&s=xyt0QGlLtTQfHmezWhutpRYBAw5sEsJlHuzrsihNJbM&e=

---

From: Uma Chunduri <[email-masked]>
Date: Fri, 9 Feb 2018 01:47:45 +0000

Hi Satoru,

Few questions in-line
--
Uma C.

-----Original Message-----
From: ila [mailto:[email-masked]] On Behalf Of Satoru Matsushima
Sent: Thursday, February 08, 2018 1:00 AM
To: Bogineni, Kalyani <[email-masked]>
Cc: [email-masked]; dmm <[email-masked]>
Subject: Re: [Ila] [E] Re: review comments on ] draft-ietf-dmm-srv6-mobile-uplane-00.txt

[Snip..]

[Uma]: I presume this is on N6 interface once de-capsulation is done at eventual UPF.  So can I say this is one more alternative to NSH ??
                Do you see any relevance of this in any other interface?

...

[Uma]: Didn't quite understand. Are you referring southbound interface like PCEP here?

---

From: Satoru Matsushima <[email-masked]>
Date: Fri, 9 Feb 2018 17:25:13 +0900

Hello Kalyani,

> [KB] is there a TR for ETSUN that I can read?

You can read it later on this September. See https://portal.3gpp.org/ngppapp/CreateTdoc.aspx?mode=view&contributionUid=SP-170743

> [KB] I think your document needs to separate out 3 architectures: one for 4G - SGW/PGW; one for 4G - CUPS; and one for 5G - UPF.

If you mean SRv6 Mobile Uplane draft, it is already a WG document, not my draft. So I’d collect opinions on this from WG. I’m sorry for that.
As a co-author of the draft, I’m afraid I disagree. SRv6 Mobile Uplane draft specifies SRv6 functions for mobile user plane, which should be architecture agnostic.

> [KB] I am also still not clear if the blue icons (which I think represent IP/MPLS nodes) in your slides are included in SRv6 architecture or not.

I put some text what those icons indicate. Please find them in the slides. The blue icons represent IPv6 or SRv6 node.

Cheers,
--satoru

---

From: Satoru Matsushima <[email-masked]>
Date: Fri, 9 Feb 2018 17:36:04 +0900

Kalyani,

> [KB] CUPS does not support branching point function as in 5G. 

Noted. It may need to be elaborated.

Cheers,
--satoru

---

From: Satoru Matsushima <[email-masked]>
Date: Fri, 9 Feb 2018 17:53:17 +0900

Kalyani,
# Subject changed.

> [KB] I think these are non-mobility functions as being discussed on the email thread with Marco Liebsch.

I saw that discussion. Non-mobility functions of which deployed on SGi/Gi-LAN types can still be considered as functions deployed in N6.
IMO I couldn’t find that assumption in TS23.501. So it would be a clarification point whether those type of UP functions can be deployed within mobility management data path programmed by SMF utilizing (multiple) N9.

Thought?

Cheers,
--satoru

---

From: Satoru Matsushima <[email-masked]>
Date: Fri, 9 Feb 2018 18:23:53 +0900

Hello Uma,

> [Uma]: I presume this is on N6 interface once de-capsulation is done at eventual UPF.  So can I say this is one more alternative to NSH ??

SRv6 can be a SFP in terms of SFC architecture. SRH is able to bring NSH in a TLV. See https://tools.ietf.org/html/draft-ietf-6man-segment-routing-header-08#section-3.1.6

>                Do you see any relevance of this in any other interface?

I’ve moved it to another thread. I’d like to discuss it in that thread.

> [Uma]: Didn't quite understand. Are you referring southbound interface like PCEP here?

It looks same question from Behcet. Let me think just an example, if a SMF sees an IPv6 address as an UPF address, is actually an IPv6 segment ID of a TE path through several IPv6 routers and links, a southbound could be PCEP but not limited. BGP-LS should work to disseminate that segment and FPC may work to disclose it to the SMF and the TE path would be attached mobility sessions by the SMF as if it is an UPF. 

Cheers,
--satoru

---

From: "Bogineni, Kalyani" <[email-masked]>
Date: Fri, 9 Feb 2018 13:27:47 +0000

Satoru:

Comments inline.

-----Original Message-----
From: Satoru Matsushima [mailto:[email-masked]] 
Sent: Friday, February 9, 2018 3:25 AM
To: Bogineni, Kalyani <[email-masked]>
Cc: [email-masked]; dmm <[email-masked]>
Subject: Re: [Ila] [E] Re: review comments on ] draft-ietf-dmm-srv6-mobile-uplane-00.txt

Hello Kalyani,

> [KB] is there a TR for ETSUN that I can read?

You can read it later on this September. See https://urldefense.proofpoint.com/v2/url?u=https-3A__portal.3gpp.org_ngppapp_CreateTdoc.aspx-3Fmode-3Dview-26contributionUid-3DSP-2D170743&d=DwIFaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=A4gJxIMQxDhuwbITGRX_eHAfWF36yy799w_bFx5TDFc&s=ZNR28OMiy-m_kDk3BNz7y8KuA-bfdBBr2HeRt8WQl5c&e
[KB] Thank you

[KB] Sections 7.2, 7.3 refer to 3GPP terminology like eNB, SGW, PGW. My comment was suggesting that you include 5G terminology and CUPS terminology 
as well so it is clear how your proposal can be used in various scenarios.

I put some text what those icons indicate. Please find them in the slides. The blue icons represent IPv6 or SRv6 node.
[KB] Seems like the IPv6/SRv6 nodes do not interact with SMF. Is that the intent? 

Cheers,
--satoru

---

From: "Bogineni, Kalyani" <[email-masked]>
Date: Fri, 9 Feb 2018 14:49:59 +0000

Response inline.

-----Original Message-----
From: ila [mailto:[email-masked]] On Behalf Of Satoru Matsushima
Sent: Friday, February 9, 2018 3:53 AM
To: Bogineni, Kalyani <[email-masked]>
Cc: [email-masked]; dmm <[email-masked]>
Subject: [E] [Ila] Non-mobility functions in Uplane [was Re: review comments on ] draft-ietf-dmm-srv6-mobile-uplane-00.txt]

Kalyani,
# Subject changed.

Thought?
[KB] My colleague in SA2 pointed me to section 5.8 in 23.501. 

Cheers,
--satoru
_______________________________________________
ila mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ila&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=Lfncf6GKwV3VXzMDab1Zrt4pS5e7aPPp71q5GG4KJoA&s=-oaS94clL2rlhMkX3t5-vZnam6do2O_1QFL8qMP4u0g&e=

---

From: Uma Chunduri <[email-masked]>
Date: Fri, 9 Feb 2018 20:16:07 +0000

>Let me think just an example, if a SMF sees an IPv6 address as an UPF address, is actually an IPv6 segment ID of a TE path through several IPv6 routers and links, a southbound could be PCEP but not limited. 
                >BGP-LS should work to disseminate that segment and FPC may work to disclose it to the SMF and the TE path would be attached mobility sessions by the SMF as if it is an UPF. 

Thx. 
I see what you are saying; this is after N3 termination and full charging, LI and bit rate enforcement is done and to move the packet on the provided TE path to the UPF on N9. 
My original question was more on SFC functionalities that ought to be done on N6 (I know the draft you pointed https://tools.ietf.org/html/draft-xuclad-spring-sr-service-chaining-00 and I still see that as alternative to NSH) and any of these have to be done on N9. The only thing I see is TE on N9.
I think, there is no bearing on SMF for Gi LAN stuff on N6.

--
Uma C.

---

From: Satoru Matsushima <[email-masked]>
Date: Tue, 13 Feb 2018 10:38:02 +0900

Hello Kalyani,

> as well so it is clear how your proposal can be used in various scenarios.

Now I’ve got your point. Thank you.

> [KB] Seems like the IPv6/SRv6 nodes do not interact with SMF. Is that the intent? 

IPv6/SRv6 nodes interact with SMF but it’s indirect, is my idea.

Cheers,
--satoru