Subject: [EAI] Preliminary copy of the post-Last Call EAI framework draft posted

From: Harald Tveit Alvestrand <[email-masked]>
Date: Fri, 02 Feb 2007 15:37:37 -0800

A copy of the updated EAI framework draft, updated to address Last Call 
comments, is available at:

http://www.alvestrand.no/ietf/eai/eai-framework-05b.txt

If people have any comments on the way issues raised at Last Call were 
resolved, please raise them now - and preferably before 10 AM US ET Monday, 
February 5 (7AM US PT, 3PM GMT).

              Harald

_______________________________________________
IMA mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ima

---

From: Frank Ellermann <[email-masked]>
Date: Sat, 03 Feb 2007 04:31:07 +0100

> http://www.alvestrand.no/ietf/eai/eai-framework-05b.txt

Hwdiff at <http://tinyurl.com/yudqse> - I think it's okay.
Does the following statement still make sense ?

| There is no such thing as an "i18mail message"; the term
| applies only to users and their agents and capabilities.

I-D.eai-dsn-00 now defines message/utf-8, and minus "TBD"
details it's a major step forward in a promising direction.

The paragraph ending with "there is no such thing" also makes
sense without this statement about a "i18mail message".

Frank

---

From: John C Klensin <[email-masked]>
Date: Sat, 03 Feb 2007 00:30:06 -0500

--On Friday, 02 February, 2007 15:37 -0800 Harald Tveit
Alvestrand <[email-masked]> wrote:

> A copy of the updated EAI framework draft, updated to address
> Last Call comments, is available at:
> 
> If people have any comments on the way issues raised at Last
> Call were resolved, please raise them now - and preferably
> before 10 AM US ET Monday, February 5 (7AM US PT, 3PM GMT).

Preferably before 8 AM US ET Monday.   By 10 (and probably by
8:15), it will be in the posting queue.    I've promised Ted
Hardie, the relevant AD, that this would be posted Monday
afternoon.  For that to happen, it needs to be in-queue before
they  start processing the things Monday morning.   

Anything that might require discussion or thought should be
posted enough in advance of that cutoff to make such discussion
possible.

Sorry about the constrained schedule on this, but it is
necessary if the thing is going to be signed off before
mid-March (or later).

Also, please do not even bother to send notes that quibble about
presentation.  If I have made stupid typographical errors or the
equivalent, please tell me.  If I have missed, or seriously
misinterpreted or mis-implemented, a Last Call comment, I
certainly want to know about that.  But, for anything along the
lines of minor wording changes or reopening old issues --
especially involving text that was not changed after -04 -- it
is just too late: the odds of my making errors in trying to
apply proposed fixes are unacceptably high.
   
      john

---

From: "Charles Lindsey" <[email-masked]>
Date: Mon, 05 Feb 2007 16:44:01 -0000

> sense without this statement about a "i18mail message".

I also spotted this paragraph when chasing something else, and I observe  
that we carefully define all the possibilities for addresses (ASCII,  
NON-ASCII and UTF8SMTP), but we do not seem to have defined any  
terminology for describing messages as such (apart from that sentence  
saying "there is no such thing").

And yet we are currently involved in heavy discussions about how messages  
of varuious sorts might or might not be handled. It seems to be the case  
that the same three types of message exist (ASCII, NON-ASCII and UTF8SMTP,  
where those terms apply to the '8bitiness' of headers, not bodies, at any  
level). Note that a message can still be Non-ASCII even if there if every  
address in it and in its envelope is pure ASCII.

This strikes me as a notable omission.

-- 
Charles H. Lindsey ---------At Home, doing my own thing------------------------
Tel: +44 161 436 6131                       
   Web: http://www.cs.man.ac.uk/~chl
Email: [email-masked]      Snail: 5 Clerewood Ave, CHEADLE, SK8 3JU, U.K.
PGP: 2C15F1A9      Fingerprint: 73 6D C2 51 93 A0 01 E7 65 E8 64 7E 14 A4 AB A5

---

From: John C Klensin <[email-masked]>
Date: Mon, 05 Feb 2007 11:58:21 -0500

FWIW, the document went into the posting queue at 0805 US ET/
1305 UT this morning, as promised/threatened.    As I tried to
indicate in my earlier note, the constraints on post-LC changes
and the time pressure on getting this out made it impossible to
make substantive changes not identified and resolved during Last
Call.  That constraint applies especially to situations, like
this one, in which the comment is "something additional needs to
be done" (in this case, adding a definition) but in which there
was not time to develop a proposal and get WG consensus on it.

     john

--On Monday, 05 February, 2007 16:44 +0000 Charles Lindsey
<[email-masked]> wrote:

>...
> I also spotted this paragraph when chasing something else, and
> I observe that we carefully define all the possibilities for
> addresses (ASCII, NON-ASCII and UTF8SMTP), but we do not seem
> to have defined any terminology for describing messages as
> such (apart from that sentence saying "there is no such
> thing").
> 
> And yet we are currently involved in heavy discussions about
> how messages of varuious sorts might or might not be handled.
> It seems to be the case that the same three types of message
>...