Subject: [EAI] DRAFT agenda, EAI WG

From: Harald Alvestrand <[email-masked]>
Date: Fri, 09 Mar 2007 14:31:17 +0100

Due to the agenda deadline, this is already filed with the secretariat.
But feel free to send suggestions for updates - the earlier we can bash 
the agenda, the better!

              Harald

Date: TUESDAY, March 20, 2007
Time: 1520-1720 Afternoon Session II
Place: Athens/Barcelona/Berlin room

1520: Welcome, scribe selection, agenda bashing
1530: Framework - review of IESG-response changes
1540: SMTP extension
  Issues:
  - Clarify need to not send UTF8 messages to non-UTF8SMTP hosts
  Draft: draft-ietf-eai-smtpext-04

1555: UTF8Headers
  Issues:
  Draft: draft-ietf-eai-utf8headers-03

1610: DSN
  Issues:
  - xtext encoding and utf8-enc encoding of addresses
  - application/utf8smtp vs message/utf8smtp
  Draft: draft-ietf-eai-dsn-00

1620: Downgrade
  Issues:
  Draft: draft-ietf-eai-downgrade-03 (not yet published)

1635: IMAP
  Issues:
  Draft: draft-ietf-eai-imap-utf8-01

1645: POP
  Issues:
  Draft: draft-ietf-eai-pop-01

1655: Mailinglist
  Issues:
  Draft: draft-ietf-eai-mailinglist-01

1710: Any Other Business
  draft-ietf-eai-scenarios: publish, or hold until end?

_______________________________________________
IMA mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ima

---

From: Frank Ellermann <[email-masked]>
Date: Fri, 09 Mar 2007 16:00:25 +0100

Harald Alvestrand wrote:

> feel free to send suggestions for updates

Are the times UTC ?

> the earlier we can bash the agenda, the better!

>   Draft: draft-ietf-eai-dsn-00

That's rather short for message/utf8.  Ideally you get
hold of John's "MIME experts", and let them explain how
the introduction of a new message/utf8 superset of the
known message/rfc822 affects the MIME 1.0 architecture
for 8bit and 7bit.

That includes message/rfc822 parts in a message/utf8,
message/utf8 parts in a message/rfc822, and as contrast
message/foo parts in a message/utf8 or message/rfc822.

Each case as pure 7bit, pure 8bit, 7bit within 8bit,
and the impossibilty of 8bit within 7bit - that case
might be what you mean with an "application/utf8smtp".

[[ I think it should also cover how to encapsulate
   8bit message/foo parts by a "8to7" gateway, IMO a
   message/utf8 is a special case of message/foo wrt
   8BITMIME to 7bit gateways. ]]

Some here apparently hope to introduce UTF-8 in MIME
header fields and MIME part headers.  Ask the experts
if that would require a MIME version 2.0 (as I think).

10 minutes, maybe five for the xtext encoding, with
only five minutes you can't discuss this.  And please
give the invited (?) MIME experts some time to prepare
for these issues.

Frank

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Sun, 11 Mar 2007 11:42:03 +0100

Thanks for the feedback, Frank. I've added the issue of "message/utf8" 
under "issues" on this agenda point.

What would you suggest that we allocate as a timeslot, and what would you 
suggest we take time away from?

---

From: Frank Ellermann <[email-masked]>
Date: Sun, 11 Mar 2007 14:45:32 +0100

Harald Tveit Alvestrand wrote:
 
 [message/utf8 and MIME 1.0} 
> What would you suggest that we allocate as a timeslot

Depends on the MIME experts, if nobody is interested to
go to the EAI meeting and explain how MIME is supposed
to work you'd need no timeslot for this issue...

> what would you suggest we take time away from?

...hard to tell, picking the POP draft as example, it's
straight forward.  Maybe add the common windows-12xx 
versions like windows-1252 to the corresponding Latin
versions in chapter 5 by name.  It discusses UTF-8 in 
Content-*, that depends on the MIME version question:

Is UTF-8 possible in MIME version 1.0 header fields ?

I'm "sure" it's not.  But I was also "sure" that 2231
can't be version 1.0 because it implicitly introduced
a "no parameter name can be used more than once" rule
not explicitly stated in 2045..2049.

So maybe the POP3 draft doesn't need ten minutes.  Now
I could go through the other drafts like mailing-list
- oops, this I-D apparently needs a "2368ter" mailto -
trying to find other "too long" timeslots, but that's
odd.  

At the moment I'm mainly interested in the SMTP, DSN,
downgrade, and utf8header I-Ds.  Anything else will 
build on the core specifications when they are ready.

As long as the core I-Ds don't introduce showstoppers
for IMAP / POP / mailing list maybe these points could
be reduced to a "cando ?", and would need less time if
the authors signal "yes (so far)".  If they'd say "no"
(the mailto business in the mailing list I-D makes me
nervous, did the 2368bis authors check this I-D ?) you 
could regroup the issues by priority, and then see how
far you come in only two hours.

Frank