Subject: Re: [EAI] Downgrade testing - Results

From: Ernie Dainow <[email-masked]>
Date: Thu, 09 Jul 2009 09:09:52 -0400

These echo tests were a good suggestion. I ran a base test from an ASCII 
address against all echo servers in the list. All responded except 
[email-masked]. Email bounced with "unknown address", so I  eliminated 
that server from the test, leaving a total of 9 echo servers.

The success rate for receiving a response from echo servers:
1) From ASCII, no downgrade      9/9      100%
2) From EAI, downgrade               7/9        78%

[email-masked] provided some SpamAssassin analysis:
1) BODY: Bayesian spam probability is 1 to 5%
2) BODY: Bayesian spam probability is 5 to 20%

For the downgrade test sent to individual participants the results were:
Total Sent    11   (all on different email domains)
Received       9    82%
Blocked        2    18%

These are not large samples, but it is interesting to see that the 
success rate in both tests were similar, and were in the SpamAssassin 
range of 20% probability of spam.

I encourage other implementers to run the same set of tests so we can 
get a larger sample and see if there are differences between Downgrade 
implementations.

    -Ernie

Stephane Bortzmeyer wrote:
> On Mon, Jun 22, 2009 at 11:19:48AM -0400,
>  Ernie Dainow <[email-masked]> wrote 
>  a message of 41 lines which said:
>
>   
>> The Downgrade test reported on the wiki basically tested against gmail.  
>> It would be valuable to do more testing 'in the wild' to see how  
>> Downgrade traverses various email systems in other organizations.
>>     
>
> You can test against various auto-responders which send you back your
> message (if you know other email addresses of auto-responders, do not
> hesitate to publish them).
>
> * [email-masked] 
> * [email-masked] 
> * [email-masked] 
> * [email-masked] 
> * [email-masked] 
> * [email-masked]
> * [email-masked]
> * [email-masked] 
> * [email-masked]
> * [email-masked]
>

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Thu, 9 Jul 2009 15:44:52 +0200

On Sat, Jun 27, 2009 at 09:56:35PM +0200,
 Stephane Bortzmeyer <[email-masked]> wrote 

> hesitate to publish them).

By the way, does anyone know a RFC 5336 auto-responder, one which does
not require downgrade?