Subject: [EAI] Fw: I-D Action:draft-yao-eai-deployment-02.txt

From: "YAO Jiankang" <[email-masked]>
Date: Thu, 9 Jul 2009 14:49:33 +0800

Dear all,

       updated to version 2.

   o  rename the section "Sending Server" to "SMTP client"
   o  rename the section "Recieve Server" to "SMTP server"
   o  add the new section "Internationalized email domain"
   o  move and refine the section "Firewall"
   o  update and refine the texts of this document

 thanks a lot to S.  Moonesamy for his kind comments to last version.

 Yao Jiankang
CNNIC

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>
Sent: Thursday, July 09, 2009 2:45 PM
Subject: I-D Action:draft-yao-eai-deployment-02.txt 

>A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> Title           : EAI Deployment Practices
> Author(s)       : J. Yao, X. Lee
> Filename        : draft-yao-eai-deployment-02.txt
> Pages           : 12
> Date            : 2009-07-08
> 
> This document captures experience in implementing systems based on
> the EAI protocols.  Some depolyment issues will be discussed here,
> which are not proper for being discussed in the core EAI protocol
> documents.  Its aim is to help the engineers to implement these
> protocols.  This document gives some suggestions about implementaions
> and reports on the prototype implementation and the interoperability
> test results, as well as the lessons and insights gained from this
> test.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-yao-eai-deployment-02.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>

--------------------------------------------------------------------------------

> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: John C Klensin <[email-masked]>
Date: Thu, 09 Jul 2009 09:13:24 -0400

>  thanks a lot to S.  Moonesamy for his kind comments to last

I have skimmed quickly through this version and find two main
issues.  There are also some less significant ones, but, until
the main ones are addressed, I don't think the others are
important.

(1) You indicate that the people you asked, or included in the
tests, want internationalized addresses.  I assume that is true,
but you cannot claim the experiments you have performed as proof
of it unless you describe the population you have sampled,
describe who they were trying to communicate with and how well
they understand the negative aspects of mixed environments, and
so on.

To state this more usefully, I think we all believe that
non-ASCII email addresses are useful and important despite some
disadvantages (otherwise we wouldn't be spending time on this).
At least most of us believe that they are going to be a lot more
useful in homogeneous environments (e.g., a Chinese user
communicating with another Chinese user) than in heterogeneous
ones (e.g., a Chinese user communicating with an Arabic user).
While the protocols may work equally well in both cases, the
opportunities for confusion, phishing, and various bad practices
will be much greater in practice in the heterogeneous ones than
in the homogeneous ones.

Whether we have downgrading or not, whether all systems have
been upgraded to EAI or not, I think we also understand that EAI
is going to lead to an increase in undeliverable mail -- that is
just the nature of alternate representation forms in Unicode--
although Chinese characters used to write Putonghua may be less
affected by these problems than scripts that utilize combining
characters, decorations that may be considered optional, or many
compatibility characters ... or languages for which standardized
orthographies either do not exist or are not widely accepted.

My own guess is that, if a user of one language (and script)
wants to communicate with a user of a very different language,
they will be better off using ASCII addresses for many years in
the future.  Only in the homogeneous cases will there be
reasonable odds of all of the facilities that are not part of
the protocols but that are required for a user perception that
i18mail really works (e.g., font availability, keyboard
compatibility, and ability by the user to conveniently read and
write the relevant language).  Whether you agree or disagree
with that, this document should, IMO, at least discuss the
issues.

Again speaking personally, I will consider i18nemail to be a
huge success if it merely enables better communication within
language communities.  Any enhancements to communication between
such communities would be wonderful, but are not critical to
success and may not even be especially important (you should be
able to deduce my reasoning from the comments above).   Let's
not try to lead the community into disappointment by setting
expectations higher than necessary and appropriate.

(2) Ernie's tests seem to show a rather different picture of
consistent and interoperable behavior, especially where
downgrading is involved, than I would deduce from the very
optimistic Section 10 of this document.  I think this document
needs to be accurate and portray the bad news as well as the
good news.  Without that, it will be impossible for people to
properly evaluate the EAI and make plans without having nasty
surprises.  It would be ok from my standpoint if you described
the bad situations and then explained what was necessary to
avoid them, but something should be said.  In particular, if the
only way to avoid bad effects is for everyone who wants to deal
with i18nemail at all to fully implement the EAI specs, then
that is very important information for us all to have.  I
encourage you to collaborate with Ernie in this area if at all
possible.

regards,
   john

---

From: "YAO Jiankang" <[email-masked]>
Date: Fri, 10 Jul 2009 11:19:09 +0800

Dear John,

    thanks a lot for your kind comments.
   after reading your comments, we may divide this draft into 2 drafts. the first draft is about EAI deployment guideline. 
We can change this current draft's name from "EAI Deployment Practices" to "EAI Deployment guideline".

we can move the section 10 about "EAI tests" to the second draft. we may name this draft with "EAI evaluation and tests "
In this new draft, we can mainly discuss the 2 issues you mentioned and  collaborate with Ernie about the issue of EAI test.

more comments are below.

thanks a lot.

YAO Jiankang
CNNIC

----- Original Message ----- 
From: "John C Klensin" <[email-masked]>
To: "YAO Jiankang" <[email-masked]>; "EAI WG" <[email-masked]>
Sent: Thursday, July 09, 2009 9:13 PM
Subject: Re: [EAI] Fw: I-D Action:draft-yao-eai-deployment-02.txt

> they understand the negative aspects of mixed environments, and

CNNIC publish Chinese internet users survey every year.
 I will suggest them do this kind survey in the near future.

> ones (e.g., a Chinese user communicating with an Arabic user).

according to our simple survey, many users want internationalized addresses to communicate with both chinese and foreigner.
so Ascii address as the alias of internationalized addresse may be a solution. This situation is similar to the situation below:
My name card have both sides, one side with english version is for the foreigner to read; the other side side with chinese version is for chinese to read.
Both sides say the same thing. English version of name card is the translation of Chinese version; Chinese version of name card is the translation of English version.
so the ascii email address (English version) is for foreigner; the chinese email address (chinese version) is for chinese. both email addresses refer to the same email store.  It is unlikely that Chinese user will present a name card only with chinese version to Arabic users or American users. similarly, It is unlikely that Chinese email user will present the email address only with chinese version to Arabic email users or American email users. so from this view, the two version email address may coexist in the longrun.

> will be much greater in practice in the heterogeneous ones than

the WG already solve the problme in the protocol level. some implementation issues need more discussions.

> is going to lead to an increase in undeliverable mail 

if the reason is due to unicode,  the problem is simialr to the problem IDNAbis encounters.

>-- that is
> the future.  

+1

>Only in the homogeneous cases will there be

I think that we can discuss the issues in the draft "EAI evaluation and tests "
> expectations higher than necessary and appropriate.

market demands will promote the EAI.

> encourage you to collaborate with Ernie in this area if at all
I think that we can discuss the issues in the draft "EAI evaluation and tests " and collaborate with Ernie.

thanks a lot.