Subject: Re: [EAI] Rechartering for Standards Track

From: Shawn Steele <[email-masked]>
Date: Thu, 14 Jan 2010 20:33:06 +0000

Message: 1
Date: Thu, 14 Jan 2010 10:25:54 +0800
> From: "YAO Jiankang" <[email-masked]>
>> I?d like the WG to recharter for standards track ASAP. 

> I hope it too.
:) Rechartering has been brought up a few times, but keeps getting dropped :(

> I like some ideas in your following proposed recharter draft.
Thanks :)

>> It?s hard for me to get my company to invest in this area when there aren?t any standards L
>Understood.
:)
 
>> Downgrading has been tricky, so the updated RFCs should be
>> revised to allow for, but not depend upon, a future downgrade
>> standard.  Retransmission by legacy protocols should still be permitted. 

>more work is necessary to downgrade before moving to next step.

Very much agree.  I was trying to suggest that while moving the agreed to standards track, that we also can continue to work on experiments.  I also wanted to leave open the possibility of standardizing downgrade IF (really big if) we managed to find the perfect solution.  I'm not set on that though, it'd be OK if we left any downgrade work as experimental and had to recharter again if we find a great downgrade solution.

- Shawn

---

From: Joseph Yee <[email-masked]>
Date: Thu, 21 Jan 2010 15:15:40 -0500

> :) Rechartering has been brought up a few times, but keeps getting  

I'm eager to have recharter started too, and hoping to get the current  
experimental round complete as soon as possible.  And mailing-list is  
in last call now, I believed that this is the last doc.

> Very much agree.  I was trying to suggest that while moving the  
> agreed to standards track, that we also can continue to work on  
> experiments.  I also wanted to leave open the possibility of  
> standardizing downgrade IF (really big if) we managed to find the  
> perfect solution.  I'm not set on that though, it'd be OK if we left  
> any downgrade work as experimental and had to recharter again if we  
> find a great downgrade solution.

I'm concern that the lack of downgrade, or mechanism to bridge UTF8  
mail & ASCII mail exchange, would make the standard less effective,  
IMHO, but I don't think it's a bad idea either.

Retransmission sounds like one form of downgrade to me.  You wait for  
the bounce, then re-send with different address.  Do I interpret it  
right?

Thanks
Joseph

>
> - Shawn
> _______________________________________________
> IMA mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ima

---

From: Shawn Steele <[email-masked]>
Date: Thu, 21 Jan 2010 22:24:47 +0000

> I'm concern that the lack of downgrade, or mechanism to bridge
> UTF8 mail & ASCII mail exchange, would make the standard less
> effective, IMHO, but I don't think it's a bad idea either.

Possibly, but I'm wary of further delay.  Worst case, if we got EAI support w/o downgrade, then we'd at least have a test bed to play with downgrade scenarios.

> Retransmission sounds like one form of downgrade to me. 
> You wait for the bounce, then re-send with different address.  
> Do I interpret it right?
 
I tried to separate the idea of retransmission from downgrade.  Retransmission doesn't really require any technology behind it.  I send a mail to you, and it bounces.  Then I pick up the phone & call you and ask for an ASCII address, and I press resend or forward the bounced mail or whatever.  It could maybe be automatic if my mail client happens to know the ASCII address already, but that's a minor detail.

OTOH I think of downgrade as being something the machine does.  It also has to be very reliable (100% IMO), otherwise I can't tell if the mail will work or not.  If I'm lucky it'll bounce, but in some forms of partial downgrade I may be able to send a mail you can't reply to.  If that happens then there's no feedback that it broke :(.  99% is almost worse than 0% because at least with 0% downgrade I know what to expect and how to deal with it, but with 99% I expect it to work, and the 1% that misses may be difficult to discover or very hard for me to handle.

Anyway, I don't want downgrade to delay any standards track rechartering.  If necessary we could even have 2 efforts, 1 for finishing the standards track items and one for more experimenting with downgrade.

-Shawn