Subject: Re: [EAI] draft of the new charter for EAI WG

From: Shawn Steele <[email-masked]>
Date: Thu, 28 Jan 2010 00:03:11 +0000

> LMTP is now standard track (RFC 3848).  We should cover this in EAI as  
> well.  It could be RFC by itself (UTF-8 LMTP) or expand the RFC of   
> UTF8SMTP extension to cover it.

I agree that it seems like just saying "UTF8SMTP can be used with LMTP" should be enough, however if we somehow started nitpicking it to death I'd prefer to just drop it or stick it someplace else rather than delaying UTF8SMTP.

> I think an advise/guideline like for email address (local part) naming  
> would help.  Would be nice to have list of restricted characters  
> documented, and may include suggestion of some normalization,  
> especially on symbol character plus and dot.  This should be an info  
> RFC.

I think that would be good.  I think that:

> * Advice for non-ASCII and ASCII addresses for the same mailbox (Info)

could be a bit broader to cover this and my earlier suggestions about aliases.  Eg:

* Advice for address(es) for use with EAI (Info)

And try to provide broader guidance on address choice, multiple addresses, normalization, mapping, choosing useful characters, etc.  (Not necessarily saying to use a specific mapping, but rather how to choose what mapping(s) might be interesting to you)  I wouldn't go so far as to replace UTR#36 (security of Unicode), because UTR36 already covers that, but there are many interesting things about local parts that administrators need to think about.

-Shawn

SSDE
Windows UX
Microsoft

---

From: Joseph Yee <[email-masked]>
Date: Thu, 28 Jan 2010 08:28:41 -0500

On 27-Jan-10, at 7:03 PM, Shawn Steele wrote:

> I agree that it seems like just saying "UTF8SMTP can be used with  
> LMTP" should be enough, however if we somehow started nitpicking it  
> to death I'd prefer to just drop it or stick it someplace else  
> rather than delaying UTF8SMTP.

I doubted that we will go beyond "UTF8SMTP can be used with LMTP".

> And try to provide broader guidance on address choice, multiple  
> addresses, normalization, mapping, choosing useful characters, etc.   
> (Not necessarily saying to use a specific mapping, but rather how to  
> choose what mapping(s) might be interesting to you)  I wouldn't go  
> so far as to replace UTR#36 (security of Unicode), because UTR36  
> already covers that, but there are many interesting things about  
> local parts that administrators need to think about.

Let's focus on what issues the whole WG like to cover that are  
considered informational, rather than deciding if topic A and B should  
be in the same RFC or not.  What 'administrators need to think about'  
may overlap with deployment info.

Joseph

>
> -Shawn
>
> SSDE
> Windows UX
> Microsoft
>
> _______________________________________________
> IMA mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ima

---

From: Shawn Steele <[email-masked]>
Date: Thu, 28 Jan 2010 18:51:31 +0000

> considered informational, rather than deciding if topic A and B 
> should be in the same RFC or not.  

That makes sense :)