Subject: [EAI] Random thought #1 - UTF8SMTP handshaking

From: Shawn Steele <[email-masked]>
Date: Wed, 7 Jul 2010 19:27:45 +0000

I don’t want to derail our time frame, but I was wondering if this was worth considering:

Currently the UTF8SMTP(bis) extension is a one-way handshaking.  Eg: the client knows the server understands UTF8SMTP, however there’s no way for the server to generally know if the client can accept UTF-8.  That leads us to things like “UTF8REPLY”.  Additionally, it is not necessarily guaranteed that a MAIL or RCPT command is UTF-8 just because it’s non ASCII (a misbehaving client could be using their local 8-bit code page or something).  It’s also not guaranteed that DATA be UTF-8 (I think historically data has sometimes used local code pages, though now it’s probably more likely to be correctly tagged).

To me, stamping “UTF8xxxx” on every command seems pretty awkward.  Should we consider a “UTF8” command that a client can use to confirm that it handles UTF-8?  Then the handshaking doesn’t have to happen with every command?  Eg:

UTF8
250 Ok
MAIL FROM:<[email-masked]>
250 Ok
…
DATA
… utf8 data …
.

As mentioned, I don’t want to cause a lot of delay discussing this, but is it worth considering?  Would it be too much churn?

-Shawn

 
http://blogs.msdn.com/shawnste

---

From: Joseph Yee <[email-masked]>
Date: Wed, 7 Jul 2010 15:59:34 -0400

Hi Shawn,

Most commands sent from server to client are purely status responses in pure ASCII, so it's almost not necessary.  Except 2 commands, which were documented in RFC 5336 bis, and had suggested to use keyword like UTF8REPLY to indicate its capability to accept response with UTF8 content.

And as you mentioned too, I think it's not time for status response coming back in non-ASCII form now :)

best
Joseph

On 2010-07-07, at 3:27 PM, Shawn Steele wrote:

> _______________________________________________
> IMA mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ima

---

From: Shawn Steele <[email-masked]>
Date: Wed, 7 Jul 2010 20:12:41 +0000

But, I think, that the server doesn't know "for sure" that FROM, RCPT and DATA are also UTF-8.  (It can "guess", since they'll have data > 0x7f, however can it be sure?)

Not a big deal, only weird behaving, probably older stuff would act up, but ?

-Shawn

-----Original Message-----
From: Joseph Yee [mailto:[email-masked]] 
Sent: Wednesday, July 07, 2010 1:00 PM
To: Shawn Steele
Cc: [email-masked]
Subject: Re: [EAI] Random thought #1 - UTF8SMTP handshaking

Hi Shawn,

best
Joseph