Subject: Re: [EAI] mail bounce versus punycode conversion

From: Shawn Steele <[email-masked]>
Date: Tue, 13 Jul 2010 02:01:09 +0000

In practice would a present-day server echo the non-ASCII part in the error?  (I'm unfamiliar with what normally happens here).

Seems like a reasonable, and probably important, example, but there're lots of combinations possible.  ("non-ASCII DISPLAY_NAME" <ASCII@ASCII>, etc.)

-Shawn

------------------------------

Message: 5
Date: Mon, 12 Jul 2010 17:17:16 -0400
From: Ernie Dainow <[email-masked]>
Subject: [EAI] mail bounce versus punycode conversion
To: [email-masked]
Message-ID: <[email-masked]>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

A message to mailbox <ASCII@non-ASCII> will bounce if the UTF8SMTPbis extension is not supported by an MTA. According to rfc5336bis, this will not be done by an MTA. This is not obvious behavior, since it is fairly trivial to do a punycode conversion of the domain part so that the address is all ASCII. Many users are familiar with web browsers that do this conversion and may expect similar behavior in email.

To reinforce that this is a failure case, we should add the following example to section 4.4 of rfc5335bis-00.

    <ASCII@non-ASCII>
         ; message will bounce if UTF8SMTPbis extension is not supported. An MTA will not convert
         ; the domain part to ASCII, but this may be done by an MUA or submission server (MSA).

-Ernie

---

From: John C Klensin <[email-masked]>
Date: Tue, 13 Jul 2010 13:16:56 -0400

--On Tuesday, July 13, 2010 02:01 +0000 Shawn Steele
<[email-masked]> wrote:

> In practice would a present-day server echo the non-ASCII part
> in the error?  (I'm unfamiliar with what normally happens
> here).

While there are exceptions, most present-day servers use fixed
text in response messages whenever possible, rather than
"echoing" anything, ASCII or not.  The principle is that one
should be able to build localized translations of the response
messages based on reply codes only and ignoring (rather than
trying to parse and translate) the text.  The main exceptions
are VRFY and EXPN where they are supported.

     john