Subject: Re: [EAI] ulabel

From: Shawn Steele <[email-masked]>
Date: Wed, 14 Jul 2010 18:59:11 +0000

Whatever you think's best.  I can't get very excited about nomenclature :), I just have the one minor concern about what ulabel means to me, but I can't even get very worked up about that :)

I have a very mild preference for utf-8 in contexts where UTF-8 is interesting.  (Internally, I expect most windows apps to store email addresses in UTF-16 WCHARS as that's what our native data/string types are, so u* as in "Unicode" could still be vague in some contexts.  Utf8* would be very clear that UTF-8 is expected and not some other form of Unicode).  IDNA didn't care about the encoding of the Unicode, so U-Label works for it.

That said, I reiterate that I've said way more words on this topic than I really have the passion for, whatever's easy for the authors is fine with me.  I mildly agree that consistency between docs would be nice, but I can't even get worked up about that either.

-Shawn

----- Original Message -----
From: "Shawn Steele" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, July 14, 2010 5:58 AM
Subject: Re: [EAI] ulabel

>> the user may confuse the old label and new label.
>> but label and uLabel is easy to de differented.
> 
> Ulabel makes me wary because its use in IDN presumes there's an alabel.  So the connotations make me uneasy (whether that's reasonable or not).
Ulabel was prevented before idna2008 defined a u-label and a-label.
ulabel may be similar to u-labe.

but we will not confuse Umailbox with u-label.

so I think that we still keep Umailbox, Ucharacter, Uatom......

the  general name of all the labels including   Umailbox, Ucharacter and Uatom may be utf-8label.

> 
> So I'd prefer utf8-label:)
> 
> -Shawn
> _______________________________________________
> IMA mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ima

---

From: Ernie Dainow <[email-masked]>
Date: Wed, 14 Jul 2010 17:43:37 -0400

> That said, I reiterate that I've said way more words on this topic than I really have the passion for, whatever's easy for the authors is fine with me.  I mildly agree that consistency between docs…

Consistency is important to support best software engineering practices. 
If there is inconsistency between documents and different definitions 
that are in fact equivalent, you are increasing the probability of 
interoperability failures. One implementer might conclude that the 
different definitions are equivalent and use common code; another 
implementer might follow the letter of the spec and write separate code 
for each set of equivalent functions. In the first case you are 
increasing the chance of error through misinterpretation of what is 
equivalent. In the second case you are increasing the chance of error 
through doubling the amount of code that needs to be written and tested.

For example, in rfc5335bis-00 we have
     mailbox      =  name-addr / addr-spec / utf8-addr-spec
     utf8-atom   = [CFWS] 1*utf8-atext [CFWS]

while in rfc5336bis-00 we have these definitions
      uMailbox  = uLocal-part "@" uDomain
      uAtom      = 1*ucharacter

Mailbox is certainly the same in both contexts. I don't know if the 
definition of atom needs to be different or not.

One common set of ABNF across documents should be a goal of subsequent 
drafts. For example put them all in rfc5335bis-00 and refer back to that 
document where necessary. If different definitions are necessary for 
different documents, they should have names that are more distinctly 
different than utf8-atom and uAtom.

-Ernie

> From: "Shawn Steele"<[email-masked]>
> To:<[email-masked]>

---

From: "Jiankang YAO" <[email-masked]>
Date: Fri, 16 Jul 2010 11:02:35 +0800

----- Original Message ----- 
From: "Ernie Dainow" <[email-masked]>
To: "YAO Jiankang" <[email-masked]>; "Shawn Steele" <[email-masked]>; <[email-masked]>
Sent: Thursday, July 15, 2010 5:43 AM
Subject: Re: [EAI] ulabel

> Consistency is important to support best software engineering practices. 

yes.

so Shawn, and Abel, will we keep utf-8mailbox or umailbox?
in next version, we may make it to be same in our drafts.

Jiankang  Yao

---

From: "Abel" <[email-masked]>
Date: Fri, 16 Jul 2010 12:15:46 +0800

>>> Whatever you think's best.  I can't get very excited about nomenclature 
>>> :), I just have the one minor concern about what ulabel means to me, but 
>>> I can't even get very worked up about that :)
>>>
>>> I have a very mild preference for utf-8 in contexts where UTF-8 is 
>>> interesting.  (Internally, I expect most windows apps to store email 
>>> addresses in UTF-16 WCHARS as that's what our native data/string types 
>>> are, so u* as in "Unicode" could still be vague in some contexts.  Utf8* 
>>> would be very clear that UTF-8 is expected and not some other form of 
>>> Unicode).  IDNA didn't care about the encoding of the Unicode, so 
>>> U-Label works for it.
>>>
>>> That said, I reiterate that I've said way more words on this topic than 
>>> I really have the passion for, whatever's easy for the authors is fine 
>>> with me.  I mildly agree that consistency between docs would be nice, 
>>> but I can't even get worked up about that either.
>>>
>>

I have no idea, and I will follow you.  In the next version, we can check 
the  term to each other and make it consistency.

Abel

---

From: Shawn Steele <[email-masked]>
Date: Fri, 16 Jul 2010 05:01:01 +0000

Whatever you'd like.  Consistency is good between docs.  I'm fine with umailbox.

I think the more interesting thing is to NOT redefine the terms in different ways in different places.  I think it'd be better? for 5336bis to point to the definitions of mailboxes in 5335bis?  Eg: 5335 should focus on headers & addresses, and 5336 should focus on how SMTP handles those changes?

-Shawn

 
http://blogs.msdn.com/shawnste

________________________________________
From: Jiankang YAO [[email-masked]]
Sent: Thursday, July 15, 2010 8:02 PM
To: Ernie Dainow; Shawn Steele; [email-masked]
Subject: Re: [EAI] ulabel

----- Original Message -----
From: "Ernie Dainow" <[email-masked]>
To: "YAO Jiankang" <[email-masked]>; "Shawn Steele" <[email-masked]>; <[email-masked]>
Sent: Thursday, July 15, 2010 5:43 AM
Subject: Re: [EAI] ulabel

yes.

Jiankang  Yao

---

From: "Jiankang YAO" <[email-masked]>
Date: Fri, 16 Jul 2010 15:06:03 +0800

the tradion is that rfc2821 and rfc28822, rfc5321 and rfc5322 has similar definitions of mailbox.

both headner and smtp documents need mailbox defintion, either you said you reference it or repeat it is same.

even rfc5336bis reference rfc5335bis'definiton, rfc5336bis should be still repeat the mailbox'defintion.

---

From: Shawn Steele <[email-masked]>
Date: Fri, 16 Jul 2010 07:23:26 +0000

Repeating is fine, so long as they're the exactly the same (which they aren't right now).  So referencing seems safer to me.  The problem with repeating is that if something's slightly different, then any ambiguity becomes more confusing.

-Shawn

 

________________________________________
From: Jiankang YAO [[email-masked]]
Sent: Friday, July 16, 2010 12:06 AM
To: Shawn Steele; Ernie Dainow; [email-masked]
Subject: Re: [EAI] ulabel

---

From: Tony Hansen <[email-masked]>
Date: Fri, 16 Jul 2010 09:14:05 -0400

+1 for referencing.

     Tony Hansen
     [email-masked]