Subject: Re: [EAI] mail bounce versus punycode conversion

From: Shawn Steele <[email-masked]>
Date: Tue, 13 Jul 2010 23:14:46 +0000

IMO I don't see any harm in stating that ascii@utf-8 might fail in unaware systems.  Like John said, it can't be required though.  I'm also not sure that it gains much to add that though.

-Shawn

---

From: Shawn Steele <[email-masked]>
Date: Tue, 13 Jul 2010 23:23:48 +0000

> > In the interest of maximum interoperability, I think we should specify 
> > that a UTF8SMTPbis MTA should do a conversion in this case.

> Speaking with my WG Co-Chair hat distinctly off, I agree.
> Interoperability is good and, if we know how to get messages
> through without problems, we should do so.

I agree as well.

> On the other hand,
> if there is lots of UTF-8 stuff in the headers, that might be harder than just converting domains to A-labels, so we need > to think through this carefully.

I wouldn't over-analyze the how part.  Yes, it can be "harder", however strange stuff could already be happening by non-aware servers, so I don't think we need to state exactly how.  This is something a 2821 environment could already do if it wanted, so there's very little we could add in the UTF8SMTP spec.

-Shawn

---

From: Shawn Steele <[email-masked]>
Date: Wed, 14 Jul 2010 22:32:09 +0000

> Sender                           Receiver
> ==========               ==========
> SMTP                 --->    SMTP
> Legacy systems, not covered by these specifications.

> SMTP                 --->    UTF8SMTPbis
> Sender will send only ASCII@ASCII or ASCII@ACE. Both must be accepted by 
> the receiver.

> UTF8SMTPbis   --->    SMTP
>Sender can only send ASCII@ASCII or ASCII@ACE.
>Anything with non-ASCII in addresses is returned as a delivery failure 
> (bounce), except for the case ASCII@non-ASCII which should be converted 
> to ASCII@ACE so that it can be sent (if the rest of the message conforms 
> to legacy email RFC 5321/5322).

For the 2nd case, it's not really different than the first, except that we have the opportunity to suggest that the receiver recognize ACE.  I wouldn't say MUST though.

For the 3rd case, again, it's limited to the legacy specifications.  Again, we can mention that the sender could consider punycode, but there are other reasons that might not work, so I think it's fair to say it depends on the legacy specifications.  There's not much point to encouraging the sender to do something that a legacy sender might not do.  

In short, I guess what I'm suggesting is that an EAI mail server must recognize the legacy stuff anyway, since it may need to send/receive regular SMTP traffic.  I think that overly specifying legacy interaction may unnecessarily complicate the main focus of these specs, which is to support UTF-8 mail.  

-Shawn