Subject: [EAI] EAI review topic: Parameter on MAIL command

From: John C Klensin <[email-masked]>
Date: Mon, 27 Dec 2010 19:12:34 -0500

(writing as co-chair)

Hi.

Joseph and/or I will be sending out a series of (short) notes to
the WG mailing list identifying substantive issues that the WG
needs to review and make decisions about.  They are going to be
short in the hope that people will read them and read them soon,
but there are relevant previous discussions on the mailing list,
in the reviews, and in the long set of notes I posted earlier
that people should try to understand before responding to the
questions.  However, remember that the WG is supposed to be
working quickly: these issues are in the critical path for
anything to more forward.

Question: Should we define, and require, an announcement
parameter on the MAIL command if the sender intends to transmit
either non-ASCII addresses or UTF-8 in headers (other than as
encoded words)?

Discussion references: My long note, especially item (2), which
I hope summarizes the review comments) and a number of comments
on-list about what is required if this header is not present.

    john

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 28 Dec 2010 20:33:32 +0000

>(writing as co-chair)
[Speaking as an individual contributor. As an AD I will be Ok with 
whatever there is rough consensus for.]

>either non-ASCII addresses or UTF-8 in headers (other than as
Yes.

(Note I think this is just one more drop in favor of having a new SMTP 
capability for the 5336bis SMTP extension).

---

From: "Jiankang YAO" <[email-masked]>
Date: Wed, 29 Dec 2010 15:23:18 +0800

....
>>either non-ASCII addresses or UTF-8 in headers (other than as

It seems that many colleagues in this list have agreed to add a parameter  on the MAIL command to indicate that
whether the message transferred is  in the format of UTF-8 in headers.
If the WG has a consensus on it, I will update it in the next version.

I propose the follow text about this parameter:
---------------------------------------------------------------------------------------------------
One optional parameter is added to the SMTP MAIL command.
 This parameter is named as UTF8HEADERS. The "UTF8HEADERS" parameter
has one of two values: y or n. The parameter "UTF8HEADERS" is
designed to assert whether the message transferred is  in the format of UTF-8 in headers, which means
that the message in the headers is in the format of UTF-8[RFC5336bis] if the value is 'y' or not if the value is
'n'.
If the server is not EAI-aware, 
the  "UTF8HEADERS" parameter MUST not be used in the MAIL command by the client.
-------------------------------------------------------------------------------------------------

any comments are welcome.

Thanks.

Jiankang Yao