Subject: [EAI] with protocol types Re: AD review of draft-ietf-eai-rfc5336bis-04.txt

From: "Jiankang YAO" <[email-masked]>
Date: Thu, 2 Dec 2010 16:54:22 +0800

----- Original Message ----- 
From: "Alexey Melnikov" <[email-masked]>
To: "EAI WG" <[email-masked]>
Sent: Saturday, November 27, 2010 9:10 PM
Subject: Re: [EAI] AD review of draft-ietf-eai-rfc5336bis-04.txt

> Alexey Melnikov wrote:
> 
>> 4.  IANA Considerations
>>
>>   +---------------+-----------------------------+---------------------+
>>   | WITH protocol | Description                 | Reference           |
>>   | types         |                             |                     |
>>   +---------------+-----------------------------+---------------------+
>>   | UTF8SMTPbis   | UTF8SMTPbis with Service    | [RFCXXXX]           |
>>   |               | Extensions                  |                     |
>>   | UTF8SMTPbisA  | UTF8SMTPbis with SMTP AUTH  | [RFC4954] [RFCXXXX] |
>>   | UTF8SMTPbisS  | UTF8SMTPbis with STARTTLS   | [RFC3207] [RFCXXXX] |
>>   | UTF8SMTPbisSA | UTF8SMTPbis with both       | [RFC3207] [RFC4954] |
>>   |               | STARTTLS and SMTP AUTH      | [RFCXXXX]           |
>>   +---------------+-----------------------------+---------------------+
>>
>> Do we really need to change the WITH protocol types?
> 
> I remembered one more thing: if other LMTP related changes are done, 
> this section should also register values for LMTP. E.g. 
> UTF8LMTP/UTF8LMTPA/UTF8LMTPS/UTF8LMTPSA.
> 

I still keep this part unchanged.

if we really need to change it to support lmtp, we may updae it in the next version.

below is my personal comments: 

if we register the with protocol type for UTF8LMTP/UTF8LMTPA/UTF8LMTPS/UTF8LMTPSA,

we must register  UTF8LMTP first as the ehlo keyword, but we have already said that UTF8SMTPbis apply to LMTP too.
for the UTF8LMTPA/UTF8LMTPS/UTF8LMTPSA, I have checked the related rfc, but not find the proper rfc for these keywords.

do the smtp related rfc ( [RFC3207]  [RFC3207] [RFC4954]) apply to lmtp too?

if that is true, we may add one sentence such as "the  "WITH protocol types" registered  are  applied to LMTP too" in the iana consideration.

or register new one for LMTP.

Jiankang Yao

_______________________________________________
> IMA mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ima

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 02 Dec 2010 12:57:28 +0000

>if we really need to change it to support lmtp, we may updae it in the next version.
Yes, we need to add 4 LMTP related entries, as LMTP is a different 
protocol from SMTP.

I think we also agreed to use "UTF8SMTP" instead of "UTF8SMTPbis" above, 
etc.?

>for the UTF8LMTPA/UTF8LMTPS/UTF8LMTPSA, I have checked the related rfc, but not find the proper rfc for these keywords.
There is no need to register a new SMTP keywords here, as LMTP is not an 
extension to SMTP, it is an independent protocol.

>do the smtp related rfc ( [RFC3207]  [RFC3207] [RFC4954]) apply to lmtp too?
Yes, both of them can be used in LMTP.

>or register new one for LMTP.
I think it would be track 5336bis-capable SMTP servers separately from 
5336bis-capable LMTP servers, that is why there are separate WITH 
keywords for them.

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 02 Dec 2010 13:23:18 +0000

This version addressed most of my concerns and is a big improvement. 
Thank you. Outstanding changes are:

1) Change "UTF8SMTPbis" WITH keywords to "UTF8SMTP", etc.
2) Add LMTP specific WITH keywords
3) I think we need to collapse X.6.8 and Y.6.8 into 1 IANA registration 
(with all allowed status codes listed in 1 place). I.e.:

      Code:               X.6.8
      Sample Text:        UTF-8 string reply is required,
                          but not permitted by the client
      Associated basic status code:  553, 550, 252
      Description:        This indicates that a reply containing a UTF-8
                          string is required to show the mailbox name,
                          but that form of response is not
                          permitted by the client.
 ...

We also need to decide on what to do with X.6.10 - deprecate it in the 
registry?

Best Regards,
Alexey

P.S. I still need to check the updated ABNF, I will do this later.

---

From: "Jiankang YAO" <[email-masked]>
Date: Fri, 3 Dec 2010 16:15:13 +0800

----- Original Message ----- 
From: "Alexey Melnikov" <[email-masked]>
To: "Jiankang YAO" <[email-masked]>; "EAI WG" <[email-masked]>
Sent: Thursday, December 02, 2010 9:23 PM
Subject: draft-ietf-eai-rfc5336bis-05.txt

> 2) Add LMTP specific WITH keywords

updated. 

   +---------------+----------------------------+----------------------+
   | WITH protocol | Description                | Reference            |
   | types         |                            |                      |
   +---------------+----------------------------+----------------------+
   | UTF8SMTP      | UTF8SMTP with Service      | [RFCXXXX]            |
   |               | Extensions                 |                      |
   | UTF8SMTPA     | UTF8SMTP with SMTP AUTH    | [RFC4954] [RFCXXXX]  |
   | UTF8SMTPS     | UTF8SMTP with STARTTLS     | [RFC3207] [RFCXXXX]  |
   | UTF8SMTPSA    | UTF8SMTP with both         | [RFC3207] [RFC4954]  |
   |               | STARTTLS and SMTP AUTH     | [RFCXXXX]            |
   | UTF8LMTP      | UTF8LMTP with Service      | [RFCXXXX]            |
   |               | Extensions                 |                      |
   | UTF8LMTPA     | UTF8LMTP with LMTP AUTH    | [RFC4954] [RFCXXXX]  |
   | UTF8LMTPS     | UTF8LMTP with STARTTLS     | [RFC3207] [RFCXXXX]  |
   | UTF8LMTPSA    | UTF8LMTP with both         | [RFC3207] [RFC4954]  |
   |               | STARTTLS and LMTP AUTH     | [RFCXXXX]            |
   +---------------+----------------------------+----------------------+

>                          but that form of response is not

updated.

> We also need to decide on what to do with X.6.10 - deprecate it in the 

a note is added in the iana consideration. 

is it ok? or just neglect it.

thanks a lot.

Jiankang Yao

---

From: Tony Hansen <[email-masked]>
Date: Fri, 03 Dec 2010 20:29:07 -0500

On 12/3/2010 3:15 AM, Jiankang YAO wrote:
> From: "Alexey Melnikov"<[email-masked]>
> To: "Jiankang YAO"<[email-masked]>; "EAI WG"<[email-masked]>

I think the order should be 252, 550, 553

> is it ok? or just neglect it.

Please add text similar to the following to the IANA considerations section:

     IANA is directed to add the following text to the end of the 
Description text of X.6.10:

         This is a duplicate of X.6.8 and deprecated from further use.

Thanks.

     Tony Hansen
     [email-masked]

---

From: "Jiankang YAO" <[email-masked]>
Date: Sat, 4 Dec 2010 10:13:27 +0800

----- Original Message ----- 
From: "Tony Hansen" <[email-masked]>
To: "EAI WG" <[email-masked]>
Sent: Saturday, December 04, 2010 9:29 AM
Subject: Re: [EAI] draft-ietf-eai-rfc5336bis-05.txt

>         This is a duplicate of X.6.8 and deprecated from further use.

thanks.
updated.

Jiankang Yao