Subject: Re: [EAI] EAI review topic: Parameter on MAIL command

From: Troy Starr <[email-masked]>
Date: Wed, 29 Dec 2010 03:01:25 -0800

Hi Jiankang -

First, apologies for not replying directly to your message and breaking your message thread.  I've been following the discussion of the mailing list archive on the web without actually subscribing to it, but wanted to respond to your proposal.  I've just subscribed to the mailing list now, but I don't have your actual e-mail message to reply to.  I've copied your original message below for context.

I agree that having an explicit MAIL parameter would be valuable for the reasons already discussed.  I'd like to propose a different parameter name and set of values, though.  My concern with the UTF8HEADERS parameter name is that it is very closely tied to this RFC, which could make future extensions more difficult than necessary.  I don't know what those future extensions might be, but I think it would be worthwhile to avoid potential difficulty if it's relatively easy to do so.

The closest analogy I could think of was the 8BITMIME SMTP extension (RFC 1652).  That WG also decided to create a MAIL parameter to indicate that the message was taking advantage of that SMTP extension.  However, instead of creating a parameter called 8BITMIMEBODY with a binary value, they gave the parameter a more generic name (BODY) and set the value to the specific type (7BIT for legacy and 8BITMIME for the new functionality).  That decision worked well for the future BINARYMIME SMTP extension (RFC 3030), since it allowed them to reuse the existing BODY parameter and simply add an additional value to it (BINARYMIME).

Making the parameter more generic may be of similar value to future working groups.  Therefore, I propose the following text instead:

----------
An optional parameter using the keyword HEADER is added to the MAIL FROM command.  The value associated with this parameter is a keyword indicating whether the message contains only ASCII characters in the envelope and header fields, or whether the message contains non-ASCII characters in the envelope and header fields and MUST follow the guidelines of this RFC.  The syntax of the value is as follows, using ABNF notation:

	header-value ::= "ASCII" / "UNICODE"

The maximum length of a MAIL FROM command line is increased by 15 characters by the possible addition of the HEADER keyword and value.
----------

I see that there's an active discussion about ASCII/Unicode/UTF-8 terminology within the mailing list, so the values used here should conform to whatever consensus is reached.  And of course, some may disagree and feel that the UTF8HEADERS proposal is more than sufficient.  I welcome any feedback.

- Troy Starr
Full disclosure: I work for Microsoft, but am not speaking on their behalf or in any official capacity.

-----Original Message-----
From: Jiankang YAO [mailto: [email-masked]]
Sent: Tuesday, December 28, 2010 11:23 PM
To: [email-masked]
Subject: Re: [EAI] EAI review topic: Parameter on MAIL command

....
>
>
>>Question: Should we define, and require, an announcement
>>parameter on the MAIL command if the sender intends to transmit
>>either non-ASCII addresses or UTF-8 in headers (other than as
>>encoded words)?
>>  

It seems that many colleagues in this list have agreed to add a parameter  on the MAIL command to indicate that
whether the message transferred is  in the format of UTF-8 in headers.
If the WG has a consensus on it, I will update it in the next version.

I propose the follow text about this parameter:
---------------------------------------------------------------------------------------------------
One optional parameter is added to the SMTP MAIL command.
 This parameter is named as UTF8HEADERS. The "UTF8HEADERS" parameter
has one of two values: y or n. The parameter "UTF8HEADERS" is
designed to assert whether the message transferred is  in the format of UTF-8 in headers, which means
that the message in the headers is in the format of UTF-8[RFC5336bis] if the value is 'y' or not if the value is
'n'.
If the server is not EAI-aware, 
the  "UTF8HEADERS" parameter MUST not be used in the MAIL command by the client.
-------------------------------------------------------------------------------------------------

any comments are welcome.

Thanks.

Jiankang Yao

---

From: Yangwoo Ko <[email-masked]>
Date: Thu, 30 Dec 2010 11:23:28 +0900

I think the name "HEADER" is broader than what it intends to specify.
Better (not in terms of asthetics but in terms of scoping) name is
"HEADER ENCODING".

In addition to this, ASCII/UTF8 sounds more appropriate in this
context than ASCII/UNICODE.

On Wed, Dec 29, 2010 at 8:01 PM, Troy Starr <[email-masked]> wrote:
> _______________________________________________
> IMA mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ima
>

-- 
a human known as [email-masked] @ gtalk

---

From: [email-masked]
Date: Wed, 29 Dec 2010 19:59:59 -0800 (PST)

> An optional parameter using the keyword HEADER is added to the MAIL FROM
> command.  The value associated with this parameter is a keyword indicating
> whether the message contains only ASCII characters in the envelope and header
> fields, or whether the message contains non-ASCII characters in the envelope
> and header fields and MUST follow the guidelines of this RFC.  The syntax of
> the value is as follows, using ABNF notation:

> The maximum length of a MAIL FROM command line is increased by 15 characters
> by the possible addition of the HEADER keyword and value.

I think this is an excellent suggestion.

> I see that there's an active discussion about ASCII/Unicode/UTF-8 terminology
> within the mailing list, so the values used here should conform to whatever
> consensus is reached.

Agreed as well.

				Ned