Subject: [EAI] Co-chair's comments on state of the documents and the WG

From: John C Klensin <[email-masked]>
Date: Tue, 21 Dec 2010 22:59:49 -0500

(writing as co-chair)

Hi.

Folks, I've been watching progress in this WG between some
weeks before the Beijing IETF and the present.  I think we are
in serious trouble and want to share that opinion with the WG
participants.  

For a WG to function and make a serious claim to represent IETF
technical consensus, there has to be significant participation,
review of documents, etc.  And that has to come from more than
the group of people writing documents.  In practice, we
sometimes relax that requirement a bit.  In particular, there
have been WGs that have been considered successful even though
there have really been only about a half-dozen really active
participants.  But that is just not sensible when the WG is
working on protocols that pose very significant risks to the
installed base if we overlook important cases.  As we have
noticed when we have sorted out the various implications of
extensions on legacy email implementations the EAI effort poses
just exactly that risk.  The extensive syntax discussion in
Beijing is an important example of how careful we need to be
about our decisions.

Our situation is made somewhat more difficult by the
observation that only a relatively small fraction of the
participants in the WG have significant personal experience
with large-scale Internet mail operations or a deep familiarity
with the existing Internet mail protocols.  As we have seen
with the reviews Alexey requested from the Apps Area review
team, when such reviews from the IETF's email expert community
come at all, they tend to come from outside the WG and tend to
find things that the WG did not.  That is disquieting to say
the least.

I note that we got a fairly large number of promises in both
Beijing and Maastricht to carefully review and comment on
documents.  Outside the author group and a few others, either
people did not do those reviews or they lack the skill or
background to find things that have been discovered by Alexey,
myself, or others outside the normal group of WG participants.

Clearly, there is a large community, especially among users of
east Asian languages, who very much want internationalized
email addresses and headers.  There are other communities with
similar needs but the they are not well-represented in the WG
(or have been strangely silent) so, if they have requirements
that are different from those we have seen already, we are at
risk of missing them or getting things wrong.  If the IETF
cannot or will not produce usable specifications, there is
reason to believe that communities will go off in their own
directions, resulting in huge interoperability problem in the
future.

One way of looking at the WG's problem is that there is a
community of people who are deeply interested in email
internationalization but who lack either extensive email
experience or significant experience in writing clear and
precise IETF specifications (whether the problem is with
technical English, ABNF, or the way the existing email specs
are written).  There is also a community who are expert in
Internet email and the writing of the relevant types of
specifications, but few of them have been actively involved in
i18n work and fewer still have time and "day job" support to
devote to this work.  The two communities are largely disjoint,
but both are needed to complete the EAI work with great
confidence about the results being correct and free of
dangerous side-effects.

In discussions with Alexey, it has become clear that we have
hard practical deadlines associated with the end of his term as
AD.  The core documents have to be in his hands and out for
IETF Last Call within the next several weeks or it seems
unlikely that the WG will be able finish its work... ever.

Having read the reviews from the last two weeks or so, I think
it ought to be possible to proceed as follows _if_ WG
participants are really interested enough in finishing this
work to put effort into it:

(1) We get some reviewers from inside the WG but outside the
author group to go through the comments and verify that they
have been properly disposed of, e.g., that appropriate changes
have been made to the documents or we have explained why not to
the satisfaction of the reviewers and/or significant consensus
of WG participants.

(2) We get ths three base documents into Alexey's hands with a
request for IETF Last Call really soon -- certainly before
January 15 and ideally early next week.  That means the
checking described in (1) needs to occur nearly immediately.
Bluntly, silence from those of you have have been silent since
July will have to be taken as indifference on your part to
whether the documents are completed and the WG continues.

(3) We get some serious suggestions from the WG on how we are
going to move forward with the two additional groups of
documents -- (i) POP/ IMAP/ common downgrading protocol
specifications and (ii) all of the "advice" stuff.  If we can
find adequate review for the protocol specs, we can presumably
proceed with them on the same basis that we are using to handle
the base documents.  I am, however, concerned that we may not
be able to find that quality of review unless more people
within the WG start doing serious work.  For the "advice"
documents, unless we can get a lot of review and input from
people who are much more experienced with Internet email than
the WG average --people who could write similar documents for
non-EAI email and have it be credible-- I suggest that we just
drop the documents from the WG agenda and handle them as
individual submissions.  I want to stress that I'm not assuming
there is anything wrong with the drafts -- the issue is only
about getting adequate review to convince ourselves and the
IETF community that those documents really do represent
community consensus.  Put differently, the problem is not
getting the I-Ds written; it is having them reflect sufficient
experience (not just opinions) to be accepted within the
broader Internet email environment.  Doing so requires noting
that the Internet email environment has survived well for
nearly 30 years without such documents.

If people disagree with this rather bleak analysis -- and I
hope they do -- suggesting areas where I am wrong would be a
useful first step in convincing us that the WG really does have
the energy to finish all of the work listed in the charter
(including the optional tasks).

   best regards and best wishes for anything you may be
   celebrating at this time of year,
    john

---

From: "Martin J. Dürst" <[email-masked]>
Date: Wed, 22 Dec 2010 17:19:01 +0900

Hello John,

I want to make sure that at least somebody replies to your mail.

I don't think at all that I'm qualifying with respect to email 
infrastructure implementation and operation experience; I'm just mostly 
an email user. I can help with internationalization issues, but my 
understanding is that that's not necessarily what's most needed now. I 
may be able to go through some comments and check whether they have been 
applied consistently (essentially a shepherd role?). Getting pointers to 
drafts and mails with comments would help.

On a meta-level, I'm a bit surprised by your comment that we have to 
finish within Alex'es term. I understand that it would be much more 
efficient if Alex could handle our drafts rather than a new AD, and I 
understand that each AD has their preferences for what work they want to 
have happening, and that on occasion very inactive WGs have been shut 
down, but what you wrote below almost sounded like the new AD would just 
shut the WG down without asking anybody, so I hope I'm misunderstanding.

Also, while I think that all your observations were to the point, I 
think a shorter mail, with a subject more like "Wanted: Reviewers for 
XYZ" would have a bigger chance to be read by the relevant people. Also, 
maybe you remember (if only faintly) some of the hands that went up in 
Maastricht or in Beijing, and might be able to contact them directly. On 
average, that gives a better result than anonymous appeals.

Regards,   Martin.

On 2010/12/22 12:59, John C Klensin wrote:
> _______________________________________________
> IMA mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ima
>
>

-- 
#-# Martin J. Dürst, Professor, Aoyama Gakuin University
#-# http://www.sw.it.aoyama.ac.jp   mailto:[email-masked]