Subject: Re: [EAI] draft review of: draft-ietf-eai-rfc5336bis-07.txt

From: Shawn Steele <[email-masked]>
Date: Thu, 23 Dec 2010 18:08:31 +0000

Sorry this was before I finished reading the rest of it, or I could've been clearer.

UTF8SMTP says the server's willing to accept UTF8.  Characters > 0x7f are illegal in addresses. So if the client sends mail with characters > 0x7f in the header, that'd be the 2nd half of the handshaking.  Doesn't work for VRFY / EXPN, so that's why they have their own thing.

-Shawn

 
http://blogs.msdn.com/shawnste

________________________________________
----------------------------------------------------------------------

Date: Wed, 22 Dec 2010 16:42:04 -0800
From: Dave CROCKER <[email-masked]>
Subject: Re: [EAI] draft review of: draft-ietf-eai-rfc5336bis-07.txt
To: Shawn Steele <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Message-ID: <[email-masked]>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

On 12/22/2010 1:43 PM, Shawn Steele wrote:
> The UTF8SMTP handshaking clearly indicates that we're talking in UTF-8.  No
> further handshaking is therefore required.

Please provide some clarification:

      Where does the text define an explicit protocol handshake, so that both
sides know that the session is now using UTF-8?

I could not find it (except for VRFY and EXPN...)

d/

--

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: Dave CROCKER <[email-masked]>
Date: Thu, 23 Dec 2010 10:28:29 -0800

On 12/23/2010 10:08 AM, Shawn Steele wrote:
> UTF8SMTP says the server's willing to accept UTF8.  Characters>  0x7f are illegal in addresses. So if the client sends mail with characters>  0x7f in the header, that'd be the 2nd half of the handshaking.  Doesn't work for VRFY / EXPN, so that's why they have their own thing.
...
> From: Dave CROCKER<[email-masked]>
...

> sides know that the session is now using UTF-8?

Sean,

Thanks for the follow-up.  Unfortunately, what you have described -- and it 
matches my understanding of the specification -- is only the first part of a 
handshake.  The remaining part is absent.  In other words, it is not a handshake.

Common examples of handshake mechanisms include:

    <http://www.inetdaemon.com/tutorials/internet/tcp/3-way_handshake.shtml>
    <http://en.wikipedia.org/wiki/Challenge-handshake_authentication_protocol>
    <http://en.wikipedia.org/wiki/Transmission_Control_Protocol>

That is, a "handshake" is a synchronization process for changing a condition. 
In this case, it moves an SMTP session from the condition of supporting network 
ASCII, for basic data representation, into the condition of supporting UTF-8.

Synchronization of such a change requires a /mutual/ exchange of coordination 
information, so that each participant can agree to the change.  This requires a 
minimum of one notification in /each direction/.  (More than one is primarily 
useful to cover certain types of failure conditions that occur in networks; 
hence TCP uses a three-way handshake.)

The EAI SMTP extension only has an announcement of UTF-8 capability by the 
server.  It has no corresponding agreement announced by the SMTP client that it 
will participate in support of UTF-8.

Adding a parameter to VRFY and EXPN is a good example of what is needed for the 
MAIL command, in that it is an explicit declaration by the client.

d/
-- 

   Dave Crocker

---

From: "Charles Lindsey" <[email-masked]>
Date: Mon, 27 Dec 2010 12:36:29 -0000

On Thu, 23 Dec 2010 18:28:29 -0000, Dave CROCKER <[email-masked]> wrote:

> That is, a "handshake" is a synchronization process for changing a  
> condition. In this case, it moves an SMTP session from the condition of  
> supporting network ASCII, for basic data representation, into the  
> condition of supporting UTF-8.
>
> Synchronization of such a change requires a /mutual/ exchange of  
> coordination information, so that each participant can agree to the  
> change.  This requires a minimum of one notification in /each  
> direction/.  (More than one is primarily useful to cover certain types  
> of failure conditions that occur in networks; hence TCP uses a three-way  
> handshake.)
>
> The EAI SMTP extension only has an announcement of UTF-8 capability by  
> the server.  It has no corresponding agreement announced by the SMTP  
> client that it will participate in support of UTF-8.

But I don't think that should be necessary. A client that is capable of  
handling these new UTF-8 messages is presumably aware of its own  
capability. So if it sees that the server advertises UTF8SMTP, it should  
be able to just start sending UTF-8 without further ado. There is no need  
to inform the server that it is willing to receive responses appropriate  
to that method of operation - the server can assume that any client  
sending such messages is uft-8 enabled (ignoring the case of broken  
clients that "just send 8 bits"). So a full handshake in the usual sense  
is not necessary.

In fact, as I have just written in my reply to Ned, the interesting case  
is when the client might wish to say "this message does NOT use UTF-8 so  
you can send it on to any destination".

-- 
Charles H. Lindsey ---------At Home, doing my own thing------------------------
Tel: +44 161 436 6131                       
   Web: http://www.cs.man.ac.uk/~chl
Email: [email-masked]      Snail: 5 Clerewood Ave, CHEADLE, SK8 3JU, U.K.
PGP: 2C15F1A9      Fingerprint: 73 6D C2 51 93 A0 01 E7 65 E8 64 7E 14 A4 AB A5

---

From: John C Klensin <[email-masked]>
Date: Mon, 27 Dec 2010 12:06:24 -0500

Charles,

I know that you (or your mail software) are inclined to strip
secondary addresses when you reply to mailing list posting.
Often that is useful.  But, for you and others with similar
habits/ systems please keep in mind that most of the reviewers
in this round are not on the IAM list -- I don't remember if Ned
is, Dave certainly is not unless he subscribed in the last week
or two.  If you have any doubt, please be sure you include the
address of whomever you are responding to in your reply.
Otherwise, the person to whom you are responding may not see
your response or, almost as bad, if you send him or her the
response separately, the WG may not see any discussion that
follows.

    thanks,
      john

--On Monday, December 27, 2010 12:36 PM +0000 Charles Lindsey
<[email-masked]> wrote:

>> That is, a "handshake" is a synchronization process for
>> changing a   condition. In this case, it moves an SMTP
>> session from the condition of   supporting network ASCII, for
>> basic data representation, into the   condition of supporting
>> UTF-8.
>> 
>> Synchronization of such a change requires a /mutual/ exchange
>> of   coordination information, so that each participant can
>> agree to the   change.  This requires a minimum of one
>> notification in /each   direction/.  (More than one is
>> primarily useful to cover certain types   of failure
>> conditions that occur in networks; hence TCP uses a three-way
>>  handshake.)
>> 
>> The EAI SMTP extension only has an announcement of UTF-8
>> capability by   the server.  It has no corresponding
>> agreement announced by the SMTP   client that it will
>> participate in support of UTF-8.
> 
> But I don't think that should be necessary. A client that is
> capable of handling these new UTF-8 messages is presumably
> aware of its own capability. So if it sees that the server
> advertises UTF8SMTP, it should be able to just start sending
> UTF-8 without further ado. There is no need to inform the
> server that it is willing to receive responses appropriate to
> that method of

---

From: Dave CROCKER <[email-masked]>
Date: Mon, 27 Dec 2010 11:02:52 -0800

On 12/27/2010 9:06 AM, John C Klensin wrote:
>  most of the reviewers
> is, Dave certainly is not

i am subscribed.

d/
-- 

   Dave Crocker

---

From: John C Klensin <[email-masked]>
Date: Mon, 27 Dec 2010 14:17:43 -0500

--On Monday, December 27, 2010 11:02 AM -0800 Dave CROCKER
<[email-masked]> wrote:

>> in this round are not on the IAM list -- I don't remember if
>> Ned is, Dave certainly is not
> 
> 
> i am subscribed.

Sorry for the duplicate then.  And thanks.

    john

---

From: "Charles Lindsey" <[email-masked]>
Date: Tue, 28 Dec 2010 12:11:56 -0000

On Mon, 27 Dec 2010 17:06:24 -0000, John C Klensin <[email-masked]> wrote:

> Often that is useful.

Indeed. Some people (myself included) prefer NOT to receive personal  
copies of messages that are also sent to a mailing list. Other people take  
exactly the opposite view. You can't please everybody _;( .

> ...  But, for you and others with similar
> or two.

OK, point taken, and I am happy to use "reply to all" when I know that  
some particular person in an occasional visitor not actually subscribed to  
the list. But in the case of Dave and Ned, Dave has confirmed he is now  
subscribed and Ned submitted a response to a message I had sent to the  
list only, so I presume he is now subscribed also. But I shall watch out  
for future problems of this nature.