Subject: [EAI] UTF-8 in Message-IDs consensus

From: Joseph Yee <[email-masked]>
Date: Wed, 14 Sep 2011 08:43:25 -0400

All,

Below are consensus statement following the discussion thread UTF-8 in Message-IDs whether allowing UTF-8 or not:

Message-ID can contain UTF-8 encodings in both formal syntax (ABNF) and general text.

----
Some note and observation
(1) There may be hiccups during transition period, but no convincing cases demonstrating Internet or Email will be "broken badly"
(2) With encouragement of using domain as value of id-right in practice,  the WG majority preference (from past discussion, not just the email thread mentioned above) is using U-label rather than A-label
(3) Regarding the concern of leak,  maybe we want to add some RECOMMEND text for MAIL FROM (or EAI capable MTA) check? [personal opinion]
(4) The "SHOULD NOT use ASCII" could be used in advice doc explaining the advantage of being more conservative [this is personal opinion, not as chair]
 
----

Again, sorry that I can't send this early enough.

Thanks
Joseph

---

From: Tony Hansen <[email-masked]>
Date: Wed, 14 Sep 2011 09:05:41 -0400

> (4) The "SHOULD NOT use ASCII" could be used in advice doc explaining the advantage of being more conservative [this is personal opinion, not as chair]

Did you get #4 wrong? Is that supposed to read

     SHOULD NOT use UTF-8

?

     Tony Hansen

---

From: Joseph Yee <[email-masked]>
Date: Wed, 14 Sep 2011 09:11:24 -0400

Yes, my mistake.

Thanks for noticing that.

Revised #4
(4) The "SHOULD NOT use UTF-8" could be used in advice doc explaining
the advantage of being more conservative [this is personal opinion,
not as chair]

Thanks
Joseph

On Wed, Sep 14, 2011 at 9:05 AM, Tony Hansen <[email-masked]> wrote:
>> Below are consensus statement following the discussion thread UTF-8 in
>> Message-IDs whether allowing UTF-8 or not:
>>
>> (1) There may be hiccups during transition period, but no convincing cases
>> demonstrating Internet or Email will be "broken badly"
>> (2) With encouragement of using domain as value of id-right in practice,
>>  the WG majority preference (from past discussion, not just the email thread
>> mentioned above) is using U-label rather than A-label
>> (3) Regarding the concern of leak,  maybe we want to add some RECOMMEND
>> text for MAIL FROM (or EAI capable MTA) check? [personal opinion]
>> (4) The "SHOULD NOT use ASCII" could be used in advice doc explaining the
>> advantage of being more conservative [this is personal opinion, not as
>> chair]
>
> _______________________________________________
> IMA mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ima
>