Subject: Re: [EAI] UTF-8 in Message-IDs consensus

From: Shawn Steele <[email-masked]>
Date: Wed, 14 Sep 2011 19:17:53 +0000

I'm happy with this; I'm fine with any extra text being in the advice doc, unless it is very simple & quibble-proof :)

-Shawn

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Wed, 14 Sep 2011 23:06:26 +0200

On 09/14/2011 09:17 PM, Shawn Steele wrote:
> I'm happy with this; I'm fine with any extra text being in the advice doc, unless it is very simple&  quibble-proof :)

"Implementers of message-id generation algorithms may prefer to restrain 
their output to ASCII since that has a few minor advantages, such as 
when constructing References fields in mailing-list threads where some 
senders use EAI and others not."

Arnt

---

From: John C Klensin <[email-masked]>
Date: Wed, 14 Sep 2011 17:27:36 -0400

--On Wednesday, September 14, 2011 19:17 +0000 Shawn Steele
<[email-masked]> wrote:

> I'm happy with this; I'm fine with any extra text being in the
> advice doc, unless it is very simple & quibble-proof :)

With the understanding that this should not affect the consensus
call results, could people clarify which "advice document" they
have in mind?  From a quick look at the charter, there are four
possibilities:

(1) Reopen draft-ietf-eai-frmwrk-4952bis (now in the RFC Editor
queue) and put text there.

(2) Advice for non-ASCII & ASCII addresses
(3) Advice for MUA implementors
(4) Advice for EAI deployment

Note that no I-Ds for any of the last three documents have been
posted, indeed, the WG hasn't made a formal decision to move
forward with any (much less all) of them.  We have decided to
not make that decision until the protocol documents are under
control and we can appraise how much actual energy there is to
complete the work.

    john

---

From: Shawn Steele <[email-masked]>
Date: Wed, 14 Sep 2011 21:30:55 +0000

I don’t care which one, except don’t reopen the queued one, not high priority for me, just don’t want a lot of back and forth.

-----Original Message-----
From: John C Klensin [mailto:[email-masked]] 
Sent: ᏦᎢᏁᎢᎦ, ᏚᎵᏍᏗ 14,2011 2:28 PM
To: Shawn Steele; [email-masked]
Subject: Re: [EAI] UTF-8 in Message-IDs consensus

--On Wednesday, September 14, 2011 19:17 +0000 Shawn Steele <[email-masked]> wrote:

> I'm happy with this; I'm fine with any extra text being in the advice 
> doc, unless it is very simple & quibble-proof :)

With the understanding that this should not affect the consensus call results, could people clarify which "advice document" they have in mind?  From a quick look at the charter, there are four
possibilities:

Note that no I-Ds for any of the last three documents have been posted, indeed, the WG hasn't made a formal decision to move forward with any (much less all) of them.  We have decided to not make that decision until the protocol documents are under control and we can appraise how much actual energy there is to complete the work.

    john

---

From: John C Klensin <[email-masked]>
Date: Wed, 14 Sep 2011 17:49:10 -0400

--On Wednesday, September 14, 2011 21:30 +0000 Shawn Steele
<[email-masked]> wrote:

> I don't care which one, except don't reopen the queued
> one, not high priority for me, just don't want a lot of back
> and forth.

Shawn (and others),

I'm asking for two main reasons:

(1) I think  there is a real possibility that the "advice"
documents will get lost, or at least deferred for a long time,
after we extrapolate from current levels of activity in the WG
to the likelihood of taking on new documents and getting them
done in a reasonable period.  IMO, the odds go up somewhat if we
handle those documents as Applicability Statements and can get
WG and IESG consensus for publishing versions at Proposed
Standard without broad consensus that all issues have been
addressed and all nits picked, but I don't know how realistic
that is.   In any event, if the WG decides that the text should
go into an "advice document" that has not yet been put on the
agenda, we need to be prepared to abandon that text if the WG
shuts down before that advice document is published.

(2) There has been a brief discussion of another option, which
would be to attach this sort of material as an appendix to
5335bis.  That has several disadvantages, including some risk of
5335bis being delayed while we quibble about text.

FWIW, my personal view is that we should narrow 5335bis and
5336bis as much as possible in the interest of getting agreement
and getting them out, but that is not a co-chair opinion.  Given
the risk of losing the material, I do not believe the co-chairs
or author team should make the decision without an opportunity
for advice from the WG.

   john

---

From: Shawn Steele <[email-masked]>
Date: Wed, 14 Sep 2011 21:50:50 +0000

Yes, I realize there's a risk of  the advice getting lost, however I'd rather take that risk than delaying or risking the existing docs

-----Original Message-----
From: John C Klensin [mailto:[email-masked]] 
Sent: Wednesday, September 14, 2011 2:49 PM
To: Shawn Steele; [email-masked]
Subject: RE: [EAI] UTF-8 in Message-IDs consensus

--On Wednesday, September 14, 2011 21:30 +0000 Shawn Steele <[email-masked]> wrote:

> I don't care which one, except don't reopen the queued one, not high 
> priority for me, just don't want a lot of back and forth.

Shawn (and others),

(1) I think  there is a real possibility that the "advice"
documents will get lost, or at least deferred for a long time, after we extrapolate from current levels of activity in the WG to the likelihood of taking on new documents and getting them done in a reasonable period.  IMO, the odds go up somewhat if we handle those documents as Applicability Statements and can get WG and IESG consensus for publishing versions at Proposed Standard without broad consensus that all issues have been addressed and all nits picked, but I don't know how realistic
that is.   In any event, if the WG decides that the text should
go into an "advice document" that has not yet been put on the agenda, we need to be prepared to abandon that text if the WG shuts down before that advice document is published.

(2) There has been a brief discussion of another option, which would be to attach this sort of material as an appendix to 5335bis.  That has several disadvantages, including some risk of 5335bis being delayed while we quibble about text.

FWIW, my personal view is that we should narrow 5335bis and 5336bis as much as possible in the interest of getting agreement and getting them out, but that is not a co-chair opinion.  Given the risk of losing the material, I do not believe the co-chairs or author team should make the decision without an opportunity for advice from the WG.

   john

---

From: Joseph Yee <[email-masked]>
Date: Wed, 14 Sep 2011 17:54:31 -0400

Hi all,

My original thought (and a personal thought) is to capture it and think about it again after core doc.  So would all agree that we (the WG) just capture it in issue log (Trac) for now and think more about it when the time is right?  Unless the rough consensus is to put it into RFC4952bis.  

Best Regards,
Joseph, co-chair of EAI

On 2011-09-14, at 5:27 PM, John C Klensin wrote:

> _______________________________________________
> IMA mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ima

---

From: Shawn Steele <[email-masked]>
Date: Wed, 14 Sep 2011 22:06:03 +0000

Yes, that's my preference (capture it)

-----Original Message-----
From: Joseph Yee [mailto:[email-masked]] 
Sent: Wednesday, September 14, 2011 2:55 PM
To: John C Klensin
Cc: Shawn Steele; [email-masked]
Subject: Re: [EAI] UTF-8 in Message-IDs consensus

Hi all,

Best Regards,
Joseph, co-chair of EAI

On 2011-09-14, at 5:27 PM, John C Klensin wrote:

> With the understanding that this should not affect the consensus call 
> results, could people clarify which "advice document" they have in 
> mind?  From a quick look at the charter, there are four
> possibilities:
> 
> posted, indeed, the WG hasn't made a formal decision to move forward 
> with any (much less all) of them.  We have decided to not make that 
> decision until the protocol documents are under control and we can 
> appraise how much actual energy there is to complete the work.
> 
>    john
>

---

From: "Martin J. Dürst" <[email-masked]>
Date: Thu, 15 Sep 2011 13:16:43 +0900

On 2011/09/15 6:06, Arnt Gulbrandsen wrote:
>> doc, unless it is very simple& quibble-proof :)
>

Just in case we put a text like this in (I don't mind one way or 
another), please remove "minor".

Regards,   Martin.

---

From: Joseph Yee <[email-masked]>
Date: Mon, 19 Sep 2011 10:59:48 -0400

All,

I have create a ticket in Trac about the scenario for future reference.
http://trac.tools.ietf.org/wg/eai/trac/ticket/11

We will revisit this only after core drafts completed.

Thanks
Joseph, co-chair of EAI

On 2011-09-15, at 12:16 AM, Martin J. Dürst wrote:

> Just in case we put a text like this in (I don't mind one way or another), please remove "minor".
> 
> Regards,   Martin.