Subject: Re: [EAI] IDN domains and EAI

From: Shawn Steele <[email-masked]>
Date: Wed, 7 May 2014 19:23:51 +0000

> Perhaps. But I fear the costs: Letting xn-- into bodies, letting phpmailer users get around a lack of EAI by using xn--, encouraging mail format upgrade by final delivery software.

I agree that it should be strongly discouraged, I wouldn't be opposed to stronger wording, or even forbidding it.  Of course, then someone's gonna want to "upgrade" from a non-EAI mail to an EAI mail (like when replying or forwarding?) and then conversion might happen anyway, and there're going to be a lot of edge cases where punycode sneaks in unexpectedly (unfortunately).

The direction we're going is that our networking APIs have Unicode interfaces anyway.  So all the punycode hackiness is hopefully hidden away in the guts of the APIs, and the applications just need to handle the Unicode forms.  Unless they have some sort of limited networking protocol that makes them do the conversion anyway, like the app is handling non-EAI SMTP.  But the goal is to hide the gory details away from most applications, most apps don't need to know how to do that.

I'd prefer having DNS servers that advertised UTF-8 awareness too, then the Punycode part could be handled transparently on those servers' sides.  But I really don't want punycode to escape its current sandbox any more than it has to.

-Shawn

---

From: Andrew Sullivan <[email-masked]>
Date: Wed, 7 May 2014 16:24:26 -0400

On Wed, May 07, 2014 at 07:23:51PM +0000, Shawn Steele wrote:
> 
> I'd prefer having DNS servers that advertised UTF-8 awareness too

As I think I've tried to explain before, you can't have this because
of the way the DNS is distributed.  If we're going to get a name
service that supports UTF-8 labels directly (presumably with a bunch
of normalization rules &c.), then it's going to be in DNSng.

I am prepared to have that conversation, but it's not something to
have in passing when talking about EAI.

A

-- 
Andrew Sullivan
[email-masked]

---

From: [email-masked]
Date: Wed, 07 May 2014 15:13:45 -0700 (PDT)

> have in passing when talking about EAI.

And given this reality, the two forms are necessarily equivalent in some
sense.

And it's not really the same as having two different domains with the same MX
or A records. 

Finally, given that EAI has been slow to standardize and deploy, and
given how these things tend to work, I believe the safest course of action
is to assume leakage of a-labels into email addresses and act accordingly.

				Ned