Subject: [imap5] News about Mark Crispin

From: Barry Leiba <[email-masked]>
Date: Mon, 19 Nov 2012 19:44:51 -0500

Everyone here knows Mark Crispin -- or at least knows who he is: Mark is the author of the original 
IMAP specification, and has taken it through its different versions to the present IMAP4rev1.  He's 
written reference implementations of both server and client, and has been a vocal participant on 
all the mailing lists I'm posting this to.

I'm sad to have to report that Mark is now terminally ill, and is in hospice care.

For now, at least, I'm told that Mark is at least somewhat aware.  If anyone has brief well-wishing 
messages they'd like to send him, please post them to the <[email-masked]> mailing list, and I'll 
forward them to Mark's long-term companion, Annie.  I will also post updates to that list as I get 
them.

[The Reply-To for this message is set to <[email-masked]>, so that replies will go there.  You will 
have to subscribe to that mailing list in order to post to it.  You can do that here:
http://www.ietf.org/mailman/listinfo/imap5 ]

Barry Leiba

---

From: Randall Gellens <[email-masked]>
Date: Mon, 19 Nov 2012 23:21:13 -0800

>  If anyone has brief well-wishing messages they'd like to send him, 
> please post them to the <[email-masked]> mailing list, and I'll 
> forward them to Mark's long-term companion, Annie.

Mark,

You've contributed so much to Internet mail.  You are one of the 
pioneers who will be long remembered (not just for technical work but 
also for personal anecdotes).  Working with you over the years has 
been fun, challenging, frustrating, and rewarding.  We didn't always 
agree, but your views always informed and progressed the debate.

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
Time is nature's way of making sure that everything doesn't
happen on schedule.

---

From: Jan Schneider <[email-masked]>
Date: Tue, 20 Nov 2012 12:07:05 +0100

This is really sad news, and on behalf of the whole Horde project I'd  
like to thank you for everything you have done to make the Internet a  
better place. We have fought our fights with the standards and the  
software you created. But without it, and without your awesome work on  
helping people to communicate with each other, we wouldn't even exist.  
We owe you a lot. Thank you!
-- 
Jan Schneider
The Horde Project
http://www.horde.org/

---

From: Sabahattin Gucukoglu <[email-masked]>
Date: Tue, 20 Nov 2012 12:24:26 +0000

I can't deny that I found discourse with him to be insufferable at best.  We most certainly did not agree on points, as I'm sure is familiar to many of us.

But … he has willingly given us all the most interoperable message exchange and access protocols this world has known, and has furthered the cause of peaceful interoperability for its own sake in one of the toughest realms there is.  His contribution will certainly not be forgotten and I wish him the very best.

Cheers,
Sabahattin

---

From: Timo Sirainen <[email-masked]>
Date: Tue, 20 Nov 2012 20:44:53 +0200

To Mark,

Your work on IMAP protocol has definitely influenced the last 10 years of my life, ever since I first started working on Dovecot. I've enjoyed most of that time and learned a lot. I remember initially having disagreements with you on several parts of the IMAP protocol design, but after a few years you convinced me that I was simply wrong in all of the important cases.

I'll do my best to keep the spirit of IMAP protocol design alive in whatever forms email access protocols may evolve to in future. Sorry I came a bit too late to the scene and never had a chance to meet you in person.

---

From: Rob Austein <[email-masked]>
Date: Tue, 20 Nov 2012 14:48:25 -0500

Not quite 30 years ago, I encountered Mark's TOPS-20 MMAILR package.
That was my first exposure to what would later be called Open Source
and to the ARPANET that was then evolving into the Internet.  A few
years later, I was a sysadmin at MIT, Mark was my opposite number at
Stanford, and he spent a lot of time correcting my silly ideas about
how to write DNS support for the TOPS-20 mailsystem.  Much later, we
met again when Mark brought IMAP to the IETF, and he was kind enough
to listen to my silly ideas on using IMAP as a replacement for PCMAIL.

Mark, I'd say it in TECO, but it'd be hard for Annie to pronounce.
Sayonara, and thanks for all the hacks.

--Rob Austein (once known, a long time ago, as SRA@MIT-XX)

---

From: Tony Hansen <[email-masked]>
Date: Tue, 20 Nov 2012 15:31:12 -0500

Mark, I have so many memories of working with you over the years, 
beginning way back when we were in grad school @stanford and then later 
on in the mail world. Sometimes we agreed and sometimes we didn't. :-)  
I always respected your work, and your care for what you felt was right. 
We owe you much.

     Tony Hansen
     [email-masked]

---

From: Dave Crocker <[email-masked]>
Date: Wed, 21 Nov 2012 13:46:13 -0800

Mark,

Think back to the first mailing lists of the 1970s.  Small group.  Only 
about 100 of us at first. Intense debates.  Fresh and fun at the time. 
Even the disagreements.  Added a new meaning to First Old Flame.  So 
much has changed in 40 years, but not the core you worked on.

Except that now it's merely an essential part of an essential global 
service.   From 100 to billions.

Thank you.

d/

-- 
  Dave Crocker
  Brandenburg InternetWorking
  bbiw.net

-- 
  Dave Crocker
  Brandenburg InternetWorking
  bbiw.net

---

From: Asheesh Laroia <[email-masked]>
Date: Wed, 28 Nov 2012 09:14:18 -0500 (EST)

Dear Barry, and Annie, and Mark,

(and the rest of imap5,)

One day in 2000 or 2001, my mail reader converted all my mail into its own 
format. That was when I knew I should leave mail access to the IMAP 
daemon.

In the past dozen years or so, I discovered UW IMAP, fell in love with 
pine, learned all about UIDVALIDITY and Maildir, became alpine's 
maintainer in Debian, and joined the imap5 list.

I wonder if you can even know the impact and legacy you have left behind. 
And separately, only a few years ago, I particularly enjoyed trading 
emails with you on the topic of downtown Newark.

It is far too soon for you to go. Please, Mark, accept my well wishes, and 
I hope Annie will accept my heartfelt sympathy. I will miss your presence.

-- Asheesh.