Subject: Re: [imapext] Spencer Dawkins' No Objection on draft-ietf-qresync-rfc5162bis-10: (with COMMENT)

From: Alexey Melnikov <[email-masked]>
Date: Thu, 20 Feb 2014 10:19:16 +0000

Hi Spencer,

> On 20 Feb 2014, at 06:23, "Spencer Dawkins" <[email-masked]> wrote:
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
> 
> This is a question, not a request for a text change.
> 
> In section 4.  Long Command Lines (Update to RFC 2683), does this work
> because the only implementations using command lines longer than 1000
> bytes are using them to implement this spec?

It is possible to hit this limit when a client not using CONDSTORE/QRESYNC issues a SEARCH and then reformats the result of the SEARCH as a parameter to FETCH, COPY or MOVE (e.g. in order to perform "move all matching messages to another mailbox" operation). In my experience client just don't check lengths of message sets.

But CONDSTORE/QRESYNC are the prime reason for extending the limit, as the updated SELECT command includes a possibly long set of UIDs as a parameter. 

> I wasn't completely comfortable updating RFC 2683 in a document that's
> mostly defining new extensions, wondering if that update would be visible
> enough to implementers who weren't reading this spec. I'm just majing
> sure I'm wrong about that ...

The update would be marked with Updates boilerplate header, that should be good enough. At least I always check this header when implementing IETF stuff ;).

Best Regards,
Alexey

---

From: "Spencer Dawkins" <[email-masked]>
Date: Wed, 19 Feb 2014 22:23:24 -0800

Spencer Dawkins has entered the following ballot position for
draft-ietf-qresync-rfc5162bis-10: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to http://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
http://datatracker.ietf.org/doc/draft-ietf-qresync-rfc5162bis/