Subject: [imapext] create-special-use

From: Arnt Gulbrandsen <[email-masked]>
Date: Tue, 3 Mar 2015 19:46:44 +0100

Hi,

do any servers implement that? If so, which?

Some Gmail-specific clients create an x-gm-label called Later. I don't see 
a way to do anything equivalent using create-special-use, am I overlooking 
anything?

Arnt

---

From: Bron Gondwana <[email-masked]>
Date: Wed, 04 Mar 2015 08:24:28 +1100

> do any servers implement that? If so, which?

Cyrus 2.5 will when it gets released (hopefully today).  We use it at FastMail when we create accounts.
 
> a way to do anything equivalent using create-special-use, am I overlooking 

So create-special-use defined only a specific set of labels.  In Cyrus we support adding other special-use fields, but you need to name them in the config file:

specialuse_extra: \XChats \XTemplates

Bron.

-- 
  Bron Gondwana
  [email-masked]

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Tue, 3 Mar 2015 22:25:55 +0100

On Tuesday, March 3, 2015 10:24:28 PM CEST, Bron Gondwana wrote:
> So create-special-use defined only a specific set of labels.  
> In Cyrus we support adding other special-use fields, but you 
> need to name them in the config file:
>

Sounds as if this is not discoverable/usable in an IMAP client?

Arnt

---

From: Bron Gondwana <[email-masked]>
Date: Wed, 04 Mar 2015 08:28:17 +1100

> Sounds as if this is not discoverable/usable in an IMAP client?

Sadly not.  The spec provides no provision for advertising what special-use names the server supports that I can see.

I guess a client can see that they exist in the LIST response, but that's about it.

Bron.

-- 
  Bron Gondwana
  [email-masked]

---

From: Chris Newman <[email-masked]>
Date: Tue, 03 Mar 2015 17:46:11 -0800

> do any servers implement that? If so, which?

We intend to provide this extension in a future release of our server (Oracle
Communications Messaging Server).

		- Chris

---

From: Paul Smith <[email-masked]>
Date: Wed, 04 Mar 2015 08:52:20 +0000

> do any servers implement that? If so, which?
Assuming you mean RFC 6154, then our VPOP3 Enterprise mail server 
supports that since v6.3 (June 2013)

We just support the \Archive, \Drafts, \Junk, \Sent and \Trash attributes.

If there were other 'normal' attributes (eg \Templates) defined in later 
updates we could add those trivially. The 'meta' attributes (\Flagged 
and \All) would be a bit more tricky to support without being very slow, 
so we haven't bothered with those for now since there isn't user demand 
for them.

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Wed, 4 Mar 2015 10:41:19 +0100

Paul Smith wrote:
> Assuming you mean RFC 6154, then our VPOP3 Enterprise mail 
> server supports that since v6.3 (June 2013)

6154 defines two capabilities, special-use and create-special-use. These 
are its example for the latter:

     C: t2 CREATE MySpecial (USE (\Drafts \Sent))
     S: t2 OK MySpecial created

     C: t3 CREATE Everything (USE (\All))
     S: t3 NO [USEATTR] \All not supported

Do you support that?

Arnt

---

From: Paul Smith <[email-masked]>
Date: Wed, 04 Mar 2015 09:47:12 +0000

On 04/03/2015 09:41, Arnt Gulbrandsen wrote:
> 6154 defines two capabilities, special-use and create-special-use. 
> These are its example for the latter:
>
Yes (the text isn't identical - eg the error would be 'NO [USEATTR] 
Unsupported special use flag attempted', but the idea is the same)

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 04 Mar 2015 10:53:35 +0000

> Communications Messaging Server).
At the moment in Isode M-Box SPECIAL-USE attributes are based on server 
configuration, so the need for this is not strong for us. But Isode can 
add support for this if there is enough interest from client developers.