Subject: Re: [imapext] The IMAP APPENDLIMIT Extension - version 04

From: Timo Sirainen <[email-masked]>
Date: Mon, 6 Apr 2015 20:26:06 +0900

On 04 Mar 2015, at 10:32, Chris Newman <[email-masked]> wrote:
> 
> Q for list: If the server has a message larger than UINT32_MAX in the store and
> a client tries to fetch it, should the server just go ahead and violate the
> base-spec's UINT32_MAX limit

Dovecot has already been doing this for the last 10 years or so. If it has been compiled with 64bit off_t support (default) it has allowed >32bit APPENDs and FETCHing will always return the full message. I doubt anybody has actually attempted using that, but if this becomes more commonly used there is already a large number of Dovecots happily serving such content without extra extensions.. I guess this isn't ideal from protocol purity point of view, but it's probably going to work fine in practise whenever such emails are actually becoming used.

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 07 Apr 2015 12:44:16 +0100

> Dovecot has already been doing this for the last 10 years or so. If it has been compiled with 64bit off_t support (default) it has allowed >32bit APPENDs and FETCHing will always return the full me…
I still prefer if support for more than UINT32_MAX is advertised 
somehow. Maybe this can be folded into IMAP update.