Subject: Re: [imapext] I-D Action: draft-melnikov-rfc2088bis-04.txt

From: Timo Sirainen <[email-masked]>
Date: Mon, 6 Apr 2015 20:34:42 +0900

Hi,

On 09 Mar 2015, at 21:21, Alexey Melnikov <[email-masked]> wrote:
> 
> I've just posted -03 and 04 (fixed a few things in 03 which I haven't noticed before posting). The main change to LITERAL- is to allow non synchronizing literals <= 4096 bytes in APPEND (instead of just prohibiting them).
> Comments are very welcome.

I'm badly lagging behind my emails, so I'm not sure if this comment has been made:

>    "LITERAL-" extension is almost identical to "LITERAL+", with one
>    exception: when "LITERAL-" is advertised, non synchronizing literals
>    used in APPEND (and extensions to APPEND such as MULTIAPPEND
>    [RFC3502 <http://tools.ietf.org/html/rfc3502>] and CATENATE [RFC4469 <http://tools.ietf.org/html/rfc4469>]) MUST NOT be larger than 4096 bytes.

What about ANNOTATE and METADATA, which could potentially be large as well?

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 07 Apr 2015 11:39:17 +0100

Hi Timo,

On 06/04/2015 12:34, Timo Sirainen wrote:
> Hi,
>
> On 09 Mar 2015, at 21:21, Alexey Melnikov <[email-masked] 
> <mailto:[email-masked]>> wrote:
>>
>> I've just posted -03 and 04 (fixed a few things in 03 which I haven't 
>> noticed before posting). The main change to LITERAL- is to allow non 
>> synchronizing literals <= 4096 bytes in APPEND (instead of just 
>> prohibiting them).

I would be happy to apply the same (or different) limit to them as well.