Subject: [imapext] Reveiw - draft-ietf-imapapnd-appendlimit-extension-05

From: Jayantheesh S B <[email-masked]>
Date: Tue, 3 Nov 2015 21:48:41 +0000

Hi All,

We have addressed all the review comments as part of draft-ietf-imapapnd-appendlimit-extension-05.

As well we have discussed all the issues and the solution in detail.  Shall we take this draft to next stage?

Regards,
Jay

---

From: Jamie Nicolson <[email-masked]>
Date: Fri, 6 Nov 2015 10:50:59 -0800

Sounds good to me, thanks Jay.

On Tue, Nov 3, 2015 at 1:48 PM, Jayantheesh S B <[email-masked]>
wrote:

> Hi All,
>
>
>
> We have addressed all the review comments as part of
> draft-ietf-imapapnd-appendlimit-extension-05.
>
>
>
> _______________________________________________
> imapext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/imapext
>
>

---

From: S Moonesamy <[email-masked]>
Date: Wed, 11 Nov 2015 07:32:43 -0800

Hello,
At 13:48 03-11-2015, Jayantheesh S B wrote:
>As well we have discussed all the issues and the solution in 
>detail.  Shall we take this draft to next stage?

I'll comment about the discussion of 
draft-ietf-imapapnd-appendlimit-extension-05 [1].  The following 
comment from Arnt Gulbrandsen caught my attention [2]: "IMO the 
document should answer this particular question".  Arnt was referring 
to the question from Timo Sirainen [3]: "Why implement something that 
going to be a problem in only some very rare cases?"  There was a 
message from Stu Brandt in which he mentioned that there is an 
implementation [4].  There was another comment from Arnt: "Make it 
seem as if the value of the implementation exceeds the effort to 
implement"  [5].  Adrien de Croy mentioned that: "At the moment for 
us appendlimit looks to have negative value overall, and we don't 
plan to implement" [6].  There was a comment from Jayantheesh about 
the using this extension in cases where the user attaches a big file 
and save the mail to their Drafts folder [7].  I view the 
"unnecessary resource usage" in the Introduction Section as a way to 
answer to the question.  Would that convince people to implement this 
extension?

On one hand there is a part of this working group is not convinced 
that it is worthwhile to implement this extension.  On the other 
hand, there is an implementation and another part of this working 
group is okay with the draft.  In my opinion, there is rough 
consensus on this draft.

The next step is for me to do the document shepherd write-up for the 
Area Director.  The Area Director will review and comment about the draft.

Regards,
S. Moonesamy (as imapapdb WG Chair)

1. https://tools.ietf.org/html/draft-ietf-imapapnd-appendlimit-extension-05
2. http://www.ietf.org/mail-archive/web/imapext/current/msg05570.html
3. http://www.ietf.org/mail-archive/web/imapext/current/msg05562.html
4. http://www.ietf.org/mail-archive/web/imapext/current/msg05507.html
5. http://www.ietf.org/mail-archive/web/imapext/current/msg05585.html
6. http://www.ietf.org/mail-archive/web/imapext/current/msg05589.html
7. http://www.ietf.org/mail-archive/web/imapext/current/msg05595.html

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 11 Nov 2015 18:04:43 +0000

On 11/11/2015 15:32, S Moonesamy wrote:
> implement"  [5].  Adrien de Croy mentioned that: "At the moment for us 
> appendlimit looks to have negative value overall, and we don't plan to 
> implement" [6].  There was a comment from Jayantheesh about the using 
> this extension in cases where the user attaches a big file and save 
> the mail to their Drafts folder [7].  I view the "unnecessary resource 
> usage" in the Introduction Section as a way to answer to the 
> question.  Would that convince people to implement this extension?
>
> that it is worthwhile to implement this extension.  On the other hand, 
> there is an implementation and another part of this working group is 
> okay with the draft.  In my opinion, there is rough consensus on this 
> draft.
Agreed. I think we could add a paragraph explaining a bit more how this 
might help IMAP servers (currently the document only talks about 
benefits to IMAP clients) to make the document slightly better, but 
there are enough people who want to implement this extension anyway.

---

From: Jayantheesh S B <[email-masked]>
Date: Wed, 11 Nov 2015 21:39:09 +0000

Hi Alexey,

Thanks for your response. 

As you mentioned, we will add few words about the benefits of IMAP Server as well.

Regards,
Jay
-----Original Message-----
From: Alexey Melnikov [mailto:[email-masked]] 
Sent: Wednesday, November 11, 2015 1:05 PM
To: S Moonesamy; [email-masked]
Cc: Jayantheesh S B; Narendra Singh Bisht
Subject: Re: [imapext] Review - draft-ietf-imapapnd-appendlimit-extension-05

On 11/11/2015 15:32, S Moonesamy wrote:
> usage" in the Introduction Section as a way to answer to the question.  
> Would that convince people to implement this extension?
>
Agreed. I think we could add a paragraph explaining a bit more how this might help IMAP servers (currently the document only talks about benefits to IMAP clients) to make the document slightly better, but there are enough people who want to implement this extension anyway.

---

From: S Moonesamy <[email-masked]>
Date: Thu, 12 Nov 2015 01:00:28 -0800

Hi Jay, Naren
>As you mentioned, we will add few words about the benefits of IMAP 

There is the following text in the Introduction Section of 
draft-ietf-imapapnd-appendlimit-extension-05:

   "This results in unnecessary resource usage.  Especially in the
    mobile device environment, appending mail with huge attachment
    consumes device resources like device battery power and mobile data."

I read that as: this results in unnecessary usage in the mobile 
device environment as it increases the consumption of device battery 
power and mobile data, i.e. it only benefits IMAP clients in a mobile 
environment.

Could you post some text about how the extension might help the IMAP 
server to the mailing list?  The Working Group can then discuss about 
that text and agree on what text to add.

Regards,
S. Moonesamy

---

From: Jayantheesh S B <[email-masked]>
Date: Fri, 13 Nov 2015 20:30:17 +0000

Dear SM,

Please find the updated text below. Kindly review and share your comments.

1. Introduction

Several IMAP server have limitation for mail upload size which is not

published to the email client.  When email client APPEND a mail with

huge attachments, it fails due to size restriction set by the IMAP

server.  This results in unnecessary resource usage.  Especially in the

mobile device environment, appending mail with huge attachment consumes

device resources like device battery power and mobile data.

The IMAP APPENDLIMIT extension provides an ability to advertise maximum

upload size allowed by the IMAP server, so that email client knows the

size limitation beforehand.

This extension provides server admins with the capability to configure the maximum append limit size they will be expecting from the client. By implementing this extension, IMAP server side processing of huge attachments above the available limit from the IMAP client can be avoided to a great extent.

Regards,

Jay

-----Original Message-----
From: imapext [mailto:[email-masked]] On Behalf Of S Moonesamy
Sent: Thursday, November 12, 2015 4:00 AM
To: Jayantheesh S B; Narendra Singh Bisht; [email-masked]
Cc: Alexey Melnikov
Subject: Re: [imapext] Review - draft-ietf-imapapnd-appendlimit-extension-05

Hi Jay, Naren

At 13:39 11-11-2015, Jayantheesh S B wrote:

>As you mentioned, we will add few words about the benefits of IMAP

>Server as well.

I read that as: this results in unnecessary usage in the mobile device environment as it increases the consumption of device battery power and mobile data, i.e. it only benefits IMAP clients in a mobile environment.

Could you post some text about how the extension might help the IMAP server to the mailing list?  The Working Group can then discuss about that text and agree on what text to add.

Regards,

S. Moonesamy

imapext mailing list

[email-masked]<mailto:[email-masked]>

---

From: Alexey Melnikov <[email-masked]>
Date: Sat, 14 Nov 2015 12:20:48 +0000

Hi Jay,

> On 13 Nov 2015, at 20:30, Jayantheesh S B <[email-masked]> wrote:
> 
> Dear SM,
>  

This is an improvement. This doesn't help if the client doesn't support the extension, but in the context of this document this is probably obvious, so doesn't need saying. (I was just wondering whether "the IMAP client" in the last sentence is clear or needs clarifying.)

---

From: Naren <[email-masked]>
Date: Mon, 16 Nov 2015 10:54:46 -0500

Hi Alexey,

Thanks for your review comments.

Please find the updated text below. Kindly review and share your views.

This extension provides server admins with the capability to configure the
maximum append limit size they will be expecting from the client. IMAP
server side processing of huge attachments above the available can be
avoided to a great extent, if this extension is supported at the IMAP
client.

Thanks & Regards

- Naren

On Sat, Nov 14, 2015 at 7:20 AM, Alexey Melnikov <[email-masked]>
wrote:

> This extension provides server admins with the capability to configure the
> maximum append limit size they will be expecting from the client. By
> implementing this extension, IMAP server side processing of huge
> attachments above the available limit from the IMAP client can be avoided
> to a great extent.
>
>
> This is an improvement. This doesn't help if the client doesn't support
> the extension, but in the context of this document this is probably
> obvious, so doesn't need saying. (I was just wondering whether "the IMAP
> client" in the last sentence is clear or needs clarifying.)
>
>
>
> Regards,
>
> Jay
>
> From: imapext [mailto:[email-masked] <[email-masked]>]
> On Behalf Of S Moonesamy
> Subject: Re: [imapext] Review -
> draft-ietf-imapapnd-appendlimit-extension-05
>
>
>
> Hi Jay, Naren
>
> I read that as: this results in unnecessary usage in the mobile device
> environment as it increases the consumption of device battery power and
> mobile data, i.e. it only benefits IMAP clients in a mobile environment.
>
>
>
> server to the mailing list?  The Working Group can then discuss about that
> text and agree on what text to add.
>
>
>
> Regards,
>
> S. Moonesamy
>
>
>

-- 
Thanks & Regards
-Narendra

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 16 Nov 2015 16:50:25 +0000

Hi Naren,

> On 16 Nov 2015, at 15:54, Naren <[email-masked]> wrote:
> 
> Hi Alexey,
> 
>  
> 
> This extension provides server admins with the capability to configure the maximum append limit size they will be expecting from the client. IMAP server side processing of huge attachments above the available can be avoided to a great extent, if this extension is supported at the IMAP client.
> 

I think "is supported by" is mor correct, but otherwise this looks good.
> Thanks & Regards
> 
> - Naren
> 
> 
>> On Sat, Nov 14, 2015 at 7:20 AM, Alexey Melnikov <[email-masked]> wrote:
>> Hi Jay,
>>

---

From: Jayantheesh S B <[email-masked]>
Date: Mon, 16 Nov 2015 16:55:30 +0000

Thanks Alexey.

We will incorporate the command and update the draft.

SM/All,

Kindly share your comments as well.

This extension provides server admins with the capability to configure the maximum append limit size they will be expecting from the client. IMAP server side processing of huge attachments above the available limit can be avoided to a great extent, if this extension is supported by the IMAP client.

Regards,
Jay
From: Alexey Melnikov [mailto:[email-masked]]
Sent: Monday, November 16, 2015 11:50 AM
To: Naren
Cc: Jayantheesh S B; S Moonesamy; [email-masked]
Subject: Re: [imapext] Review - draft-ietf-imapapnd-appendlimit-extension-05

Hi Naren,

On 16 Nov 2015, at 15:54, Naren <[email-masked]<mailto:[email-masked]>> wrote:
Hi Alexey,

Thanks & Regards
- Naren

On Sat, Nov 14, 2015 at 7:20 AM, Alexey Melnikov <[email-masked]<mailto:[email-masked]>> wrote:
Hi Jay,

On 13 Nov 2015, at 20:30, Jayantheesh S B <[email-masked]<mailto:[email-masked]>> wrote:

Dear SM,

1. Introduction

Regards,

Jay

-----Original Message-----
From: imapext [mailto:[email-masked]] On Behalf Of S Moonesamy
Sent: Thursday, November 12, 2015 4:00 AM
To: Jayantheesh S B; Narendra Singh Bisht; [email-masked]<mailto:[email-masked]>
Cc: Alexey Melnikov
Subject: Re: [imapext] Review - draft-ietf-imapapnd-appendlimit-extension-05

Hi Jay, Naren

Regards,

S. Moonesamy

imapext mailing list

---

From: S Moonesamy <[email-masked]>
Date: Mon, 16 Nov 2015 09:39:59 -0800

Hi Naren, Jay,

Alexey, thanks for reviewing the proposed text.

At 08:55 16-11-2015, Jayantheesh S B wrote:
>This extension provides server admins with the capability to 
>configure the maximum append limit size they will be expecting from 
>the client. IMAP server side processing of huge attachments above 
>the available limit can be avoided to a great extent, if this 
>extension is supported by the IMAP client.

I read the text [1] proposed by Jay.  You mentioned that there may be 
a server-side limit for upload size which is not published to the 
email client.  The last paragraph quoted above says that server 
administrator can configure the maximum append limit that he/she is 
expecting from the IMAP client.  This is already possible.  What you 
might be trying to say is that the IMAP server can advertise the 
maximum append size which it will allow for the IMAP client.  Both 
sides, i.e. the IMAP server and the IMAP client, will have to support 
this extension for the feature to work.

The paragraph which Naren suggested is about convincing the server 
side to implement this extension.  It is argued that by supporting 
this extension, IMAP server side processing of huge attachments can be avoided.

How about the following:

   1. Introduction

   The IMAP APPENDLIMIT extension provides an ability to advertise the maximum
   upload size allowed by the IMAP server so that an IMAP client supporting
   this extension knows the size limitation beforehand.  By implementing this
   extension, IMAP server side processing of huge attachments above the maximum
   upload size can be avoided.

Regards,
S. Moonesamy

1. http://www.ietf.org/mail-archive/web/imapext/current/msg05622.html

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 16 Nov 2015 17:47:44 +0000

Hi SM,

On 16/11/2015 17:39, S Moonesamy wrote:
>> the client. IMAP server side processing of huge attachments above the 
>> available limit can be avoided to a great extent, if this extension 
>> is supported by the IMAP client.
>

Yes, I think this read better.

---

From: Jayantheesh S B <[email-masked]>
Date: Mon, 16 Nov 2015 18:00:11 +0000

Hi Alexey/SM,

I have updated the draft with final text as below. I will publish the next version (06) shortly.

1. Introduction

The IMAP APPENDLIMIT extension provides an ability to advertise maximum
upload size allowed by the IMAP server, so that email client knows the
size limitation beforehand. By implementing this extension, IMAP server
side processing of huge attachments above the maximum upload size can
be avoided.

Regards,
Jay
-----Original Message-----
From: Alexey Melnikov [mailto:[email-masked]] 
Sent: Monday, November 16, 2015 12:48 PM
To: S Moonesamy; Jayantheesh S B; Naren
Cc: [email-masked]
Subject: Re: [imapext] Review - draft-ietf-imapapnd-appendlimit-extension-05

Hi SM,