Subject: [IMRG] Measurement tool for bandwidth,one-way delay and loss?

From: Yeggy Easwaran <[email-masked]>
Date: Sat, 31 May 2003 12:23:23 -0700 (PDT)

Hi all.. I am wondering if there is a tool (active or passive) that measures the bandwidth,one-way delay and loss along a link when a connection is established between two computers to transfer data,voice and video between them.I am aware of the existence of pathchar but it is too time-consuming as it is used to estimate per-hop bandwidth, delay, queue time drop rate,etc and I am not really interested in the per-hop metrics and i would just like the entire link metrics.Futhermore, I would like to know if there is any means to discover alternate routes on the internet between the two computers and perhaps reroute the packets along an alternate route that is less lossy/congested or perhaps offers better bandwidth than the default route.I am a novice in the area of internet measurements and would appreciate any help,pointers to documentation & links in this regard. Thanks a bunch

---------------------------------
Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo.

---

From: "Cottrell, Les" <[email-masked]>
Date: Sat, 31 May 2003 14:19:44 -0700

You may want to look at pathrate (to measure path capacity, see http://www.cc.gatech.edu/fac/Constantinos.Dovrolis/pathrate_tutorial.html <http://www.cc.gatech.edu/fac/Constantinos.Dovrolis/pathrate_tutorial.html> ) and pathload to measure available bandwidth.(see http://www.cc.gatech.edu/fac/Constantinos.Dovrolis/bw.html <http://www.cc.gatech.edu/fac/Constantinos.Dovrolis/bw.html> ). Also there is pathchirp (see http://moat.nlanr.net/PAM2003/PAM2003papers/3824.pdf <http://moat.nlanr.net/PAM2003/PAM2003papers/3824.pdf> ). All of these use trains of packets and look at the inter packet delays. They all require a client and server to be installed. To get one way delay usually means needing a GPS at both ends. To get one way loss you may want to use sting (see http://www.cs.washington.edu/homes/savage/sting/ <http://www.cs.washington.edu/homes/savage/sting/> ) it does not require a server to be installed at the remote end. You can also use iperf (see http://dast.nlanr.net/Projects/Iperf/
<http://dast.nlanr.net/Projects/Iperf/> ) or netperf to measure TCP achievable bandwith.  All the above are active tools.  For passive tools you may be able to get access to a router (e.g. on your site or at your boder) running netflow and this would give you the throughput of a flow, or you can use SNMP to read the MIBs and from utilization and capacity can find available bandwidth.  However, you may have difficultly getting the network folks to provide Netflow or SNMP access.

-----Original Message-----
From: Yeggy Easwaran [mailto:[email-masked]] 
Sent: Saturday, May 31, 2003 12:23 PM
To: [email-masked]
Subject: [IMRG] Measurement tool for bandwidth,one-way delay and loss?

Hi all..
 
I am wondering if there is a tool (active or passive) that measures the bandwidth,one-way delay and loss along a link when a connection is established between two computers to transfer data,voice and video between them.
I am aware of the existence of pathchar but it is too time-consuming as it is used to estimate per-hop bandwidth, delay, queue time drop rate,etc and I am not really interested in the per-hop metrics and i would just like the entire link metrics.
Futhermore, I would like to know if there is any means to discover alternate routes on the internet between the two computers and perhaps reroute the packets along an alternate route that is less lossy/congested or perhaps offers better bandwidth than the default route.
I am a novice in the area of internet measurements and would appreciate any help,pointers to documentation & links in this regard.
 
Thanks a bunch

  _____  

Do you Yahoo!?
The New  <http://us.rd.yahoo.com/search/mailsig/*http://search.yahoo.com> Yahoo! Search - Faster. Easier. Bingo.